How to enable IPV6 SLAAC for LAN only

Hi guys,

I am trying to set up a SLAAC based IPV6 address for LAN traffic. I do not have a IPV6 on my WAN interface, for now I just want to set it up on LAN.

Furthermore, I have done the following:

    # cat /etc/config/network
    config globals globals
            option ula_prefix fd00:db80::/48
    
    config interface lan
            option proto    static
            option ip6assign 60
            ...
    # cat /etc/config/dhcp
    config dhcp lan
        option dhcpv6 disabled
        option ra server
        list ra_flags 'none'
        ...

But none of my LAN clients get any IPV6 address other than local-link address, nor am I seeing any router advertisement on Wireshark. Any pointers will be appreciated :slight_smile:

The default configuration advertises SLAAC+DHCP6 on the lan from the ULA prefix. Either revert to defaults or fix the configuration with the proper settings in DHCP

1 Like

Is the DHCP required ? I am testing this with LwIP which doesn't support DHCPV6 properly.

SLAAC is also configured in dhcp config file.

1 Like

Is there something I am missing in this ? The following is the configuration I have on the router

# /etc/config/dhcp

...
config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option ra 'server'
        list ra_flags 'none'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'
        list ra_flags 'none'
...
# /etc/config/network
...
config globals 'globals'
        option ula_prefix 'fd11:ba30:c2df::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0.1'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device
        option name 'eth0.2'
        option macaddr 'xx:xx:xx:xx:xx'

config interface 'wan'
        option device 'eth0.2'
        option proto 'dhcp'
        option ipv6 '0'
        option delegate '0'
...

config interface 'WAN6'
        option device 'eth0.2'
        option proto 'none'

Looks good to me.

then I don't know what's going on here :stuck_out_tongue:

You can always take a backup and reset to defaults. This should work and then you can start restoring the configuration.