How to download older versions of Snapshop-Builds or software packages?

Hello everybody,

I am using a TP-Link Archer C2600 router. Before I installed the latest snapshot-build yesterday, I used an older snapshot-build from february 2019. In LUCI, the following informations was displayed:

Firmware Version: OpenWrt SNAPSHOT r9329-29b69e8 / LuCI Master (git-19.043.27122-eda8f02)
Kernel: 4.14.98

Together with the Snapshot-Build from february, the package "ath10k-firmware-qca99x0-ct" was installed and everything worked fine. Unfortunately, I did not remember the exact package version.

With the newest Snapshot-Build from yesterday installed, I'm facing massive problems with data rate and ping as soon as I am a little further away (about 5 meters) from the router. It makes no difference if I keep my personal settings or reset everything to default while upgrading. I noticed that the package "ath10k-firmware-qca99x0-ct" in version "2019-06-28-7651f5bb-1" is installed here and I found out, that the problems are only there with package "ath10k-firmware-qca99x0-ct". Not with "ath10k-firmware-qca99x0". But I need the advanced features. A little bit frustrating.

Now LUCI is showing the following informations:

Firmware Version: OpenWrt SNAPSHOT r11126-cb289777ca / LuCI Master (git-19.270.39227-355223e)
Kernel: 4.14.146

Now I think that there are two possible solutions and I'm asking for your advice. Either trying to find a older snapshot-build (maybe exactly the old one from february 2019) or installing only a different/older version of the "ath10k-firmware-qca99x0-ct" package in hope that this will solve the problems.


However, the firmware may not be considered a "kmod" (nor have tried the above approach).

If you want to "play around with old versions", building from source would be my suggestion.

The source tree would also indicate the specific version of the CT firmware used for your "good" build.

1 Like

Hello Jeff,

sorry for my late answer and thanks for the idea to building from source. The last days I tried to build old versions. But something I think I'm doing wrong. Maybe your or someone other knows what.

I followed the official Guide:

First I successfully build the newst snapshot version with:
git clone
./scripts/feeds update -a
./scripts/feeds install -a
make menuconfig
make -j 7

For building a older version in searched the git log and found some older commits. With "git reset --hard 9c0c1c44013003616e2f5c55c062430dbda3cce5" i thought it will work. But after checking "menuconfig" and another building-process i figured out, that the kernel and git version in Luci was older, but all packages (including the athk10 ones) was still up-to-date!

Can you guide me which commands I'll need to build an older OpenWRT-Image (for example from commit 9c0c1c44013003616e2f5c55c062430dbda3cce5)?

Without knowing I'm thinking that my issue was:
./scripts/feeds update -a
./scripts/feeds install -a

If I'm not doing these two commands "make" is creating some error massages which are meaning that some dependencies are missing. Also it can happen that the building-process will fail.

Thank you :slight_smile:

You need to reset all local git repos to commits from the same date.
at least

  • main source (in buildenv root)
  • packages in feeds/packages
  • LuCI in feeds/luci

Do not use scripts/feeds update, but manually reset each of them to the correct feed-specific git commit of that date.;a=summary;a=summary;a=summary

Your example 9c0c1c440 seems to be from 18 July 2019, so you should investigate and find the correct feeds-specific commits from that date for each feed (that you use packages from).

(But you may need to use "feeds/scripts install" to adjust the package data after resetting all fedds correctly).

1 Like

Hello hnyman,

thank you for your hint with the other git repos. Next to openwrt, i also cloned luci, packages, telephony and routing, "reset --hard" to a commit near to the commit from openwrt-repo. After that, I created a folder with the name "feeds" in the root-location of "openwrt" and copied the other main folders of the git repos into it.

Before I was able to build I also done the following:

./scripts/feeds update -i (to create missing index-files)
./scripts/feeds install -a (to install all packages)
make menuconfig (to select what i want and what not)
make -j 7 (start the building process)

All worked as expected but unfortunatly I doesn't found my old, 100% working combination for my TP-Link C2600 router.

I was headless to upgrade a snapshot build without making a copy of all things. :expressionless:

How can it be that before the upgrade to a newer Snapshot build a throughput of about 200 Mbit/s (stable) was possible and with newer builds only a maximum of 90 Mbit/s (unstable, ping dropouts) on 5 GHz? On all tests I had the same distance/location to the router.

If I reduced the distance to the router before the upgrade, even over 400 Mbit/s were possible. With newer builds it stays exactly at 90 Mbit/s but it will be more stable. There are no dropouts if I'm right next to the router. But a few meters further on it starts and the throughput is extremely irregular (1 Mbit/s, 20 Mbit/s, 0 Mbit/s, 90 Mbit/s).

Do you have any suggestions or solutions for me?