How to disable tracert?

Hi all !
If you enter the command
cat /proc/sys/kernel/yama/ptrace_scope
then writes
No such file or directory
and the command does not work
sysctl -w kernel.yama.ptrace_scope=3

Can you please tell me how to disable tracert ?

I fail to see the connection between



I don't want my router to respond to trace from wan, but it responds and I don't know how to turn it off, please tell me, version 22.03.3

disable/delete the Allow-Ping rule in the firewall traffic rules.

might need to do the same with Allow-MLD and Allow-ICMP-v6-Input, not sure what the MLD one does, though.

Ping fails, only tracert responds

post the tracert output, only mask public IPs...

1 Like

I disabled icmp, and the tracert command, as I understand it, works on udp ports

the usual standard tracing and as I noticed on some hosts there are asterisks, I want to do the same

earlier it was possible to disable the kernel.yama.ptrace_scope command, but it does not work in the new version, I did not find information on the Internet how to disable it, I decided to contact the specialists here

Change WAN INPUT rule to DROP, not Reject. This should stop it.

1 Like

and how to do it ? I'm not very good at linux

kernel.yama.ptrace_scope is not what you're looking for. It's to do with memory protection.

Can you show a log of what you're trying to stop from happening?


Change first column (Input) to DROP.


Thank you all so much, it helped :slight_smile:

1 Like