How to disable bridge mode?

Several years ago I was able to set up openwrt to properly work, but now when I updated to the latest version I seem to not be able to do it any more. When I do a factory reset with the reset button the settings default to some kind of bridge mode that lets my ISP see my computers and mobile devices, my ISP allows my PC to connect to the internet because it "recognizes" it (probably by its MAC). I originally set the "recognized" MAC onto the router so that it connects to my ISP and then lets all my devices connect to it. But now no matter what I try it either only works as a bridge or doesn't work at all (for example my PC claiming the cable is disconnected) and I have to factory reset it again. Please help! How do I set the default openwrt to work again as it worked before?

ubus call system board

did you reset configuration when upgrading
from which version you upgraded

This doesn't sound like any default configuration I know of. Are you sure you didn't just accidentally plug one of the LAN ports of your router into your internet cable? You should use your WAN port here.

the configuration got reset when I did the factory reset. I think I upgraded from something like 21.02

BusyBox v1.36.1 (2024-03-22 22:09:42 UTC) built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 OpenWrt 23.05.3, r23809-234f1a2efa
 -----------------------------------------------------
root@OpenWrt:~# ubus call system board
{
	"kernel": "5.15.150",
	"hostname": "OpenWrt",
	"system": "MediaTek MT7621 ver:1 eco:3",
	"model": "Edimax RG21S",
	"board_name": "edimax,rg21s",
	"rootfs_type": "squashfs",
	"release": {
		"distribution": "OpenWrt",
		"version": "23.05.3",
		"revision": "r23809-234f1a2efa",
		"target": "ramips/mt7621",
		"description": "OpenWrt 23.05.3 r23809-234f1a2efa"
	}
}

I double checked my wan cable is in the wan port

restore defaults via luci/system/backup-restore-config

then it will be dhcp client towards wan port and 192.168.1.1 and dhcp server towards LAN with nat in the middle.

I did a reset to defaults, it's still the same

Provide a dump of the /etc/config/network default OOTB config.

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix '***::/48'
	option packet_steering '1'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config device
	option name 'lan1'
	option macaddr '***'

config device
	option name 'lan2'
	option macaddr '***'

config device
	option name 'lan3'
	option macaddr '***'

config device
	option name 'lan4'
	option macaddr '***'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config device
	option name 'wan'
	option macaddr '***'

config interface 'wan'
	option device 'wan'
	option proto 'dhcp'

config interface 'wan6'
	option device 'wan'
	option proto 'dhcpv6'

***I redacted the MACs

You wiped ip4 addresses so well that you are your own helper now.

what ip4 addresses?

the blank spaces in your posted picture?

what about them?

I don't have a problem with addresses, I have a problem with the config

Reset the config, then build upon working defaults.

Which is apparently what has been done, but looks like no FW, bit hard to accept at face value or there would be a chorus of unhappy campers; and it ain't the bridge.

The wan IPv4 is important. It should have come from the modem/router and it needs to be outside 192.168.1.0/24.

There may be a few models where the logical eth names do not match the manufacturer's labeling on the case. Check the log as you plug and unplug the wan cable to confirm that it is wan going up and down.

1 Like

yes, it is outside. It's the ip my router got from my ISP's DHCP

I checked the wan cable, it registers as wan in the log and it has always worked in the wan port for years with older openwrt versions

I could try to downgrade to version 22 and then back up to 23, or I could try to install the "factory" version instead of "sysupgrade", but according to this https://openwrt.org/toh/edimax/gemini_rg21s#network_interfaces it appears what I got is the expected default config, I just haven't figured out yet how to set it to work as NAT instead of a bridge

Backup and reset configuration and confirm it nat-s correctly.
Kind of your excess confidence clicking past red box at sysupgrade does not fix itself.

Do not try to install the "factory" build over OpenWrt, it will brick. The factory file is for initial installation only.

1 Like

sorry I don't understand, what should I click where?