How to customize Prefix Delegation?

Hello
I have problem with IPv6 PD , I use RTK , provider sayd what BRAS give IPv6PD , But I very often recive IPv6 and not recive IPv6 PD. In OpenWRT I see what can do delegated prefix customize , but if I write mine prefix , for example 2a01:800:400:200::/56 , I cannot use internet , because command ping -6 google.com simply not recive answers from sites , however If I do ping -6 to IP address from provider - I recive answers , also , If I do ping -6 to my mine prefix - I recive answers. Why so ? What need do for work custom prefix ?
Please , only without as modifed files , say what need do in LUCI interface for fix this problem.

I had a similar issue and it was because of banIP firewall. Maybe you have something similar?
If your ISP is delegating a prefix, then the custom delegated prefix field doesn't need to be filled in. Furthermore, if you are not assigned a static prefix, it is useless.

1 Like

But , why anyway work any pings from tab Diagnostics even not recived or not checking to request PD ? As be for router transfer packets via virtual prefix to IPv6 address? If I link to bridge e.g from PC to High Speed Internet Connection - I'm always recive PD and IPv6. However when I do connect in router via PPPoE - I not always can recive PD. What do not correctly ? Also I see what 18.06.5 more correctly work with IPv6 and IPv6 PD versus 19.07.8 , why ?

no idea, why you experience instable behavior

My experience with PD is that
Request IPv6-prefix of length: auto
is unclear, what „auto“ actually does, it seems you should not assume a „fetch me the best prefix possible“. So far I had to use discrete values and use trial&error&repeat to identify a prefixrequest accepted by the provider.
Also on my ISP, PD only seems to work, when the ISP router is switched to bridge/modemOnly-mode (as I otherwise end up with a /64 assigned to the router, which allows no further delegation).

Please run the following commands (copy-paste the whole block) and paste the output here, using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have

ubus call system board; \
uci export network; \
uci export dhcp; ip6tables-save -c; ifstatus wan6
1 Like
        option vlan '1'
        option ports '0 1 2 3 5t'

package dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        option ednspacket_max '1232'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option ignore '1'
        option dynamicdhcp '0'
        option ra 'hybrid'
        option ra_default '1'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'
        list ra_flags 'home-agent'
        option dhcpv6 'hybrid'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'
        list ra_flags 'none'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

config dhcp 'wan6'
        option interface 'wan6'
        option ra 'relay'
        option dhcpv6 'relay'
        option ndp 'relay'
        option ndproxy_slave '1'
        option ignore '1'
        list ra_flags 'none'

# Generated by ip6tables-save v1.8.7 on Tue Sep 21 00:12:50 2021
*mangle
:PREROUTING ACCEPT [237095:31156202]
:INPUT ACCEPT [62878:5535274]
:FORWARD ACCEPT [164319:23876220]
:OUTPUT ACCEPT [67431:9132609]
:POSTROUTING ACCEPT [216445:31958309]
[9595:719884] -A FORWARD -o pppoe-wan -p tcp -m tcp --tcp-flags SYN,RST SYN -m comment --comment "!fw3: Zone wan MTU fixing" -j TCPMSS --clamp-mss-to-pmtu
[9549:714612] -A FORWARD -i pppoe-wan -p tcp -m tcp --tcp-flags SYN,RST SYN -m comment --comment "!fw3: Zone wan MTU fixing" -j TCPMSS --clamp-mss-to-pmtu
COMMIT
# Completed on Tue Sep 21 00:12:50 2021
# Generated by ip6tables-save v1.8.7 on Tue Sep 21 00:12:50 2021
*filter
:INPUT ACCEPT [179:17184]
:FORWARD DROP [0:0]
:OUTPUT ACCEPT [88:7744]
:forwarding_lan_rule - [0:0]
:forwarding_rule - [0:0]
:forwarding_wan_rule - [0:0]
:input_lan_rule - [0:0]
:input_rule - [0:0]
:input_wan_rule - [0:0]
:output_lan_rule - [0:0]
:output_rule - [0:0]
:output_wan_rule - [0:0]
:reject - [0:0]
:syn_flood - [0:0]
:zone_lan_dest_ACCEPT - [0:0]
:zone_lan_forward - [0:0]
:zone_lan_input - [0:0]
:zone_lan_output - [0:0]
:zone_lan_src_ACCEPT - [0:0]
:zone_wan_dest_ACCEPT - [0:0]
:zone_wan_dest_REJECT - [0:0]
:zone_wan_forward - [0:0]
:zone_wan_input - [0:0]
:zone_wan_output - [0:0]
:zone_wan_src_REJECT - [0:0]
[0:0] -A INPUT -i lo -m comment --comment "!fw3" -j ACCEPT
[62878:5535274] -A INPUT -m comment --comment "!fw3: Custom input rule chain" -j input_rule
[705:62443] -A INPUT -m conntrack --ctstate RELATED,ESTABLISHED -m comment --comment "!fw3" -j ACCEPT
[9:756] -A INPUT -p tcp -m tcp --tcp-flags FIN,SYN,RST,ACK SYN -m comment --comment "!fw3" -j syn_flood
[61873:5444847] -A INPUT -i br-lan -m comment --comment "!fw3" -j zone_lan_input
[121:10800] -A INPUT -i pppoe-wan -m comment --comment "!fw3" -j zone_wan_input
[164319:23876220] -A FORWARD -m comment --comment "!fw3: Custom forwarding rule chain" -j forwarding_rule
[101123:14578792] -A FORWARD -m comment --comment "!fw3: Traffic offloading" -m conntrack --ctstate RELATED,ESTABLISHED -j FLOWOFFLOAD
[101123:14578792] -A FORWARD -m conntrack --ctstate RELATED,ESTABLISHED -m comment --comment "!fw3" -j ACCEPT
[55547:8719221] -A FORWARD -i br-lan -m comment --comment "!fw3" -j zone_lan_forward
[7649:578207] -A FORWARD -i pppoe-wan -m comment --comment "!fw3" -j zone_wan_forward
[7649:578207] -A FORWARD -m comment --comment "!fw3" -j reject
[0:0] -A OUTPUT -o lo -m comment --comment "!fw3" -j ACCEPT
[67431:9132609] -A OUTPUT -m comment --comment "!fw3: Custom output rule chain" -j output_rule
[34279:6042980] -A OUTPUT -m conntrack --ctstate RELATED,ESTABLISHED -m comment --comment "!fw3" -j ACCEPT
[26309:2667890] -A OUTPUT -o br-lan -m comment --comment "!fw3" -j zone_lan_output
[6755:413995] -A OUTPUT -o pppoe-wan -m comment --comment "!fw3" -j zone_wan_output
[7649:578207] -A reject -p tcp -m comment --comment "!fw3" -j REJECT --reject-with tcp-reset
[1:187] -A reject -m comment --comment "!fw3" -j REJECT --reject-with icmp6-port-unreachable
[9:756] -A syn_flood -p tcp -m tcp --tcp-flags FIN,SYN,RST,ACK SYN -m limit --limit 25/sec --limit-burst 50 -m comment --comment "!fw3" -j RETURN
[0:0] -A syn_flood -m comment --comment "!fw3" -j DROP
[26309:2667890] -A zone_lan_dest_ACCEPT -o br-lan -m comment --comment "!fw3" -j ACCEPT
[55547:8719221] -A zone_lan_forward -m comment --comment "!fw3: Custom lan forwarding rule chain" -j forwarding_lan_rule
[55547:8719221] -A zone_lan_forward -m comment --comment "!fw3: Zone lan to wan forwarding policy" -j zone_wan_dest_ACCEPT
[0:0] -A zone_lan_forward -m comment --comment "!fw3" -j zone_lan_dest_ACCEPT
[61873:5444847] -A zone_lan_input -m comment --comment "!fw3: Custom lan input rule chain" -j input_lan_rule
[61873:5444847] -A zone_lan_input -m comment --comment "!fw3" -j zone_lan_src_ACCEPT
[26309:2667890] -A zone_lan_output -m comment --comment "!fw3: Custom lan output rule chain" -j output_lan_rule
[26309:2667890] -A zone_lan_output -m comment --comment "!fw3" -j zone_lan_dest_ACCEPT
[61873:5444847] -A zone_lan_src_ACCEPT -i br-lan -m conntrack --ctstate NEW,UNTRACKED -m comment --comment "!fw3" -j ACCEPT
[7657:472500] -A zone_wan_dest_ACCEPT -o pppoe-wan -m conntrack --ctstate INVALID -m comment --comment "!fw3: Prevent NAT leakage" -j DROP
[54645:8660716] -A zone_wan_dest_ACCEPT -o pppoe-wan -m comment --comment "!fw3" -j ACCEPT
[0:0] -A zone_wan_dest_REJECT -o pppoe-wan -m comment --comment "!fw3" -j reject
[7649:578207] -A zone_wan_forward -m comment --comment "!fw3: Custom wan forwarding rule chain" -j forwarding_wan_rule
[0:0] -A zone_wan_forward -p ipv6-icmp -m icmp6 --icmpv6-type 128 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Forward" -j ACCEPT
[0:0] -A zone_wan_forward -p ipv6-icmp -m icmp6 --icmpv6-type 129 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Forward" -j ACCEPT
[0:0] -A zone_wan_forward -p ipv6-icmp -m icmp6 --icmpv6-type 1 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Forward" -j ACCEPT
[0:0] -A zone_wan_forward -p ipv6-icmp -m icmp6 --icmpv6-type 2 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Forward" -j ACCEPT
[0:0] -A zone_wan_forward -p ipv6-icmp -m icmp6 --icmpv6-type 3 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Forward" -j ACCEPT
[0:0] -A zone_wan_forward -p ipv6-icmp -m icmp6 --icmpv6-type 4/0 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Forward" -j ACCEPT
[0:0] -A zone_wan_forward -p ipv6-icmp -m icmp6 --icmpv6-type 4/1 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Forward" -j ACCEPT
[0:0] -A zone_wan_forward -p esp -m comment --comment "!fw3: Allow-IPSec-ESP" -j zone_lan_dest_ACCEPT
[0:0] -A zone_wan_forward -p udp -m udp --dport 500 -m comment --comment "!fw3: Allow-ISAKMP" -j zone_lan_dest_ACCEPT
[7649:578207] -A zone_wan_forward -m comment --comment "!fw3" -j zone_wan_dest_REJECT
[121:10800] -A zone_wan_input -m comment --comment "!fw3: Custom wan input rule chain" -j input_wan_rule
[1:141] -A zone_wan_input -s fc00::/6 -d fc00::/6 -p udp -m udp --dport 546 -m comment --comment "!fw3: Allow-DHCPv6" -j ACCEPT
[0:0] -A zone_wan_input -s fe80::/10 -p ipv6-icmp -m icmp6 --icmpv6-type 130/0 -m comment --comment "!fw3: Allow-MLD" -j ACCEPT
[0:0] -A zone_wan_input -s fe80::/10 -p ipv6-icmp -m icmp6 --icmpv6-type 131/0 -m comment --comment "!fw3: Allow-MLD" -j ACCEPT
[0:0] -A zone_wan_input -s fe80::/10 -p ipv6-icmp -m icmp6 --icmpv6-type 132/0 -m comment --comment "!fw3: Allow-MLD" -j ACCEPT
[0:0] -A zone_wan_input -s fe80::/10 -p ipv6-icmp -m icmp6 --icmpv6-type 143/0 -m comment --comment "!fw3: Allow-MLD" -j ACCEPT
[0:0] -A zone_wan_input -p ipv6-icmp -m icmp6 --icmpv6-type 128 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Input" -j ACCEPT
[0:0] -A zone_wan_input -p ipv6-icmp -m icmp6 --icmpv6-type 129 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Input" -j ACCEPT
[0:0] -A zone_wan_input -p ipv6-icmp -m icmp6 --icmpv6-type 1 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Input" -j ACCEPT
[0:0] -A zone_wan_input -p ipv6-icmp -m icmp6 --icmpv6-type 2 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Input" -j ACCEPT
[0:0] -A zone_wan_input -p ipv6-icmp -m icmp6 --icmpv6-type 3 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Input" -j ACCEPT
[0:0] -A zone_wan_input -p ipv6-icmp -m icmp6 --icmpv6-type 4/0 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Input" -j ACCEPT
[0:0] -A zone_wan_input -p ipv6-icmp -m icmp6 --icmpv6-type 4/1 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Input" -j ACCEPT
[0:0] -A zone_wan_input -p ipv6-icmp -m icmp6 --icmpv6-type 133 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Input" -j ACCEPT
[0:0] -A zone_wan_input -p ipv6-icmp -m icmp6 --icmpv6-type 135 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Input" -j ACCEPT
[119:10472] -A zone_wan_input -p ipv6-icmp -m icmp6 --icmpv6-type 134 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Input" -j ACCEPT
[0:0] -A zone_wan_input -p ipv6-icmp -m icmp6 --icmpv6-type 136 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Input" -j ACCEPT
[1:187] -A zone_wan_input -m comment --comment "!fw3" -j zone_wan_src_REJECT
[6755:413995] -A zone_wan_output -m comment --comment "!fw3: Custom wan output rule chain" -j output_wan_rule
[6755:413995] -A zone_wan_output -m comment --comment "!fw3" -j zone_wan_dest_ACCEPT
[1:187] -A zone_wan_src_REJECT -i pppoe-wan -m comment --comment "!fw3" -j reject
COMMIT
# Completed on Tue Sep 21 00:12:50 2021
Interface wan6 not found
root@DIR-825:~#

But if now work , at next time this can not workin. Settings not modify.

The output from the first 2 commands and half of the third is missing.

1 Like

I'm user Windows , in what me can do your you asking ? I'm use Putty , how replace?

Now like be have all.

=~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2021.09.21 16:27:32 =~=~=~=~=~=~=~=~=~=~=~=
login as: root
root@192.168.16.1's password: 


BusyBox v1.33.1 (2021-08-31 22:20:08 UTC) built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 OpenWrt 21.02.0, r16279-5cc0535800
 -----------------------------------------------------
e]0;root@DIR-825: ~aroot@DIR-825:~# ubus call system board; \
> uci export network; \
> uci export dhcp; ip6tables-save -c; ifstatus wan6
{
	"kernel": "5.4.143",
	"hostname": "DIR-825",
	"system": "Atheros AR7161 rev 2",
	"model": "D-Link DIR825B1",
	"board_name": "dlink,dir-825-b1",
	"release": {
		"distribution": "OpenWrt",
		"version": "21.02.0",
		"revision": "r16279-5cc0535800",
		"target": "ath79/generic",
		"description": "OpenWrt 21.02.0 r16279-5cc0535800"
	}
}
package network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd9f:857d:77cc::/48'

config device
	option name 'eth1'
	option macaddr '00:18:e7:8c:b7:0c'

config interface 'wan'
	option device 'eth1'
	option proto 'pppoe'
	option username 'removed'
	option password 'removed'
	option force_link '1'
	option ipv6 'auto'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0.1'

config device
	option name 'eth0.1'
	option macaddr '00:18:e7:8c:b7:0b'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.16.1'
	option delegate '0'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 3 5t'

package dhcp

config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option filterwin2k '0'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option nonegcache '0'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
	option nonwildcard '1'
	option localservice '1'
	option ednspacket_max '1232'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv4 'server'
	option ignore '1'
	option dynamicdhcp '0'
	option ra 'hybrid'
	option ra_default '1'
	list ra_flags 'managed-config'
	list ra_flags 'other-config'
	list ra_flags 'home-agent'
	option dhcpv6 'hybrid'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'
	list ra_flags 'none'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

config dhcp 'wan6'
	option interface 'wan6'
	option ra 'relay'
	option dhcpv6 'relay'
	option ndp 'relay'
	option ndproxy_slave '1'
	option ignore '1'
	list ra_flags 'none'

# Generated by ip6tables-save v1.8.7 on Tue Sep 21 14:27:52 2021
*mangle
:PREROUTING ACCEPT [348781:47386640]
:INPUT ACCEPT [86589:7532093]
:FORWARD ACCEPT [245225:36766518]
:OUTPUT ACCEPT [95222:12487550]
:POSTROUTING ACCEPT [313333:47397238]
[12945:978152] -A FORWARD -o pppoe-wan -p tcp -m tcp --tcp-flags SYN,RST SYN -m comment --comment "!fw3: Zone wan MTU fixing" -j TCPMSS --clamp-mss-to-pmtu
[12877:970696] -A FORWARD -i pppoe-wan -p tcp -m tcp --tcp-flags SYN,RST SYN -m comment --comment "!fw3: Zone wan MTU fixing" -j TCPMSS --clamp-mss-to-pmtu
COMMIT
# Completed on Tue Sep 21 14:27:52 2021
# Generated by ip6tables-save v1.8.7 on Tue Sep 21 14:27:52 2021
*filter
:INPUT ACCEPT [306:29376]
:FORWARD DROP [0:0]
:OUTPUT ACCEPT [88:7744]
:forwarding_lan_rule - [0:0]
:forwarding_rule - [0:0]
:forwarding_wan_rule - [0:0]
:input_lan_rule - [0:0]
:input_rule - [0:0]
:input_wan_rule - [0:0]
:output_lan_rule - [0:0]
:output_rule - [0:0]
:output_wan_rule - [0:0]
:reject - [0:0]
:syn_flood - [0:0]
:zone_lan_dest_ACCEPT - [0:0]
:zone_lan_forward - [0:0]
:zone_lan_input - [0:0]
:zone_lan_output - [0:0]
:zone_lan_src_ACCEPT - [0:0]
:zone_wan_dest_ACCEPT - [0:0]
:zone_wan_dest_REJECT - [0:0]
:zone_wan_forward - [0:0]
:zone_wan_input - [0:0]
:zone_wan_output - [0:0]
:zone_wan_src_REJECT - [0:0]
[0:0] -A INPUT -i lo -m comment --comment "!fw3" -j ACCEPT
[86589:7532093] -A INPUT -m comment --comment "!fw3: Custom input rule chain" -j input_rule
[1213:108172] -A INPUT -m conntrack --ctstate RELATED,ESTABLISHED -m comment --comment "!fw3" -j ACCEPT
[10:840] -A INPUT -p tcp -m tcp --tcp-flags FIN,SYN,RST,ACK SYN -m comment --comment "!fw3" -j syn_flood
[84862:7375937] -A INPUT -i br-lan -m comment --comment "!fw3" -j zone_lan_input
[208:18608] -A INPUT -i pppoe-wan -m comment --comment "!fw3" -j zone_wan_input
[245225:36766518] -A FORWARD -m comment --comment "!fw3: Custom forwarding rule chain" -j forwarding_rule
[145965:21743300] -A FORWARD -m comment --comment "!fw3: Traffic offloading" -m conntrack --ctstate RELATED,ESTABLISHED -j FLOWOFFLOAD
[145965:21743300] -A FORWARD -m conntrack --ctstate RELATED,ESTABLISHED -m comment --comment "!fw3" -j ACCEPT
[86019:14026537] -A FORWARD -i br-lan -m comment --comment "!fw3" -j zone_lan_forward
[13241:996681] -A FORWARD -i pppoe-wan -m comment --comment "!fw3" -j zone_wan_forward
[13241:996681] -A FORWARD -m comment --comment "!fw3" -j reject
[0:0] -A OUTPUT -o lo -m comment --comment "!fw3" -j ACCEPT
[95222:12487550] -A OUTPUT -m comment --comment "!fw3: Custom output rule chain" -j output_rule
[45475:8026628] -A OUTPUT -m conntrack --ctstate RELATED,ESTABLISHED -m comment --comment "!fw3" -j ACCEPT
[37739:3722964] -A OUTPUT -o br-lan -m comment --comment "!fw3" -j zone_lan_output
[11920:730214] -A OUTPUT -o pppoe-wan -m comment --comment "!fw3" -j zone_wan_output
[13241:996681] -A reject -p tcp -m comment --comment "!fw3" -j REJECT --reject-with tcp-reset
[2:374] -A reject -m comment --comment "!fw3" -j REJECT --reject-with icmp6-port-unreachable
[10:840] -A syn_flood -p tcp -m tcp --tcp-flags FIN,SYN,RST,ACK SYN -m limit --limit 25/sec --limit-burst 50 -m comment --comment "!fw3" -j RETURN
[0:0] -A syn_flood -m comment --comment "!fw3" -j DROP
[37739:3722964] -A zone_lan_dest_ACCEPT -o br-lan -m comment --comment "!fw3" -j ACCEPT
[86019:14026537] -A zone_lan_forward -m comment --comment "!fw3: Custom lan forwarding rule chain" -j forwarding_lan_rule
[86019:14026537] -A zone_lan_forward -m comment --comment "!fw3: Zone lan to wan forwarding policy" -j zone_wan_dest_ACCEPT
[0:0] -A zone_lan_forward -m comment --comment "!fw3" -j zone_lan_dest_ACCEPT
[84862:7375937] -A zone_lan_input -m comment --comment "!fw3: Custom lan input rule chain" -j input_lan_rule
[84862:7375937] -A zone_lan_input -m comment --comment "!fw3" -j zone_lan_src_ACCEPT
[37739:3722964] -A zone_lan_output -m comment --comment "!fw3: Custom lan output rule chain" -j output_lan_rule
[37739:3722964] -A zone_lan_output -m comment --comment "!fw3" -j zone_lan_dest_ACCEPT
[84862:7375937] -A zone_lan_src_ACCEPT -i br-lan -m conntrack --ctstate NEW,UNTRACKED -m comment --comment "!fw3" -j ACCEPT
[13875:860523] -A zone_wan_dest_ACCEPT -o pppoe-wan -m conntrack --ctstate INVALID -m comment --comment "!fw3: Prevent NAT leakage" -j DROP
[84064:13896228] -A zone_wan_dest_ACCEPT -o pppoe-wan -m comment --comment "!fw3" -j ACCEPT
[0:0] -A zone_wan_dest_REJECT -o pppoe-wan -m comment --comment "!fw3" -j reject
[13241:996681] -A zone_wan_forward -m comment --comment "!fw3: Custom wan forwarding rule chain" -j forwarding_wan_rule
[0:0] -A zone_wan_forward -p ipv6-icmp -m icmp6 --icmpv6-type 128 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Forward" -j ACCEPT
[0:0] -A zone_wan_forward -p ipv6-icmp -m icmp6 --icmpv6-type 129 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Forward" -j ACCEPT
[0:0] -A zone_wan_forward -p ipv6-icmp -m icmp6 --icmpv6-type 1 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Forward" -j ACCEPT
[0:0] -A zone_wan_forward -p ipv6-icmp -m icmp6 --icmpv6-type 2 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Forward" -j ACCEPT
[0:0] -A zone_wan_forward -p ipv6-icmp -m icmp6 --icmpv6-type 3 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Forward" -j ACCEPT
[0:0] -A zone_wan_forward -p ipv6-icmp -m icmp6 --icmpv6-type 4/0 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Forward" -j ACCEPT
[0:0] -A zone_wan_forward -p ipv6-icmp -m icmp6 --icmpv6-type 4/1 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Forward" -j ACCEPT
[0:0] -A zone_wan_forward -p esp -m comment --comment "!fw3: Allow-IPSec-ESP" -j zone_lan_dest_ACCEPT
[0:0] -A zone_wan_forward -p udp -m udp --dport 500 -m comment --comment "!fw3: Allow-ISAKMP" -j zone_lan_dest_ACCEPT
[13241:996681] -A zone_wan_forward -m comment --comment "!fw3" -j zone_wan_dest_REJECT
[208:18608] -A zone_wan_input -m comment --comment "!fw3: Custom wan input rule chain" -j input_wan_rule
[2:282] -A zone_wan_input -s fc00::/6 -d fc00::/6 -p udp -m udp --dport 546 -m comment --comment "!fw3: Allow-DHCPv6" -j ACCEPT
[0:0] -A zone_wan_input -s fe80::/10 -p ipv6-icmp -m icmp6 --icmpv6-type 130/0 -m comment --comment "!fw3: Allow-MLD" -j ACCEPT
[0:0] -A zone_wan_input -s fe80::/10 -p ipv6-icmp -m icmp6 --icmpv6-type 131/0 -m comment --comment "!fw3: Allow-MLD" -j ACCEPT
[0:0] -A zone_wan_input -s fe80::/10 -p ipv6-icmp -m icmp6 --icmpv6-type 132/0 -m comment --comment "!fw3: Allow-MLD" -j ACCEPT
[0:0] -A zone_wan_input -s fe80::/10 -p ipv6-icmp -m icmp6 --icmpv6-type 143/0 -m comment --comment "!fw3: Allow-MLD" -j ACCEPT
[0:0] -A zone_wan_input -p ipv6-icmp -m icmp6 --icmpv6-type 128 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Input" -j ACCEPT
[0:0] -A zone_wan_input -p ipv6-icmp -m icmp6 --icmpv6-type 129 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Input" -j ACCEPT
[0:0] -A zone_wan_input -p ipv6-icmp -m icmp6 --icmpv6-type 1 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Input" -j ACCEPT
[0:0] -A zone_wan_input -p ipv6-icmp -m icmp6 --icmpv6-type 2 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Input" -j ACCEPT
[0:0] -A zone_wan_input -p ipv6-icmp -m icmp6 --icmpv6-type 3 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Input" -j ACCEPT
[0:0] -A zone_wan_input -p ipv6-icmp -m icmp6 --icmpv6-type 4/0 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Input" -j ACCEPT
[0:0] -A zone_wan_input -p ipv6-icmp -m icmp6 --icmpv6-type 4/1 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Input" -j ACCEPT
[0:0] -A zone_wan_input -p ipv6-icmp -m icmp6 --icmpv6-type 133 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Input" -j ACCEPT
[0:0] -A zone_wan_input -p ipv6-icmp -m icmp6 --icmpv6-type 135 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Input" -j ACCEPT
[204:17952] -A zone_wan_input -p ipv6-icmp -m icmp6 --icmpv6-type 134 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Input" -j ACCEPT
[0:0] -A zone_wan_input -p ipv6-icmp -m icmp6 --icmpv6-type 136 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Input" -j ACCEPT
[2:374] -A zone_wan_input -m comment --comment "!fw3" -j zone_wan_src_REJECT
[11920:730214] -A zone_wan_output -m comment --comment "!fw3: Custom wan output rule chain" -j output_wan_rule
[11920:730214] -A zone_wan_output -m comment --comment "!fw3" -j zone_wan_dest_ACCEPT
[2:374] -A zone_wan_src_REJECT -i pppoe-wan -m comment --comment "!fw3" -j reject
COMMIT
# Completed on Tue Sep 21 14:27:52 2021
Interface wan6 not found
e]0;root@DIR-825: ~aroot@DIR-825:~# 

on first two comnands not output

No, you ran them properly. One more that was not properly written before: ifstatus wan_6; ifstatus lan

1 Like

You understanding what I can not and I not want to show for all people mine IPv6 address ) , therefore I hide more part of IPv6 address.

=~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2021.09.22 00:27:51 =~=~=~=~=~=~=~=~=~=~=~=
login as: root
root@192.168.16.1's password: 


BusyBox v1.33.1 (2021-08-31 22:20:08 UTC) built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 OpenWrt 21.02.0, r16279-5cc0535800
 -----------------------------------------------------
e]0;root@DIR-825: ~aroot@DIR-825:~# before: ifstatus wan_6; ifstatus lan
-ash: before:: not found
{
	"up": true,
	"pending": false,
	"available": true,
	"autostart": true,
	"dynamic": false,
	"uptime": 152305,
	"l3_device": "br-lan",
	"proto": "static",
	"device": "br-lan",
	"updated": [
		"addresses"
	],
	"metric": 0,
	"dns_metric": 0,
	"delegation": false,
	"ipv4-address": [
		{
			"address": "192.168.16.1",
			"mask": 24
		}
	],
	"ipv6-address": [
		
	],
	"ipv6-prefix": [
		
	],
	"ipv6-prefix-assignment": [
		{
			"address": "2a01:xxx:xxxx:xxxx::",
			"mask": 60,
			"preferred": 64169,
			"valid": 64169,
			"local-address": {
				"address": "2a01:xxx:xxxx:xxxx::1",
				"mask": 60
			}
		},
		{
			"address": "fd9f:857d:77cc::",
			"mask": 60,
			"local-address": {
				"address": "fd9f:857d:77cc::1",
				"mask": 60
			}
		}
	],
	"route": [
		
	],
	"dns-server": [
		
	],
	"dns-search": [
		
	],
	"neighbors": [
		
	],
	"inactive": {
		"ipv4-address": [
			
		],
		"ipv6-address": [
			
		],
		"route": [
			
		],
		"dns-server": [
			
		],
		"dns-search": [
			
		],
		"neighbors": [
			
		]
	},
	"data": {
		
	}
}
e]0;root@DIR-825: ~aroot@DIR-825:~# 

You didn't paste it properly and the ifstatus wan_6 was not executed, but it is visible from the output of the lan that a /60 prefix is delegated to it.
I am still not sure where exactly lies the problem you are facing, as everything is correct here. Maybe you could post the output of the previous commands when you face the issue.

1 Like

You not right , because you see Prefix Delegation /60 per LAN , but you not see PD from ISP , from ISP /56 and this work not stable , not looking what BRAS issues PD , Router can recive , and can not recive PD from BRAS. As I show this to you ?

Alright, then post the ifstatus wan_6
However a /56 from the ISP is normal. And delegating a /60 to the lan is enough.







What need ?

One missing thing is to assign the wan_6 interface in wan firewall zone. Other than that I don't see any other problem.
What problem are you facing?

If I create WAN6 interface as separate and will appoint Alias of WAN , next add to Firewall zone , I will have so as now , problem not fixed and add new problem , I recive stable problem with recive IPv6 PD from @wan6. As me need set connections ?

You cannot have both wan6 and wan_6.

I know , but If I create Alias of wan for WAN6 and appoint in WAN as on screenshot , problem not fixed.