How to create a Bridge between Modem and Router

i need help creating a Bridge between Modem and Router to rule out the possible issue in this thread here: https://forum.openwrt.org/t/sqm-struggle-continues/67751/14

My current setup and hardware:

Modem: CM1000 modem
Router: Linksys WRT3200ACM
ISP: Comcast/Xfinty

how things are setup as of right now:
   `config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fdab:bbcc:401e::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option ifname 'eth1.2'
	option proto 'dhcp'

config interface 'wan6'
	option ifname 'eth1.2'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 3 5t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '4 6t'`

I couldn't find much information or tutorials on this, hopefully someone will help. Thanks

So from one of your posts, I assumed double NAT/SQM-bypass, but now I am not so sure anymore. Looking at the CM1000 manual it seems this device only has a single ethernet port and no wifi at all. So if you connected that DOCSIS-modem to your WRT3200ACM's WAN port there is no real possibility for a bypass, and according to https://openwrt.org/toh/linksys/linksys_wrt3200acm your switch configuration seems to be okay.

Which version of OpenWrt do you have installed and what is the output of:
ifstatus wan
(log in via ssh issue that command above and copy and past the result here)

"So if you connected that DOCSIS-modem to your WRT3200ACM's WAN port there is no real possibility for a bypass"

i believe that is exactly how it's setup, so there are no other way to create this Bridge or get rid of the Double NAT? i also need to run the WIFI as well for other devices. i will post the requested information when i get home from work. thanks

Let's first make 100% sure you actually see double NAT to begin with, please post the output of:
ifstatus wan
as well as the IP address returned from e.g. browsing over to https://whatismyipaddress.com?

root@OpenWrt:~# ifstatus wan
{
        "up": true,
        "pending": false,
        "available": true,
        "autostart": true,
        "dynamic": false,
        "uptime": 82,
        "l3_device": "eth1.2",
        "proto": "dhcp",
        "device": "eth1.2",
        "updated": [
                "addresses",
                "routes",
                "data"
        ],
        "metric": 0,
        "dns_metric": 0,
        "delegation": true,
        "ipv4-address": [
                {
                        "address": "73.52.188.127",
                        "mask": 22
                }
        ],
        "ipv6-address": [

        ],
        "ipv6-prefix": [

        ],
        "ipv6-prefix-assignment": [

        ],
        "route": [
                {
                        "target": "0.0.0.0",
                        "mask": 0,
                        "nexthop": "73.52.188.1",
                        "source": "73.52.188.127/32"
                }
        ],
        "dns-server": [
                "75.75.75.75",
                "75.75.76.76"
        ],
        "dns-search": [
                "hsd1.ut.comcast.net."
        ],
        "neighbors": [

        ],
        "inactive": {
                "ipv4-address": [

                ],
                "ipv6-address": [

                ],
                "route": [

                ],
                "dns-server": [

                ],
                "dns-search": [

                ],
                "neighbors": [

                ]
        },
        "data": {
                "hostname": "OpenWrt",
                "leasetime": 196053
        }
}

My IP Address Is:
IPv6: 2601:681:8700:27e:943a:1d6:eae1:81e4
IPv4: 73.52.188.127

This is a publicly routed IPv4 address from comcast, this is indication that double NAT is not your issue... it also fits to the description of your CM1000 modem. So that means that this topic is "solved"/moot as your modem is already in bridged mode.
That still leaves your SQM issues open, though.

1 Like