How to configure VLANS?

I would like to extend my wi-fi coverage in my house. There are two wireless networks: the first is a private and the second is a guest network. I have an old TP-Link WR841N router, which can be used as an auxiliary router to repeat Wi-Fi signals. The main router is a TP-Link WR1043ND.

I tried to follow OneMarcFifty's video. This is very clear and detailed. However I always get stucked, when wi-fi networks assigned to VLANs (from 5:28 in the video).

It seems that DSA messed up a lot of things. My router is based on the ath79 target, which is not supported (yet) by DSA, so I have to use swconfig.

In the video, it is necessary to navigate Interfaces >> LAN >> Physical settings tab but this tab is missing. I know that it has been reorganized a few months ago (I use 21.02, however in the video 19.07 is used), but I can't understand the new method.

Is there anybody who can tell me how to configure VLAN (or how to complete this step)?

There were two major changes: Bridges are now separate, and DSA. Ath79 so far only implements the bridge change.

To build out a new bridged network for guests, do these steps in order.

  1. In Network->Switch, add a VLAN to the switch. Make it tagged on the interconnect (trunk) cable and the CPU. Also change VLAN 1 (the existing LAN) to tagged on the trunk cable.
  2. Go to Network->Interfaces and click the Devices tab. Click the green Add button on the left at the bottom of the list. Select type Bridge Device. Assign a name such as br-guest. Choose the eth0.X VLAN as the device, matching the VLAN number you used in step 1.
  3. Click the Interfaces tab to get back to the interfaces. Click the Add button. On the main router, the new guest interface will be protocol Static address (setting the guest IP, DHCP and firewall also needs to be done, this is the same process as in old guides). On the dumb AP, the guest interface will be protocol Unmanaged. Use the same name without br- as the name. Choose your br-guest as the device.
  4. Add wifi APs. Select guest as the network.
  • Note that the blue WAN port on a WR841 is a direct line to a separate CPU port, it does not go through the switch. If you're going to use that port as the trunk, skip step 1 and use eth0.N in step 2. (I think it is eth0 it may be eth1). Also edit the wan to remove that port, and edit the lan bridge to add it with a tag of 1.
1 Like

Hi,
Thank you for your answer. Unfortunately I can't complete step 3. I created VLAN to the switch, and I set up a bridge device, br-guest. However if I assign br-guest to the GUEST interface, I lose my internet connection and I can't reach my router on WIRED connection (wi-fi still works).

Notice: GUEST interface already created a few months ago to be able to use guest wi-fi on my main router. It works perfectly.

Switch:

Please note that CPU eth0 and eth1 is swapped here, because eth1 is assigned to LAN and not to WAN and eth0 is assigned to WAN and not to LAN, so I had to create VLANs from 3, attaching them to the eth1.x sub-interfaces.

Interfaces >> Devices:

br-guest:

Interfaces overview:

Interfaces >> GUEST:

I can't figure out what cause the problem... It would be appreciated if you could help me.