How to configure Internet connection for DHCPVLAN

I am a new LEDE user. I have a TP-Link Archer C7 V2 router and have installed LEDE Reboot 17.01.4 / LuCI lede-17.01 branch. My ISP is Vodafone New Zealand FibreX, which uses Vlan Tagging with an VLAN Tagging ID of 10.

When using the TP-Link firmware I needed to select the internet protocol "Dynamic IP", but in LEDE I think the the correct option is DHCP but with VLAN tagging enabled. I am not sure how or where I go to input the WAN IP address, subnet mask and default Gateway. Many thanks for advice.When I go to "interfaces" I see there are a WAN and WAN6 port. Obviously, my router has only Blue WAN port, so I'm a bit confused (I'm a bit ignorant about routers).

Vodafone requires a VLAN Tagging ID of 10. I'd prefer to use the GUI to set this up. Many thanks!

In the switch configuration, change the VLAN number of the one containing the WAN port from 2 to 10. Then change the port from untagged to tagged. Leave the CPU port untagged.

Thanks for your response. I managed to get the internet working, but can no longer access via browser. Tried doing a reset on the router with the rest button ... does not reset. Tried using PuTTy with on Port 22, get "Network error: No route to host".

I set up the router with static ip and VLAN tagging as you described above.

I had to reset the firmware after booting into failsafe mode. So I am now not sure which protocol to use with Vodafone FibreX. In the TP-Link firmware I chose "Dynamic IP" and enable Vlan tagging. In LEDE I tried DHCP with VLAN tagging enable to WAN, but get no internet. When set to static IP, and with the ISPs IP, Subnet and Default Gateway specified by me, I get an internet connection but get the ISPs IP address assigned to my PC instead of something like Then, of course, I cannot access

Sounds like the problem was a mistake in the VLAN config... should be pretty simple. If you post your /etc/config/network file, I think it will be possible to recommend the correct modifications. (alternatively, if you are using the LuCI web interface, post a screen grab of the switch config page.)

Thanks psherman for your offer of help. I rebooted the router and it is now working perfectly. Very happy.