How to asign WAN port to to normal LAN?


#1

Hello,have router wich is working as DUMB AP and i need asign WAN port to normal LAN,tp-link wr843ND and LEDE version 17.0.1,before this device standing just ordinary simple switch,i need this,because not working ping,tracert,dhcp is disabled,so where i made mistake?maybe something need to do in firewall settings or in network->vlan ?


#2

You do not need to assign WAN to LAN for a dumb AP to work (I would even suggest to reserve the WAN port as an emergency port). Post your config files here, please.


#3

The 4 LAN ports should already work as LAN. If not, something else is wrong. Reconfiguring the WAN port just gives you 5 usable ports instead of 4.

Move eth0 into the LAN bridge. (network --> Interfaces, click on edit LAN, click physical settings). Then remove it from the WAN network the same way. On a dumb AP you can delete the WAN network entirely if you want, or leave it there with nothing connected.


#4

@mk24 @eduperez you both right and yes for me need do 5 lan"s instead 4,but i wanna keep DUMB AP :smile: switch
And i need do something here?lan


#5

Check the eth0 box in the LAN physical settings. You want both Ethernet ports and your WiFi all in the bridge.

And go to WAN physical settings and detach eth0 from there, or delete the WAN network entirely. In a dumb AP, there is only one active network-- lan.

The blue "WAN" port on the back of the router does not go through the switch. It has a direct connection to the CPU as eth0. The other ports come from eth1 and go through the switch. So what you do is bridge the two CPU ports in the kernel.


#6

well what i need is that blue WAN port can work as yellow LAN,in other words this device i wanna turn to switch :slight_smile:


#7

That is exactly what @mk24 just described how to do.

Just bear in mind that it will be best to connect whichever device will use the least bandwidth to that blue port as it will be bridged/switched using the CPU so "might" slow down WiFi performance if that device is pulling a lot of bandwidth.


#8

well thank you all to tried for help me :slight_smile:


#9

What do you mean "tried"? It should work fine.


#10

worked,but now i"m stuck with dd-wrt on this device.:thinking::neutral_face:


#11

The WiFi work better on DD-WRT or something?


#12

noup,and mine mistake,because dd-wrt glitching as hell,now looking way back to LEDE.


#13

little top-up theme,because still wan not working as regular LAN port,i mean that dont have switch+wifiAP and diagnostics not working,so what to adjust in Firewall settings? :slight_smile:


#14

Read again what I wrote before. It still applies. All you need to do is move eth0 into the LAN network bridge. eth0 is a direct connection to the blue port on the back of the router.
The firewall and the switch don't have anything to do with this. The switch is only involved with eth1 and the four yellow "LAN" ports. eth1 is already in the LAN bridge, and the switch simply switches eth1 out to all 4 ports equally.


#15

dont get it what doing wrong interfaceslanwan


#16

Delete WAN6 just to be sure its not interfering.


#17

WAN6 deleted,but Diagnostics not working :smiley:


#18

Have you set the gateway and DNS servers for LAN, or is it set to DHCP Client?

For a bridge/switch/AP to work it doesn't matter, but the box will have no access to the Internet if it doesn't know how to get there. :wink:


#19

well dhcp are disabled,but you mentioned gateway and dns are not set :smiley:


#20

How are you colleagues?

I was also curious to have WAN as LAN and I was able to do what they shared in this forum, I will detail the steps.
For this I have a DHCP server on the PC

  1. With the DHCP server of the PC deactivated, I connected to the LAN, it has IP Static and I put it in DHCP CLient, then click on Switch Protocol, Save and Apply.
  2. I connected by cable to the LAN with the DHCP server of the PC activated, I entered the LAN interface, Physical Settings, I marked eth1 (WAN), Save and Apply.
  3. Enter WAN to edit it, Physical Settings, mark Creates to bridge over specified interface (s) and uncheck eth1 (LAN, WAN), SAVE and Apply.

Ready, that was it.

WAN%20to%20LAN