How to add second client to WWAN interface?

The openwrt-22.03 is connected to "internet router 1" by wifi as a client. It work perfectly.

Now I try to connect to other wifi network by "internet router 2". Add new network, set SSID etc. Internet is connected.

But WWAN interface show Error: Network device is not present. And router with openwrt does not give internet through wifi as a master.
I check manual but did not see my case.

Please give me advice how to add second client?

First working router
interface WWAN router 1


Second router
interface WWAN router 2


Try this:

Thank you for the link!
As I see this article is about making extender/repeater/bridge.
My problem is simplier. I don't need to create a mesh network.

There is the router1 which give internet through wifi to router with openWrt.
I need to set up connection to the router2 as a reserve canal when the router1 will be not available.
For simulate this situation I disable wireless connection to the router1 and enable wireless connection to the router2 into openWrt UI.

I don't understand why WWAN interface does not connect to network device (router2) even this device was selected manually.

It almost never works to simultaneously run two clients on the same radio. At the very least, the two APs would need to be on the same channel, and you can't control that.

The travelmate package can be used to have two clients configured and it will automatically select one based on a priority scheme. If the primary AP goes off the air, the other client will be enabled.

To solve the problem, it is enough to define two clients (connect to router1 / router2) that must be switched manually.
Automatic activation is not required. I expect that when the client is turned on, it will be determined in the WWAN.
For router1 it works - Wireless Adapter interface showed connect to Device: Client "router1"

When I switch off router1 and switch on router2 - got Error: Network device is not present. At the same time the Wireless Overview shows that the connection to router2 was successfully established.

Then just click the Disable button on the one that you're not using.

Travelmate automates that process, and will also disable both of them if neither AP is found. That is useful since any APs configured on the same radio go off the air until the STA is able to link up with its AP.

They should both be set to the same network such as wwan.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.