How to activate 4G roaming on TL-MR6400

Hi,

today I set up my new TL-MR6400 Ver 5.30 with OpenWRT 23.05

Everything is working fine. I also managed to get the 4G Modem up an running.

I´m based in Germany but work in Switzerland. So I have a swiss 4G SIM card with roaming.

But I did not manage to set Roming "on", so I can use this SIM also in Germany (40GB roaming Data in Contract included).
When I use a German SIM instead, the Router and the 4G works fine (in Germany)

I tried uqmi -d /dev/cdc-wdm0 --set-network-roaming any but it did not work.

I was not able to use an terminal to set AT commandy because the modem seems not to be USB connected so I can´t access it via serial terminal.

This is the output of some diagnostic:

root@OpenWrt:~# uqmi -d /dev/cdc-wdm0 --get-serving-system
{
        "registration": "registered",
        "plmn_mcc": 262,
        "plmn_mnc": 2,
        "plmn_description": "▒79l~▒▒.r\u0019",
        "roaming": true
}
root@OpenWrt:~# uqmi -d /dev/cdc-wdm0 --get-signal-info
{
        "type": "lte",
        "rssi": -72,
        "rsrq": -7,
        "rsrp": -101,
        "snr": 18.600000
}
root@OpenWrt:~# uqmi -d /dev/cdc-wdm0 --get-data-status
"connected"


root@OpenWrt:~# cat /etc/config/network
.
.
.
config interface 'Sunriseinternet'
        option proto 'qmi'
        option device '/dev/cdc-wdm0'
        option auth 'none'
        option pdptype 'ipv4'
        option apn 'internet'



ifconfig
wwan0     Link encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
          inet addr:10.57.38.38  P-t-P:10.57.38.38  Mask:255.255.255.252
          inet6 addr: fe80::bf4c:671d:bd39:593d/64 Scope:Link
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1500  Metric:1
          RX packets:2 errors:0 dropped:0 overruns:0 frame:0
          TX packets:7579 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:630 (630.0 B)  TX bytes:679441 (663.5 KiB)


ls -al /dev/ttyUSB*
ls: /dev/ttyUSB*: No such file or directory

I hope someone can help me to set up roaming so I can use this Router in my Camper on vacation.

Cheers

Udo

The output you provided shows that the modem is registered, connected, etc. in roaming.
What is the problem?

The Problem is = no Internet connection when I use the Swiss SIM in Germany.

When I use the German SIM (in Germany )it works.

No ping 8.8.8.8 from SSH Terminal, no running LuCI diagnostic, no WWW on PC-Client.

The Swiss SIM works fine in my Notebook (also roaming in Germany)

Please show the output of ifstatus Sunriseinternet once connected in roaming.

Have you tried connecting to another German network?

Hi AndrewZ,

thx for your help. Here is the output of ifstatus Sunriseinternet and ifstatus Sunriseinternet_4:

root@OpenWrt:~# ifstatus Sunriseinternet
{
        "up": true,
        "pending": false,
        "available": true,
        "autostart": true,
        "dynamic": false,
        "uptime": 596,
        "l3_device": "wwan0",
        "proto": "qmi",
        "updated": [
                "data"
        ],
        "metric": 0,
        "dns_metric": 0,
        "delegation": true,
        "ipv4-address": [

        ],
        "ipv6-address": [

        ],
        "ipv6-prefix": [

        ],
        "ipv6-prefix-assignment": [

        ],
        "route": [

        ],
        "dns-server": [

        ],
        "dns-search": [

        ],
        "neighbors": [

        ],
        "inactive": {
                "ipv4-address": [

                ],
                "ipv6-address": [

                ],
                "route": [

                ],
                "dns-server": [

                ],
                "dns-search": [

                ],
                "neighbors": [

                ]
        },
        "data": {
                "cid_4": "1",
                "pdh_4": "-2046364336"
        }
}
root@OpenWrt:~# ifstatus Sunriseinternet_4
{
        "up": true,
        "pending": false,
        "available": true,
        "autostart": true,
        "dynamic": true,
        "uptime": 597,
        "l3_device": "wwan0",
        "proto": "dhcp",
        "device": "wwan0",
        "updated": [
                "addresses",
                "routes",
                "data"
        ],
        "metric": 0,
        "dns_metric": 0,
        "delegation": true,
        "ipv4-address": [
                {
                        "address": "10.85.135.154",
                        "mask": 30
                }
        ],
        "ipv6-address": [

        ],
        "ipv6-prefix": [

        ],
        "ipv6-prefix-assignment": [

        ],
        "route": [
                {
                        "target": "0.0.0.0",
                        "mask": 0,
                        "nexthop": "10.85.135.153",
                        "source": "10.85.135.154/32"
                }
        ],
        "dns-server": [
                "212.161.168.15",
                "212.161.168.14"
        ],
        "dns-search": [

        ],
        "neighbors": [

        ],
        "inactive": {
                "ipv4-address": [

                ],
                "ipv6-address": [

                ],
                "route": [

                ],
                "dns-server": [

                ],
                "dns-search": [

                ],
                "neighbors": [

                ]
        },
        "data": {
                "zone": "wan",
                "dhcpserver": "10.85.135.153",
                "hostname": "OpenWrt",
                "leasetime": 7200,
                "zone": "wan"
        }
}

How can I change the connected 4G network for testing?

All looks good to me. Can you run any DNS query on the router, like nslookup openwrt.org ?

You can use option plmn to select specific provider, see https://openwrt.org/docs/guide-user/network/wan/wwan/ltedongle#qmi_protocol_configuration_parameters

root@OpenWrt:~# nslookup openwrt.org
;; connection timed out; no servers could be reached

OpenWRT

I discovered that every time, I receive only 630 B (2 Pkts.) on the 4G internet.

Is there an option to check the roaming setting? (roaming on/off)?

I will try to change the network and post an update.

You have roaming enabled and used, otherwise you wouldn't get an IP address.

Try disabling DHCP for QMI with option dhcp '0' and see if it will make any difference.

It is an roaming issue. I put the SIM back to my Windows Notebook and tried to connect to 4G. And I got the info that roaming is disabled. So I enabled roaming on the SIM card and then it worked on my Windows Notebook.

After this I put the SIM back in the router and now it works! I have an Internet connection. :slight_smile:

@AndrewZ many thanks for your support!

Cheers

Udo