How I can passively/protocol agnostic bridge one lan port ot a wan one?

In my H300s I saw that Both PPP and DHCP traffic comes from WAN ethernet port by plugging this ethernet port to my computer ethernet port and sniffing it through wireshark:

https://drive.google.com/file/d/1EYcNZ-p3TZNh4cbQSQsz7csdFv692bvk/view?usp=sharing

So what I want is to use an openwrt router in this setup:

εικόνα

In other words I sacrifice on Lan port and use that to pasively forwatd traffic from H300s to the Internet using an opoenwrt router. Also I want this traffic to actively be sniffed through TCP dump.

My knowledge so far is to make openwrt to connect to VOIP VLAN and to DSL VLAN:

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdd2:a40d:d919::/48'

config device 'wan_dsl0_dev'
	option name 'dsl0'
	option macaddr '00:20:da:86:23:75'

config atm-bridge 'atm'
	option vpi '1'
	option vci '32'
	option encaps 'llc'
	option payload 'bridged'
	option nameprefix 'dsl'

config dsl 'dsl'
	option annex 'b'
	option ds_snr_offset '0'
	option line_mode 'vdsl'
	option tone 'auto'
	option firmware '/lib/firmware/vr9-B-dsl.bin' 

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ip4table '1'

config interface 'wan'
	option device 'dsl0.835'
	option proto 'pppoe'
	option username 'guest@adsl.gr'
	option password '******'
	option ipv6 'none'
	option keepalive '10'
	option mtu '1492'
	list dns '1.1.1.1'
	list dns '1.0.0.1'
	option peerdns '0'

config interface 'voip'
	option device 'dsl0.837'
	option proto 'dhcp'
	option defaultroute '0'
	option ip4table '2'

config interface 'wan6'
	option device '@wan'
	option proto 'dhcpv6'

But how I can change that in order lan1 port to pasively forward traffic to applications and ports?
I am using a Fritzbox 7360 router.

Are you asking to mirror the WAN Ethernet port in order to sniff traffic?

1 Like

Exactly this is what I want to. To mirror the DSL router wan port to my router.

In other words I want to forward whatever the h300s wan port does to actual dsl network, whilst I snoff the traffic out of it.