How I can configure OpenWrt to be able to use the box in **WPS** (not in **WDS** )?

AS in the tittle:
how I can configure OpenWrt to be able to use the box in WPS (not in WDS ) ?

For use with a WR1200JS slave WPS

The master router is a Livebox4 in 5 GHz

As I noted in the previous thread, you must setup the button, first.

thank you very much, I had read well, but am I completely stupid because I understand absolutely nothing ...

it looks like there are mixtures with old OpenWrt versions and the most recent ones

what I want to do is when I press the button of the Livebox 4 (master) the Openwrt box can be associated in WPS mode as with other boxes that I own as an Arris / Orange extender case

Out of curiosity, why are you utilizing WPS (as it's not even remotely secure, able to be cracked in minutes, normally hours to a few days in reaver or wpscrack)?

1 Like

Sorry but in my country France all internet box use WPS with button

My request is for use OpenWrt connect to WDS with my Internet Box




bouyghes Bbox

I would be very surprised if those devices don't allow for the entry of a pass phrase. As pointed out, WPS is deemed by many to be a significant security risk. WPS is merely a convenience feature that, regrettably, is still supplied by many manufacturers in the desire to sell their products.

Checking the first on your list, though finding English-language instructions is difficult, seems to indicate that manual configuration of the pass phrase is straightforward. I certainly would look into changing the pass phrase to longer than the 8-characters that is supplied by default.

That is not a problem with the paraphrase
My request is for use WDS because: i use also with the Orange box a Orange TV player and i can watch TV channel

Orange BOX <-LAN> Box TV Sagem ====>>>> no problem

Orange Box <- WIFI AC -> WPS - Extender Orange/Arris 5Ghz <-LAN-> Box TV Sagem ====>>>> no problem

Orange Box <- LAN - > OpenWrt-1 / WDS ap <- WIFI -> OpenWrt-2 / WDS sta <-LAN-> Box TV Sagem ====>>>> no problem

Orange Box <- WIFI AC -> OpenWRT repeater <- LAN -> Box TV Sagem ====>>>> problem , I can use internet replay TV but not the TV flux

Finnaly what I want is to pass the TV (multicast) by the box as with two Openwrt boxes in WDS or with a extender in WPS as this:

Orange Box <- WIFi -> OpenWRT <-LAN-> Box TV Sagem with TV ok

Or for replace two OpenWRT in WDS by only one in WPS

Taking your list of working and not-working configurations, let's look at them to see if it can help narrow down the problem:

(1) Orange BOX <-LAN> Box TV Sagem ====>>>> no problem

(2) Orange TV <- WIFI AC -> WPS - Extender Orange/Arris 5Ghz <-LAN-> Box TV Sagem ====>>>> no problem

(3) Orange Box <- LAN - > OpenWrt-1 / WDS ap <- WIFI -> OpenWrt-2 / WDS sta <-LAN-> Box TV Sagem ====>>>> no problem

(4) Orange Box <- WIFI AC -> OpenWRT repeater <- LAN -> Box TV Sagem ====>>>> big problem I can use internet replay TV bit not the TV flux

(1) -- wired configuration, WPS doesn't play a role

(2) -- suggests that as the two Orange-supplied boxes implement WDS (which is not a "standard"), the Sagem is able to get multicast content over the Orange-flavor WDS

(3) -- suggests that the OpenWrt-flavor WDS is able to pass the multicast content

(4) -- is interesting, but note that you're mixing Orange-flavor WDS with OpenWrt-flavor WDS.

As WDS is not a standard, right now I suspect this has more to do with WDS interoperability than with authentication credentials created using a WPS button.

Do you have Internet connectivity from the OpenWrt repeater, over the WDS link through the Orange Box in configuration 4? (It looks like you do.) If so, I suspect your problems are related to multicast content not being handled properly by the two flavors of WDS between the Orange Box and the OpenWrt repeater.


WDS may be incompatible between different products (even occasionally from the same vendor) since the IEEE 802.11-1999 standard does not define how to construct any such implementations or how stations interact to arrange for exchanging frames of this format. The IEEE 802.11-1999 standard merely defines the 4-address frame format that makes it possible.[2]

thank you for numbering the different mode options !!!

in all modes i have internet

problem is only in mode 4 with the multicast TV flux

my request is just for my education because now Orange provides TV mini UHD boxes with WIFI AC / WPS for 10 euros and that work very well


If you're going to utilize WPS, at least lock down the access to the WPS network... i.e. create a guest wifi network and interface and firewall it off from everything except WAN, as your router is the equivalent of the front door of your house to your digital life.

  • It's highly probable someone has already exploited your network with a tool like aircrack, reaver, or wpscrack (with the previous two available as packages for OpenWrt), and is the reason why it's recommended to never utilize WPS, WEP, or WPA in the Wireless Overview wiki, under Wireless Security

Because they care more about customer convenience than customer security, just as most consumer product businesses do.

  • Many, if not a majority, of consumer routers come with UPnP and WPS enabled, even though both are massive security risks.

  • Almost all electronics with an IoT device (any "smart device" that can be connected via WiFi/BT, including children's toys) are a security nightmare with few, if any, security measures to prevent unauthorized access, which is why they're consistently utilized in DDOS attacks.

Apparently companies believe it's far too difficult to force a consumer to correctly secure their devices in the 21st century... and they're likely right [unfortunately]. The vast majority of consumers couldn't care less about digital security and is why the top 5 passwords, year after year, have always been at least one or more of the following:

  • password
  • 12345678 (variations of)
  • 1111 (variations of)
  • qwerty
  • p@$$w0rd (variations of)

Thank you but this story does not answer my request is to manage to operate the OpenWRT box as a client linked to my Orange Internet box in WPS

You asked why your provider utilizes WPS, to which I provided a possible answer and explanation... I did quote your question after all.

My question is:

How I can configure OpenWrt to be able to use the box in WPS (not in WDS )? 

That for a WRT1200JS

1 - How i configure the WPS button
2 - How I test that the button works
3 - How I can link two boxes in WPS with the buttons

For test i have 2 * WR1200JS , one in master , one in slave in WDS at this time

I agree with @JW0914 and others about WPS, having said that I see from another thread you've already removed wpad-mini and installed wpad and hostapd-utils, so check to see if you have kmod-gpio-button-hotplug installed too and install if not.

kmod-gpio-hotplug-button is iinstalled and up to date

Based on earlier discussion on your observed behavior, you most likely will be unable to be able to link the Orange-flavored WDS with OpenWrt-flavor WDS for multicast, with or without WPS.

As repeated many times, WPS is nothing more than a known-insecure way of providing "easy" transfer of credentials between units, not a change in wireless protocols used for the transmission or routing of packets.

If I already managed to link the two boxes WR1200JS WPS I would already be certain that it works between the two boxes OpenWRT which is not the case

That suggests that

  • You're able to connect two OpenWrt boxes together with wireless and have "all" traffic flow as expected
  • You're able to connect the Orange Box to the OpenWrt box with wireless and that it works for general traffic, but not for "TV flux".

As WPS is used to exchange credentials, not traffic, I would be very surprised if it changed the interoperability problem between the Orange-flavor WDS and the OpenWrt-flavor WDS.

The only other things I can think of are to make sure you reboot after enabling WPS and that you enable WPS on the same band the device you're connecting to is on, meaning enable WPS on 2.4ghz band if that's what the other device is operating on. If it still doesn't work then you'll most likely have to configure the button yourself as @lleachii suggested.