How do I get a Wifi Extender to be recognized in the subnet it extends itself?

I followed the Wifi Extender or Repeater or Bridge Configuration Guide for my TL-WR810N and succeded in setting up a relay. I also want the Wifi Extender (TL-WR810N) to be able to act as a shairport-sync receiver and Snapcast Client, but for some reason no other device is recognizing it. I can neither ssh into it nor can I ping the device. If I connect to it with ethernet over the Subnet 192.168.2.X everything works. I guess it is related to the way the Wifi Extender (TL-WR810N) is known in the Subnet 192.168.1.X it extends itself.

Can someone point me in the right direction or tell my the steps I need to do in order to get other devices connected to the Subnet 192.168.1.X over the Wifi Extender (TL-WR810N) to recognize the Wifi Extender (TL-WR810N) itself and be able to communicate with it?

Check out my notes too see if you missing someting:

If you have compatible chipset routers (at least from same vendor) you could also try WDS, it is easier to configure:

This works extremely well and stable on OpenWRT 15, but I don't have tried many hours on LEDE to know if it is stable or not, it should be.

@braian87b I wouldnt recommend wds. Its not stable on the current release. OP will get wifi crashes on any router everytime the network load get a bit higher. Sometimes after a few minutes, sometime days, making wds extremly frustrating. I have myself this issue on 4 different atheros powered router.

@tristank Do your services need multicast? If yes add this into /etc/rc.local in front of 'exit 0' on your repeater:
echo "0" > /sys/devices/virtual/net/br-lan/
Change br-lan with the name of your lan bridge.

About the ping problem: wwan (or whatever you named the wifi interface) and the relayd interface need both the same ip. If not you can still have internet on your clients, but the repeater itself remain unaccessible.


What kind of unstability it has? since it seems to be at firmware level there is some progress on detection and how to fix it? or it is just because the normal growth of codebase that reduced the flash and ram and the limit makes the wds unusable?

I've been using WDS on 17.01.4 with no problems between a MR3420 v1 and R6100, up time 7 days. I do have a 64MB RAM chip refitted in the MR3420 so I don't know if 32MB would cause a problem.

@braian87b The devices are: Archer c5 v1 (128mb), WR1043NDv3 (64mb), 841ndv7, 841ndv9 (both 32mb). Every device gave me instability issues with wds on 2,4ghz during weeks. Ending in a complete wifi crash (for 5ghz too) randomly on single or every router at the same time. It took sometime minutes or up to 9 days to crash with wds: connection was still present but no network transfer working and/or i wasnt able to connect with new devices on both wifi bands. All devices worked well without wds. Logs werent useful and i dont had the time to test further. It seems i needed more verbosity to find out the problem. My goal was a simple wds bridge between 2 router. But well lets not hijack the thread. This a topic for another one.

There is a follow up on this on another place to keep a track on this?

Didnt started one yet. I will probably during the holidays after setting up a testing setup and will ping you there since i generaly need help for debuging.