How do I enable channels 12 and 13?

The title says it all...

Background:

In the country I live in (Germany), and in most countries, channels 12 and 13 are allowed.

According to https://upcommons.upc.edu/bitstream/handle/2117/1234/CrownCom07_CReady.pdf?sequence=1 , the best channel assignment to minimize overlap is achieved by using channels 1, 5, 9 and 13.

My neighbors have grabbed all channels until 11 included (maybe they are running LEDE ?), so how can I breathe in channel 13 ?

Hi @deuteragenie.
On my WRT1200AC router I need to both wireless radios to my country (UK) then I can access channel 12/13 - the US defaults will only allow channel 11. You can do this in the Wireless Device Configuration > Advanced Settings > Country code for both radio0 and radio1. Or use the command line uci utility to set these to germany here.

uci set wireless.radio1.country='DE'
uci set wireless.radio0.country='DE'

Thank you!

It works on my TP-Link 842N v3.1,
LEDE Reboot SNAPSHOT r3061-d9b1a55 / LuCI Master (git-17.020.82842-e1edb10)
I believe (although not 100% sure) that after changing the country code, a reboot was needed in order to enable the extra channels.

It DOES NOT work on my Archer C7 v2,
LEDE Reboot SNAPSHOT r3075-fa66900 / LuCI Master (git-17.023.63100-eaafb45)

Any idea what is going on?

Hi @deuteragenie. On your Archer C7 v2 try this command below and paste the results back here. Another good thing to try is using the world country code 00 instead of DE. The below command will show you what region your wifi is currently in and what frequencies are allowed.

iw reg get

Thanks again,

Here is the output of iw reg get for the Archer C7:

global
country US: DFS-FCC
	(2402 - 2472 @ 40), (N/A, 30), (N/A)
	(5170 - 5250 @ 80), (N/A, 23), (N/A), AUTO-BW
	(5250 - 5330 @ 80), (N/A, 23), (0 ms), DFS, AUTO-BW
	(5490 - 5730 @ 160), (N/A, 23), (0 ms), DFS
	(5735 - 5835 @ 80), (N/A, 30), (N/A)
	(57240 - 63720 @ 2160), (N/A, 40), (N/A)

phy#0
country US: DFS-FCC
	(2402 - 2472 @ 40), (N/A, 30), (N/A)
	(5170 - 5250 @ 80), (N/A, 23), (N/A), AUTO-BW
	(5250 - 5330 @ 80), (N/A, 23), (0 ms), DFS, AUTO-BW
	(5490 - 5730 @ 160), (N/A, 23), (0 ms), DFS
	(5735 - 5835 @ 80), (N/A, 30), (N/A)
	(57240 - 63720 @ 2160), (N/A, 40), (N/A)

I gather that the country is still set to US, although Luci shows Germany. Looks like a bug.
Note:I did not install ath10k on that router as I do not have any device that are 5 Ghz ready.

After the following

uci set wireless.radio0.country='DE'

the output of iw reg get is still "US", and Luci still does not enable channels 12 and 13.

uci set wireless.radio1.country='DE'

results in an invalid argument, as I did not enable the 5Ghz radio.

Finally:

iw reg set DE

resulted in the desired behavior, i.e, channel 12 and 13 are enabled in Luci.

Here is the final outcome of iw reg get:

global
country DE: DFS-ETSI
(2400 - 2483 @ 40), (N/A, 20), (N/A)
(5150 - 5250 @ 80), (N/A, 20), (N/A), NO-OUTDOOR, AUTO-BW
(5250 - 5350 @ 80), (N/A, 20), (0 ms), NO-OUTDOOR, DFS, AUTO-BW
(5470 - 5725 @ 160), (N/A, 27), (0 ms), DFS
(5725 - 5875 @ 80), (N/A, 14), (N/A)
(57000 - 66000 @ 2160), (N/A, 40), (N/A)

phy#0
country US: DFS-FCC
(2402 - 2472 @ 40), (N/A, 30), (N/A)
(5170 - 5250 @ 80), (N/A, 23), (N/A), AUTO-BW
(5250 - 5330 @ 80), (N/A, 23), (0 ms), DFS, AUTO-BW
(5490 - 5730 @ 160), (N/A, 23), (0 ms), DFS
(5735 - 5835 @ 80), (N/A, 30), (N/A)
(57240 - 63720 @ 2160), (N/A, 40), (N/A)

I still do not know why the US is referred to in "phy#0", and what are the consequences...

Great info!!!

Thank's a lot deuteragenie.

Nice write-up @deuteragenie thanks for sharing. I'm curious to know if the iw reg set persists after a reboot if UCI/Luci is not following?

The settings persists after a shutdown and/or a reboot.

I suppose that Luci has a bug in the setting of the parameter(s), but does not have a problem reading from the config files and displaying the list of all available channels.

In my experience, you have to set the country in Luci, Save and Apply, and (if you haven't yet), enable wireless. After the settings are applied (and wireless is enabled), you'll be able to select channels 12 and 13 (and it'll also show the correct power limits).

I'm still running into a similar issue. While I am able to set channel 13 correctly for the NL region, transmit power seems to run into an issue. While I am able to set up to 20 dBm on the 2.4ghz wifi as expected, when setting anything higher than 17 still shows a transmit power of 17 in Luci.

A transmit power of 20 dBm was possible on Openwrt with the Reghack applied, so the hardware is capable of doing it. Why am I not able to set this correctly on Lede? Will I need to apply a reghack again to use a txpower of 20?

I'm still running into a similar issue. While I am able to set channel 13 correctly for the NL region, transmit power seems to run into an issue. While I am able to set up to 20 dBm on the 2.4ghz wifi as expected, when setting anything higher than 17 still shows a transmit power of 17 in Luci.

A transmit power of 20 dBm was possible on Openwrt with the Reghack applied, so the hardware is capable of doing it. Why am I not able to set this correctly on Lede? Will I need to apply a reghack again to use a txpower of 20?

Just checking, is hte higher transmit power allowed on that channel in that
region? the regulations do include power limits that vary by channel and
location.

David Lang

Yes, the limit at 2.4ghz is 20 dBm for The Netherlands.

Including or excluding the gain of the antenna?
How high is the gain of your antenna?

Ah, that might be it. I think the gain is 3 dBm, so then with a limit of 20 dBm in the Netherlands, a maximum of 17 makes sense. It is kind of strange that 18, 19 and 20 are possible to select in Luci, even though they do not work. Probably an GUI bug then, rather than a LEDE bug. Thanks for clearing this up for me :slight_smile:

The gain of the internal 2.4 GHz antennas of the Archer C7 v2 is far less than 3 dBi (antenna gain isn't measured in dBm BTW). Even a standard external lossless dipole antenna offers only 2.15 dBi gain minus connector losses.

Why does OpenWrt assume high gain antennas for this device?

LEDE doesn't really assume anything here, these values are -among other things- taken from the calibration data (ART).

I dug through the code and the 3 dBm value comes from the variable "pwr_reduction_80211h".

802.11h is intended to reduce radar inference, but there is no radar on 2.4 GHz. So at a glance this looks a code error. Instead of applying it to specific (DFS) channels, it gets applied over all bands and channels.

In linux-ar71xx_generic/backports-2017-11-01/net/mac80211/mlme.c or elsewhere?

Yes, mlme.c is one place, where I found it.

I also suspect that it gets the reduction wrong for the radar channels too. Here in the ETSI regulatory domain, the allowed transmit power on 5.5 GHz for devices with DFS+TPC is 30 dBm and 27 dBm with DFS and without TPC.

The Archer C7 doesn't seem to be TPC-enabled, so cuts back 3 dBm. However, the regulatory data already accounts for 3 dBm less when setting the reg domain to outside the US (showing the limit at 27 dBm) and the code cuts back another 3 dBm going down further to 24 dBm. That reduction is also applied to 5.2 GHz and 2.4 GHz, where it should never happen and the ETSI regulation sets a maximum of 20 dBm, ending up with a TX power of 17 dBm, which is essentially unusable on 5 GHz (and makes a very poor 2.4 GHz access point).

On the other hand my other OpenWrt device Linksys WRT1200AC with mwlwifi is operating fine at the correct power levels set by the authorities.

Is this a Linux bug or openwrt bug?

I upgraded my WDR3600 to an Archer C5 and my WDS repeater dropped from 10Mbit over 2.4ghz to 3Mbit. I get 7Mbit upload (i.e. from repeater to router) Router and repeater are in the exact same locations.

The archer c5 will only go to 17dbm even if I select 20dbm on luci.
18.06.4