How do I completely clear any LUCI caches and restart it?

As the main question states - how to?

I recently installed two different opkg packages that were supposed to add a new UI entry to Luci, and yet they didn't, until I have rebooted the device. These were two separate and independent occasions. Obviously, I don't want to restart the device.

  1. luci-app-openvpn - the whole top category would not render: image
  2. https-dns-proxy - the item inside the dropdown would not render: image

Here's what I tried (to no avail):

  • rm -rf /tmp/luci*
  • /etc/init.d/lighttpd restart

Any ideas what I should do next time I encounter this problem?

# cat /etc/openwrt_release
DISTRIB_DESCRIPTION='TurrisOS 5.1.0 33973a90dc210c45d2fea38b1b68786734066500'

You've already tried what I thought was the right solution (rm -rf /tmp/luci-*), so just in case you haven't tried these yet, simply closing the current luci tab and opening luci in a new tab has worked for me in the past, also, going to another section of luci and then going back to the affected section has also worked. This should be fixed in 19.07.4 incase you're not on it and want to upgrade.

edit - or apparently just logout/back in as that git suggests.

I tried these solutions, even trying a different browser, with no result.

My build is on this commit Looks like it's several days before the fix. I depend on Turris bringing releasing these fixes in their repos so my hands are tried for now.

Assuming the PR really fixed it, it means there's another cache somewhere that is not in tmp/luci*. Any idea where it's stored? find / -name '*cache*' doesn't reveal anything.

Sorry, I don’t know.

Runtime configuration in OpenWrt should be limited to RAM and /tmp.
Typically, it's enough to restart the involved services to reload the configuration.
Though, some changes may require you to flush the client side cache.

Are you really using lighttpd instead of the normal default uhttpd?

Yep, he is on TurrisOS which is using lighttpd by default.

@Nowaker Since 19.x LuCI is using heavily client side JS ... that means you should clean up all your browser caches as well. Also please restart the rpc daemon (/etc/init.d/rpcd restart) to refresh your LuCI ACLs.


Thanks. Maybe that was the missing piece.