How can we make the lantiq xrx200 devices faster

There is also a PR that increases efficiency. It contains the previously mentioned patches.

im testing this currently, one thing I cant confirm is whether it's possible to have a port carry 2 tagged vlans on it

1 is ok, I haven't confirmed 2 work

Are you testing QinQ?

no, just basically want a public lan and a private lan with 1 port tagged in on both
maybe it's just the difficulty of DSA and UCI config or perhaps the vlan id was too high or something
i'll try again later

everything seems stable with your performance branch, been up for 3-4 days now no problems

My patches have been applied to the master in 7e484b9.


Is that from WAN to LAN? I can only get 150mbps from wan to lan, on lan to lan I get 950 so there its great

Measurement results are between LAN and WAN. I can get 700Mbps with software flow offload enabled.

how about WIFI to WAN? I'll dig out my ethernet and tran LAN to WAN also.

Also are your changes@olek210 in the latest snapshot builds, or do I need to build a custom image.

I cannot get above 150mbps on WAN to LAN, but 700 to 900 on LAN to LAN. I wonder what I can do to investigate cause and difference.

The patch was applied on 16/01/2022, any snapshot build after that date include that commit.

Probably the contract with your ISP limits your WAN speed around 150 MBps (or a bit above that but software overhead and network congestion always degrade maximum obtainable speed).

Wan speed over ethernt from isp cable modem in router mode is
370mbps. I ran snapshot from 18 Jan, tried to upgrade to latest one last night and bricked the bloody thing. Sys upgrade failed to reboot and the led turns briefly green then red.

Don't have serial port and hw mod so unless there is a way out of that it's going in the trash.

There could be a way.
I updated from stable to 16-Jan snapshot and there were some problems (network configuration changed), but I finally solved the situation using the reset button.

See Reset button problem in 19.07.1 on BT Home Hub 5A

I used the first method: Holding reset down while powering up until the LED starts flashing (green on this device) and the device goes into failsafe mode (with rapid red LED flashing on this device).
You can try to use firstboot & reboot now commands or you can even send a previous version of openwrt via SCP and perform another upgrade.

Give it a try & good luck.

Sorry for not being contributing to the speed test, but my Internet connection is 100mb, so I cannot see any difference.

No change, goes from green to solid red, no ports open and no access

I assume you have used the search in the forum.
However, as this model has several documentation on other forums, please, check also the existing installation guide, in particular, section 8:

You will see different methods to try.

Hope it helps.

Source: Bthub solid red light after firmware update 19.07 - #6 by realpandas

I tried the daily versions. and there is no difference. performance is still very bad

Is the WAN connection PPPoE or DHCP? Have you enabled Software Flow Offloading?

yes wan vdsl pppoe and flow active

My patches don't touch the DSL part hence you don't see any improvement. The performance gain is only visible during transfers over the Ethernet interface (WAN and LAN).

1 Like

The maximum speed of VDSL is 100Mbps, conditioned by the physical state of the copper pair line. Before @olek210 patches this SoC was already able to transfer over 100Mbps in NAT, so no performance improvement under VDSL is possible.