How can we make the lantiq xrx200 devices faster

Also are your changes@olek210 in the latest snapshot builds, or do I need to build a custom image.

I cannot get above 150mbps on WAN to LAN, but 700 to 900 on LAN to LAN. I wonder what I can do to investigate cause and difference.

The patch was applied on 16/01/2022, any snapshot build after that date include that commit.

Probably the contract with your ISP limits your WAN speed around 150 MBps (or a bit above that but software overhead and network congestion always degrade maximum obtainable speed).

Wan speed over ethernt from isp cable modem in router mode is
370mbps. I ran snapshot from 18 Jan, tried to upgrade to latest one last night and bricked the bloody thing. Sys upgrade failed to reboot and the led turns briefly green then red.

Don't have serial port and hw mod so unless there is a way out of that it's going in the trash.

There could be a way.
I updated from stable to 16-Jan snapshot and there were some problems (network configuration changed), but I finally solved the situation using the reset button.

See Reset button problem in 19.07.1 on BT Home Hub 5A

I used the first method: Holding reset down while powering up until the LED starts flashing (green on this device) and the device goes into failsafe mode (with rapid red LED flashing on this device).
You can try to use firstboot & reboot now commands or you can even send a previous version of openwrt via SCP and perform another upgrade.

Give it a try & good luck.

Sorry for not being contributing to the speed test, but my Internet connection is 100mb, so I cannot see any difference.

No change, goes from green to solid red, no ports open and no access

I assume you have used the search in the forum.
However, as this model has several documentation on other forums, please, check also the existing installation guide, in particular, section 8:

You will see different methods to try.

Hope it helps.

Source: Bthub solid red light after firmware update 19.07 - #6 by realpandas

I tried the daily versions. and there is no difference. performance is still very bad

Is the WAN connection PPPoE or DHCP? Have you enabled Software Flow Offloading?

yes wan vdsl pppoe and flow active

My patches don't touch the DSL part hence you don't see any improvement. The performance gain is only visible during transfers over the Ethernet interface (WAN and LAN).

1 Like

The maximum speed of VDSL is 100Mbps, conditioned by the physical state of the copper pair line. Before @olek210 patches this SoC was already able to transfer over 100Mbps in NAT, so no performance improvement under VDSL is possible.

wan to lan
wan to 5ghz
lan to 5ghz

i tested these but performance is still poor

Does any one noticed that recent trunk has IRQ VPE enabled but moving ethernet IRQ (72 / 73) to second core kills network ?
kernel 5.4 + DFS + VPE patch didn't had that issues as I'm still using it on "production" FB7412

Indeed i noticed the same thing.. I am able to move the ath9k interrupts to the second core. But moving the dsl or erhernet interrupt hangs my wr9980.

You should use this patch.
0901-add-icu-smp-support.patch

1 Like

Hi, I have Astoria networks VGV7519 (VRX288 V1.2) running latest stable OpenWRT v21.02.3.
My internet uplink is pppoe ethernet 100mbps (I don't use dsl/telephony)
What patches/settings would you advice to improve performance of this unit? I already enabled "Software flow offloading", but would like to go a bit further.

root@wrt0-vgv:~# cat /proc/cpuinfo
system type             : xRX200 rev 1.2
machine                 : KPN Experiabox V8
processor               : 0
cpu model               : MIPS 34Kc V5.6
BogoMIPS                : 332.54
wait instruction        : yes
microsecond timers      : yes
tlb_entries             : 16
extra interrupt vector  : yes
hardware watchpoint     : yes, count: 4, address/irw mask: [0x0ffc, 0x0ffc, 0x0ffb, 0x0ffb]
isa                     : mips1 mips2 mips32r1 mips32r2
ASEs implemented        : mips16 dsp mt
Options implemented     : tlb 4kex 4k_cache 32fpr prefetch mcheck ejtag llsc dc_aliases userlocal vint perf_cntr_intr_bit perf
shadow register sets    : 1
kscratch registers      : 0
package                 : 0
core                    : 0
VPE                     : 0
VCED exceptions         : not available
VCEI exceptions         : not available
root@wrt0-vgv:~# dmesg | grep smp
[    0.000000] Kernel command line: console=ttyLTQ0,115200 mem=62M vpe1_load_addr=0x83e00000 vpe1_mem=2M maxvpes=1 maxtcs=1 nosmp
[    0.075297] smp: Bringing up secondary CPUs ...
[    0.079759] smp: Brought up 1 node, 1 CPU

Please use 22.03.0-rc1 or trunk It contains major improvements for lantiq platform . And there will be more in stable 22.03.0 branch in next few months .

I tried both 22.03.0-rc1 and trunk but there is still 1 core shown in /proc/cpuinfo and no SMP support. So do I still need to compile myself and apply some patches?

lantiq devices with FXS (analogue phone-) ports reserve one CPU core as voice core (running a special voice firmware and reserving 2 MB of the main RAM). If you don't need that and want to re-use the second core as CPU core, you will have to adapt the cmdline in your device's dts and rebuild OpenWrt (from source).

This is the expected behaviour and not a bug.

1 Like