How can I get Dynamic DNS to work binded to Huawei 4G in Hilink mode?

I have a setup in my car so that wifi is used when it's within range, and 4G is used when it's not. I'm trying to bind the Dynamic DNS to the 4G modem, which is a Huawei in Hilink mode. Only it doesn't get the actual WAN DNS from it, it gets the private address ( For some reason it does get the WAN address from the wifi connection, probably because it's overriding when it's connected. And that's exactly why I would like to use only the 4G to my DynDNS, because I can connect to that both home and away, at any time (the setup is for Home Assistant). I have tried to bind to both network and interface, and to set the DNS that the Huawei uses as the DNS to connect to, but to no avail.

Here's my log:

 110824       : Registered IP '' detected
 110824  info : Starting main loop at 2023-01-20 11:08
 110824       : Detect local IP on 'network'
 110824       : Local IP '' detected on network '4G'
 110824       : Update needed - L: '' <> R: ''
 110824 ERROR : No or private or invalid IP '' given! Please check your configuration
 110824 ERROR : No update send to DDNS Provider

So for some reason it doesn't get a WAN address, but the private address from the 4G modem.

If I try to run "reload" on the DDNS, it times out with

XHR request timed out

I assume whatismyip reports the 92.221 IP when you use it via the Huawei modem ?

Still not sure how the DDNS would help, since you're probably CGNATed.

Thanks for answering! When I'm on the Huawei modem only (disconnected from the wifi) it reports the correct external IP from the modem, when it's connected to the wifi it only reports the wifi's address. The same goes for using an URL ( to update.

And the Huawei is set up with a DMZ, so everything goes to OpenWRT.