Hosts on LAN cannot ping IP Addresses outside of LAN Gateway

Hi, everyone,

I'm trying to set up a mesh network where devices connect using OpenWRT on an older Linksys WRT54GL router. I have OpenWRT running, and can get IP Addresses for the hosts. The WAN interface gets an IP Address from the next device in line (set to 5-host direct). From the router's diagnostics page, I can ping the next device in line (router 1 for the purposes of this post). However my computer cannot ping router1 at all. It can ping the IP Address of it's gateway on the Linksys router, but nothing further.

I'm going to put this next part in all caps because it's vital. THIS ROUTER/NETWORK WILL NOT BE INTERNET ACCESSIBLE

I've tried disabling the firewall, putting the WAN interface into the same zone as the LAN interface, and disabling the wifi in case it was trying to send the pings out over that interface instead.

Essentially the system will look like this:

device ==> Linksys Router ==> Mesh Node ==> Mesh node ==> router ==> Device 2. Everything works except the last mile (device to router to mesh node).

I'm attaching screenshots of the current setup.
OpenWRTFirewall OpenWRTInterfacesGeneral OpenWRTRoutes OpenWRTStatus

Hopefully you can help me get this figured out. I've used OpenWRT before but not in a setup like this. So, I'm kind of in the weeds here. For reference, the router will connect to an AREDN mesh (which uses OpenWRT as the base-system).

Have a great day. :slight_smile:

  • You haven't described where router1 is
  • Nor its IP
  • I just converted a WRT54GL from HSSM-Broadband - I did so because OLSR was not compatible
  • If you are routing using OLSR protocol, it's a good time to mention it regarding this issue
  • My section is choosing for straight OpenWrt with OLSR installed
  • There is another HAM from AREDN that came here
  • If you are using OLSR routing, you have not mentioned it here

  • I'd love to PM to exchange callsigns

  • BTW, I think your issue is that you disabled masquerade on WAN.

I am pretty sure that router1 doesn't have a route back to device 1 sitting behind the Linksys router.
That happens because when you ping from the diagnostics page of the Openwrt, you use the WAN IP address. But since you have deselected Masquerading in the WAN interface, the IP of the device1 will not be NATed with the WAN IP of the Openwrt.
Try to add a static route on router1, the one on the left of device2.
Or enable Masquerade on WAN zone of Openwrt.
73 de sv1liv

1 Like

I'll try to explain it a little better. Router 1 is going to be the last mile between the laptops/desktops and the first mesh node. On the LAN side, it will have either or for an IP Address (and feed out that subnet to clients). On the WAN side, it's getting the IP Address from the mesh node, so something like Most likely you're right about it being that I didn't have Masquerade turned on. I'm not familiar with that term for anything, so I didn't mess with it.

In the short-term, I flashed DD-WRT on the router and everything worked out of the box. I've got three more routers to configure, so I'll retry OpenWRT on them. If they work better, I'll go back to it.

Have a great day and thanks for all of your help. :slight_smile:

WAN port in Openwrt is by default configured to masquerade the traffic, so you shouldn't experience such a situation. Openwrt is also plug 'n' play in such a scenario.

1 Like