Host Showing IPV6 Address

How can I force openwrt to show only ipv4 addresses only or hostname resolution under host.

Just disable it:

1 Like

I'm afraid, the setting affects only ULA and GUA, but those are LLA on the screenshot.


@vgaetera @lleachii Is there any way of fixing it? I disabled IPV6 but issue remains.

1 Like

You'd probably have to explicitly disable the ipv6 stack on all of your clients. LLA addresses are automatically assigned on hosts with an operational ipv6 stack, since they're critical to the functionality of ipv6.

I haven't tried this yet, but if you go to the LAN interface (assuming this is the interface your wireless radios are bridged onto) and disable the ipv6 dhcp options, maybe it will stop showing the LLA addresses....not sure, but worth a try.


Or even just stop odhcpd running. Disable the service, although also not tried that, so you'll need to experiment

That said, why do you particularly want to disable it?

1 Like

These ipv6 addresses are link-local addresses. They're not routable.

At most, your clients might use them to send dns queries to openwrt. They're not going to attempt to get onto the internet with ipv6.

Those devices look like a combination of a playstation, a samsung mobile phone, a sony mobile phone and an apple device. They all have ipv6 enabled on them out of the box and there's little you can do to disable it unless you root or jailbreak the device.

1 Like

I am just looking for way to make devices show ipv4 address under host.

It's just a display issue i think. He wants to see only the ipv4 on the luci page. Not sure how you can do that though.

1 Like

Correct, that's all I want.

which is why turning off odhcpd may do the trick, either by setting everything to disabled like I showed or by deactivating the service. You'll need to test. I've not done so...

I tried both of them, It shows ? mark or ipv6.

This helped getting rid of ipv6 address, but now there is only ? mark under host.

Adding there commands under System -> Startup -> Local Startup

sysctl -w net.ipv6.conf.all.disable_ipv6=1
echo 1 > /proc/sys/net/ipv6/conf/all/disable_ipv6
sysctl -w net.ipv6.conf.default.disable_ipv6=1

disabling ipv6 seems pretty heavy handed for a pure display issue. :expressionless:


Any suggestion what we can we try?

1 Like

File a bug against LUCI requesting some option to set what is being displayed?

1 Like

Where can I file that?

1 Like

1 Like

Done, Thanks


Sorry, that tracker is for OpenWrt core:
A bigger picture - #8 by vgaetera

LuCI-related bugs should be reported here:

1 Like