Host name missing from associated stations page on dumb AP

Is there a setting I need to enable to allow my dumb AP to see the hostnames under Network>Wireless? Currently, this is not populated.

This is a common question.Search is your friend here...

One solution is here:

There are many more to be found, too ("dumb ap hostnames" in the forum search or Google).


Thanks for the links. I can manually populate /etc/ethers on the dumb AP but an automatic method would be better. I cannot seem to find such a method.

For those interested, on the router, this one-liner will give the needed info in the right format to populate /etc/ethers on the dumb AP:

cat /tmp/dhcp.leases | awk '{print $2" "$4}'

you could always cron it ...

in openwrt 19 fping worked too, look for those threads, see if it's still not able to do the same.

I thought about a script-based method + cron job as well. Might be more trouble that it's wroth as my list of clients does not change all that much.

same here, ended up using ethers, and then distributing it to all my APs.

This is what i used when i was using Openwrt on my Ap‘s


Someone can add to/update that.

would that someone be you ?

@frollic - You misunderstand, I started a new section with some info on this topic; I was inviting others to contribute :smiley:


I'll follow up on updating the dumb ap guide.
I never included my alternative fix threre as I was concerned the DHCP caveat might confuse newbies, however the topic keeps coming up, so I guess that warrants an update to the documentation.


It's good to present options, if you a write up, please append as another method.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.