Host Exposure through OpenWrt router and ISP router doesn't work

Hey everyone,
I'm fairly new to OpenWrt and have trouble setting up my new network. I flashed my Xiaomi AX3600 with OpenWrt (LuCI Master (git-22.213.35850-abd9125)) and it works great during normal use.

Now for the problem I have: I run an Unraid server and need to expose two ports. Previously when beeing directly attached to my ISP router that worked when setting up a host exposure. Now I have added in the OpenWRT router and created a seperate subnet ( but whatever I do the server is not reachable from the outside. As I am sharing the ISP router with my roommates removing it is not an option.

I have set up the host exposure on the ISP router to point to the OpenWrt router and on the OpenWrt router I have set up an IPv4 Port forward and a traffic rule for IPv6 as I wasn't sure which one it was using on the internal network, but neither seem to work

Here is an image of what the network looks like with corresponding IP adresses:

I have noticed that the systems connected to the OpenWrt router are only getting local IPv6 adresses. Maybe that's part of the problem but I couldn't find a way to change that. My provider does seem to do IPv6 prefix delegation, at least that what it says on the ISP routers configuration page: IPv6 Prefix Delegation: 2a02:8071:3480:xxxx::/62 (I added the xxxx)

So my main questions would be:

  1. How do I set up OpenWrt to use the publicly accessible IPv6 adresses provided by my ISP?
  2. What else do I need to configure to get the ports exposed/forwarded through both routers?

Any help would be appreciated :slight_smile:


Welcome to this forum.

First your version of OpenWrt is not the correct one, it's 22.03, 21.02, snapshot or lower/other versions. See
You mentioned the installed git-version, that can / could be updated to higher (or lower) than regular OpenWrt versions.

Could it be that default WAN port has delegated ipv6 on? This should be off.
Check on Interfaces / Network / active WAN / Advanced settings
@ the bottom:

Oh this is on the latest OpenWrt firmware 22.03. On the older versions its clear @ Interfaces / Network / active WAN / Advanced settings

Keep also the Firewall - Traffic Rules in mind, some IPv6 items are default off.