HooToo HT-TM01 - How to flash Stock Firmware?

@xabolcs , Thanks for providing all of the files and information. I have the exact problem you guys were talking about. If the offer still stands, could you make that custom sysupgrade.bin? It's a bit over my head.

Hello @hashcraft95!

Using an official 19.07.x release is easier than a random custom build from a random community member.


  • sysupgrade to latest 19.07 (e.g. openwrt-19.07.4-ramips-rt305x-ht-tm02-squashfs-sysupgrade.bin),
  • install kmod-mtd-rw
  • insmod it: insmod mtd-rw i_want_a_brick=1

And you are there: with writable partitions.

Instead that custom sysupgrade I could provide a script later, which would flash the original Bootloader back to the device.

1 Like

Insmod was my missing link, I got it up and running stock. Thanks so much!

1 Like

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

Problem is that this would close the topic in a few days which I don’t want in case people have problems and wanna ask things :wink:

I prefer marking this as solved too ... but before that, it would be nice to:

  • create a minimal HooToo HT-TM01 device page on Wiki - independently from that HT-TM02
    • document the steps of this "Revert to Stock, but from wingspinner's build"
    • link this topic for the details
  • create a new backup archive:
    • readme.txt - with the steps
    • Bootloader.bin, Kernel_RootFS.bin, params.bin, Rootfs.bin
    • answer your wingspinner issue #21: where/how to edit that params.bin
  • put the new backup archive to archive.org (like TL-WR1043ND v4 EEPROM dump)

Yep that’s why I’m holding off for now :slight_smile: Until everything’s set up so others can easily follow along in case theirs is screwed up too.
I guess there’s no way to supply a sysupgrade image for people already on a working OpenWrt to easily revert? And then additional steps for people who screwed their install up beyond repair :slight_smile:

Feel free to add usefull information about this device.

1 Like

I tried upgrading the firmware of my HooToo Tripmate Nano (HT-TM02) but failed, now the device's blue LED keep on blinking and I am not able to see the WIFI network, device became unusable, I have tried to reset by inserting the pin but it seems not to be working.

Can anybody help me to get my HT-TM-02 back to life

HT-TM02 had to switch to source-only, exactly of the same error.

Your last hope is the 19.07 release.

Thanks for creating the new openWRT page for the HooToo TM01. I'm happy to add instructions there, but please confirm what is the recommended installation procedure for a factory-new TM01:

  • install the OpenWrt 19.07 "Install" firmware linked there straight from the stock menu?
  • install wingspinner's TM02 image (using an empty USB stick), and then sysupgrade to 19.07?
  • or simply install the official release recommended on the generic openWRT page for TM01–04?

Hi @ubr :wave: !

Well, it's a little bit complicated. Let me explain.

Sadly the current support isn't as good as it could (should? :thinking:) be:

  • it overwrites device specific parts of the device: the params partition
  • it changes the way of the TFTP recovery
    • it listens on another address
    • it uses different filename
    • it uses one file instead of separate kernel and rootfs files
  • it creates a full backup to the usb drive where from the user installed, but
  • the user doesn't know about it, and wouldn't put it to a safe place

Because of the above I won't recommend the current way of installation. :confused:

I did my experiments (thanks @jwmullally for the initial work) about creating a safer device support which uses only the 1536 k Kernel_RootFS for kernel, and the 6144 k ​Rootfs partition for rootfs.
It's safe to use, and compatible with the official releases (currently 19.07.7).
(It's not finished yet, in terms of documentation :sweat_smile:)

But it's still a community build from a random guy from the Forum. :upside_down_face: So I couldn't recommend this too! :grinning:

Hi xabolcs, thanks four your quick response!

So what's the best way forward, given the situation?

  • happy to install your random-guy community build. I'd trust you :slightly_smiling_face: And I'd happily contribute to user-friendly documentation :sunglasses:
  • also fine to keep a USB stick in a safe place. Actually, if I get to install OpenWRT once on my TM01, I assume I'll be fine. I will run shairport-sync and that's it. If needed, I could live without OpenWRT updates etc.
  • it would be nice to be assured that with OpenWRT, the TM01's internal battery can still power the device. E.g. so that my TM01 can run for a while without external power attached, and re-charge later again when external power is available.
  • And in turn, ideally, that the battery could run in a way that the TM01 can still charge other devices if needed.

See my previous comments! :wink:

The most valuable contribution would be, IMHO:

After that, you could write about the two way of installing OpenWrt to the device with its pros and cons:

  • wingspinner's way:
    • easy installation through web interface :white_check_mark:
    • it creates a full backup from the device :white_check_mark:
      • should be put to a safe place
      • should be put to a safe place
      • should be put to a safe place
      • should be put to a safe place
      • should be put to a safe place
      • should be put to a safe place
      • should be put to a safe place
      • should be put to a safe place
    • it overwrites some device specific partition :x:
    • it needlessly replaces factory U-Boot :x:
    • which means other ways of TFTP recovery :x:
  • random community member, xabolcs's way:
    • no easy way installation (== TFTP recovery) :x:
    • compatible with original partition layout: 1536k kernel + 6144k rootfs :white_check_mark:
    • it keeps device specific partitions and U-Boot intact :white_check_mark:
      • it's compatible with the factory TFTP recovery
      • it's easy to revert to stock
      • keeps device's identity
    • created by Image Builder :white_check_mark:
      • no need for initial flashing, compatible with official release from the beginning
      • reproducible, customizable

After these are written down, then you could continue with the steps of installing them.
Please note, there is no easy way to go back and forth between the two installation. They aren't combatible with each other.
The only way is through stock firmware.

After these are written down, you could contribute to my readme.md, about installing, using and rolling back to stock, ...

Shairport-sync? I went to Snapcast way! :wink:

Well, I dug up my old HT-TM04 thinking I could use it in the vehicle on long roads, but the Android app will no longer works and found OWRT is supported on here. Apparently the same as the TM02, I started and use the option to firmware update in the stock unit:


This worked, I logged in and poked around, then found the page for this unit here: https://openwrt.org/toh/hwdata/hootoo/hootoo_tripmate_elite_ht-tm04 which shows newer version of OWRT.

So from there I downloaded


Which went well. But checking through the menus, it was missing the Service menu that the previous version had as well as no way to map the USB drive.

So tried to flash the previous one back:


Now it's hosed. Green light and Blue light are solid. Is there a way out of this? I can set up a TFTP but I couldn't find any stock firmware for this particular model.

Any help would be appreciated. Can't find any write up or links to the firmware although I saw someone posted some files here mid-thread...


This could become an interesting project. Obviously I prefer following your second option :slight_smile:

I'm just not sure how to help best, i.e. how to figure out how to actually go that route and install OpenWRT that way.

Where in your process are you stuck? Would it help you if I try opening my TM01 and attaching a serial connection, as I understand from your other post? I've done this in the past with other devices so I assume it's not a big challenge here, too.

But what would be a next step then? And how would we proceed from there?

Hi @teredactle !

You nicely softbricked your HT-TM04! :upside_down_face:

Factory files (like the openwrt-ramips-rt305x-ht-tm02-squashfs-factory-r44945-ws.bin) are for installing OpenWrt through vendor firmware, e.g. it's web UI.
You have to use factory.bin files only once! When your device first met with OpenWrt.

Sysupgrade files (openwrt-19.07.7-ramips-rt305x-ht-tm02-squashfs-sysupgrade.bin) are for installing OpenWrt through OpenWrt.
You have to use sysupgrade.bins files for upgrading and downgrading between OpenWrt versions.

You used factory.bin when your device already had OpenWrt installed. So you bricked. :man_shrugging:

Yep. Official OpenWrt release images contains a minimal package list, and the end users had to install the packages of their needs. (Snapshot images don't even contain LuCi.)

Wingspinner's images are prepared and filled with nice packages. :+1:

You have to revive your HT-TM04 through TFTP recovery!
Rewind the thread to my comment from Oct. 2020 and read through the whole thread! :wink:

You need your backup what openwrt-ramips-rt305x-ht-tm02-squashfs-factory-r44945-ws.bin did for you to your flash drive!
You need a TFTP server too. Windows and Linux has a few.

All your questions should have been answered in this thread! Read it carefully!
If not, then please split into a new HooToo HT-TM04 - How to flash Stock Firmware thread!

Ouf, I should have used this to downgrade I guess: openwrt-15.05.1-ramips-rt305x-ht-tm02-squashfs-sysupgrade.bin

I hope it's in this folder HT-FLASH on the USB stick.

This is not a problem.

I will look through this thread and see if I can do the recovery through TFTP.

Thanks for responding!!!

1 Like

Put that HT-FLASH directory to a safe place!

Good luck! You have all the files for success! :+1:


Is this folder the backup of the OEM/stock firmware, when one first does the upgrade to the factory.bin?
Or does that get overwritten again, when one does Luci upgrade using sysupgrade.bin? If it's the latter, I think I'm screwed... :slight_smile: