So I recently bought three Netgear R6700v2 routers off eBay after watching this video which talked about flashing routers so that I can DIY my own mesh network.
I was able to flash my routers okay, removed the pre-installed wpad*basic and then installed the wpad-mesh-openssl per the video.
I was able to configure the "base station" router and the two "satellites" without much issue (took a few tries on account of errors I made in the sequence of operations, but I think that I've got it down now).
However, when I am just pinging the "base station" router (all three are currently sitting next to each other, in my basement), there are two things that I noticed:
The router has a high load average (on the order of 6.05/5.85/5.02).
It has about a 1.8% packet loss and a maximum ping time of 286.177 ms with a ping time standard deviation of 25.200 ms.
As a result of the high load average, my clients (Maingear Vector Pro 2, MacBook Air, 2 iPhones, and an iPad Air 2) all are having a hard time connecting to said network.
Is there something that I can do or check to try and figure out why the load averages, ping times, and packet losses are relatively high?
Yes, not a problem. However, being that I am new here, if you don't mind pointing me in the right direction as to how I/where I would be able to find those files, then I would be able to provide them. Thank you.
Also, given the high-ish ping times, I don't have a reliable ssh connection into the routers.
Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
Remember to redact passwords, MAC addresses and any public IP addresses you may have:
BusyBox v1.36.1 (2025-02-03 23:09:37 UTC) built-in shell (ash)
_______ ________ __
| |.-----.-----.-----.| | | |.----.| |_
| - || _ | -__| || | | || _|| _|
|_______|| __|_____|__|__||________||__| |____|
|__| W I R E L E S S F R E E D O M
-----------------------------------------------------
OpenWrt 24.10.0, r28427-6df0e3d02a
-----------------------------------------------------
root@mesh0:~# ubus call system board
{
"kernel": "6.6.73",
"hostname": "mesh0",
"system": "MediaTek MT7621 ver:1 eco:3",
"model": "Netgear R6700 v2",
"board_name": "netgear,r6700-v2",
"rootfs_type": "squashfs",
"release": {
"distribution": "OpenWrt",
"version": "24.10.0",
"revision": "r28427-6df0e3d02a",
"target": "ramips/mt7621",
"description": "OpenWrt 24.10.0 r28427-6df0e3d02a",
"builddate": "1738624177"
}
}
root@mesh0:~# cat /etc/config/network
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fded:bca:b9d3::/48'
option packet_steering '1'
config device
option name 'br-lan'
option type 'bridge'
list ports 'lan1'
list ports 'lan2'
list ports 'lan3'
list ports 'lan4'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr 'x'
option netmask '255.255.255.0'
option ip6assign '60'
config interface 'wan'
option device 'wan'
option proto 'dhcp'
config interface 'wan6'
option device 'wan'
option proto 'dhcpv6'
root@mesh0:~# cat /etc/config/wireless
config wifi-device 'radio0'
option type 'mac80211'
option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
option band '2g'
option channel '1'
option htmode 'HT20'
option disabled '1'
config wifi-device 'radio1'
option type 'mac80211'
option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'
option band '5g'
option channel '44'
option htmode 'VHT80'
option cell_density '0'
config wifi-iface 'wifinet0'
option device 'radio1'
option mode 'ap'
option ssid 'x'
option encryption 'psk2'
option key 'x'
option ieee80211r '1'
option ft_over_ds '0'
option ft_psk_generate_local '1'
option network 'lan'
config wifi-iface 'wifinet1'
option device 'radio1'
option mode 'mesh'
option encryption 'sae'
option mesh_id 'x'
option mesh_fwding '1'
option mesh_rssi_threshold '0'
option key 'x'
option network 'lan'
root@mesh0:~# cat /etc/config/dhcp
config dnsmasq
option domainneeded '1'
option boguspriv '1'
option filterwin2k '0'
option localise_queries '1'
option rebind_protection '1'
option rebind_localhost '1'
option local '/lan/'
option domain 'lan'
option expandhosts '1'
option nonegcache '0'
option cachesize '1000'
option authoritative '1'
option readethers '1'
option leasefile '/tmp/dhcp.leases'
option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
option nonwildcard '1'
option localservice '1'
option ednspacket_max '1232'
option filter_aaaa '0'
option filter_a '0'
config dhcp 'lan'
option interface 'lan'
option start '100'
option limit '150'
option leasetime '12h'
option dhcpv4 'server'
option dhcpv6 'server'
option ra 'server'
list ra_flags 'managed-config'
list ra_flags 'other-config'
config dhcp 'wan'
option interface 'wan'
option ignore '1'
config odhcpd 'odhcpd'
option maindhcp '0'
option leasefile '/tmp/hosts/odhcpd'
option leasetrigger '/usr/sbin/odhcpd-update'
option loglevel '4'
root@mesh0:~# cat /etc/config/firewall
config defaults
option syn_flood 1
option input REJECT
option output ACCEPT
option forward REJECT
# Uncomment this line to disable ipv6 rules
# option disable_ipv6 1
config zone
option name lan
list network 'lan'
option input ACCEPT
option output ACCEPT
option forward ACCEPT
config zone
option name wan
list network 'wan'
list network 'wan6'
option input REJECT
option output ACCEPT
option forward REJECT
option masq 1
option mtu_fix 1
config forwarding
option src lan
option dest wan
# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
option name Allow-DHCP-Renew
option src wan
option proto udp
option dest_port 68
option target ACCEPT
option family ipv4
# Allow IPv4 ping
config rule
option name Allow-Ping
option src wan
option proto icmp
option icmp_type echo-request
option family ipv4
option target ACCEPT
config rule
option name Allow-IGMP
option src wan
option proto igmp
option family ipv4
option target ACCEPT
# Allow DHCPv6 replies
# see https://github.com/openwrt/openwrt/issues/5066
config rule
option name Allow-DHCPv6
option src wan
option proto udp
option dest_port 546
option family ipv6
option target ACCEPT
config rule
option name Allow-MLD
option src wan
option proto icmp
option src_ip fe80::/10
list icmp_type '130/0'
list icmp_type '131/0'
list icmp_type '132/0'
list icmp_type '143/0'
option family ipv6
option target ACCEPT
# Allow essential incoming IPv6 ICMP traffic
config rule
option name Allow-ICMPv6-Input
option src wan
option proto icmp
list icmp_type echo-request
list icmp_type echo-reply
list icmp_type destination-unreachable
list icmp_type packet-too-big
list icmp_type time-exceeded
list icmp_type bad-header
list icmp_type unknown-header-type
list icmp_type router-solicitation
list icmp_type neighbour-solicitation
list icmp_type router-advertisement
list icmp_type neighbour-advertisement
option limit 1000/sec
option family ipv6
option target ACCEPT
# Allow essential forwarded IPv6 ICMP traffic
config rule
option name Allow-ICMPv6-Forward
option src wan
option dest *
option proto icmp
list icmp_type echo-request
list icmp_type echo-reply
list icmp_type destination-unreachable
list icmp_type packet-too-big
list icmp_type time-exceeded
list icmp_type bad-header
list icmp_type unknown-header-type
option limit 1000/sec
option family ipv6
option target ACCEPT
config rule
option name Allow-IPSec-ESP
option src wan
option dest lan
option proto esp
option target ACCEPT
config rule
option name Allow-ISAKMP
option src wan
option dest lan
option dest_port 500
option proto udp
option target ACCEPT
### EXAMPLE CONFIG SECTIONS
# do not allow a specific ip to access wan
#config rule
# option src lan
# option src_ip 192.168.45.2
# option dest wan
# option proto tcp
# option target REJECT
# block a specific mac on wan
#config rule
# option dest wan
# option src_mac 00:11:22:33:44:66
# option target REJECT
# block incoming ICMP traffic on a zone
#config rule
# option src lan
# option proto ICMP
# option target DROP
# port redirect port coming in on wan to lan
#config redirect
# option src wan
# option src_dport 80
# option dest lan
# option dest_ip 192.168.16.235
# option dest_port 80
# option proto tcp
# port redirect of remapped ssh port (22001) on wan
#config redirect
# option src wan
# option src_dport 22001
# option dest lan
# option dest_port 22
# option proto tcp
### FULL CONFIG SECTIONS
#config rule
# option src lan
# option src_ip 192.168.45.2
# option src_mac 00:11:22:33:44:55
# option src_port 80
# option dest wan
# option dest_ip 194.25.2.129
# option dest_port 120
# option proto tcp
# option target REJECT
#config redirect
# option src lan
# option src_ip 192.168.45.2
# option src_mac 00:11:22:33:44:55
# option src_port 1024
# option src_dport 80
# option dest_ip 194.25.2.129
# option dest_port 120
# option proto tcp
Where there is an x, it means that the information has been redacted per your recommendation/reminder. (Thank you, for the reminder. That is greatly appreciated.)
I appreciate your help.
edit
Sorry -- that was for the "base station". I'll have to pull the same commands for the other two routers tomorrow as it is getting quite late here.
option ipaddr 'x': As long as you are using a private network segment, there is no harm in sharing it (and, if you are using a public network segment, then there is an issue).
option disabled '1': Any reason why radio0 is disabled (not that it matters in this issue, just curious)?
option ieee80211r '1': I would start with the simplest working configuration, then add the optimizations.
I didn't realise that this mattered nor that it would make a difference, but I can certainly try it, when I get home tonight.
Yeah, it's in the 192.168.x.y segment, i.e. not using a public segment.
So, I've been doing a lot of testing with this since my third router arrived. I've lost count how many times I've reset the routers by now.
But I created a mesh and WiFi on the 2.4 GHz radio, and for some reason, the 5 GHz radio won't come online no matter how hard I try (channel 153, 80 MHz width) across all three routers.
So, just as I was posting this, I ended doing the factory reset (held the reset button for 10 seconds after it finished booting, and then released the reset button) again.
So this time, I figured that I'd try putting the mesh backhaul on the 5 GHz radio instead (channel 44, 80 MHz width) and that seemed to work.
I might add the 2.4 GHz WiFi later on, but for now, just to reduce the number of potential variables, I only have the mesh on the 5 GHz radio and WiFi on the 5 GHz radio as well.
Yeah, I can try that as well.
I only enabled the Fast Transition in preparation for deployment in my two storey (plus basement), ~1000 ft^2 house.
When I first set it up, I immediately moved my network over from my eero 6 mesh over onto this an it quickly overwhelmed it. (30-40% packet drop rate when pinging google.com)
So, I brought my eero 6 mesh back up online, moved everything back over, and now I am just studying what happens if I just have the "base station" (the first router/gateway) plus the two "satellites" up and running, to see what the network would do, just with that, and have all three routers sitting right next to each other.
And then on top of the high load averages and high packet loss, per the YouTube video instructions (re: turning the second and third routers into dumb routers (i.e. disabled dnsmasq, firewall, odhcpd, removed the WAN interfaces, added the wan port to the lan bridge, and then set the lan interface to be a DHCP (v4) client), deleting the firewall zones) -- when I have the two "satellites" physically plugged into the "base station" then I can see that it will pull an IPv4 address.
But if I disconnect the network cable, then I can't manage it over the mesh network anymore. So not sure what that's about, but working on tackling one problem at a time.