HH5A - LuCI stops working after changing subnet

Hello all. I am new to these forums, so sorry if this is in the wrong place.

I am trying to change my router's IP address into another subnet. Here's the issue: LuCI does not work after I do so.

I can change my address via SSH, or via LuCI, it does not matter. Once I have changed it, I must change my laptop's network settings to match the relevant subnet, that's all fine. But I cannot then get access to the web interface. If I run nmap on my laptop, I can see that the OpenWRT router does indeed have the correct IP address I want it to have (

Chrome gives me a connection refused error.

Now, I have access to SSH, so I may as well have a look if I find any issues. uhttpd is running. uci show shows the correct address. So does the /etc/config/network file. I can also restart the network and uhttpd services as much as I like.. It does not make a difference.

I know the issue must be when changing subnets. I have reset my router multiple times. With this clean config, the only thing I do is change the IP address, but it does not work.

I have tried changing to the SAME subnet. And that works..

Here's some things I have tried:

  • edit /etc/config/uhttpd and change the ip to my new internal IP.
  • Use https and http
  • Check firewall setting
  • Disable firewall entirely
  • Downgrade versions. I have tried stable, old stable, and 18.06.0

netstat -plen | grep :80

tcp    0    0*    LISTEN    1412/uhttpd
tcp    0    0  :::80    :::*    LISTEN    1412/uhttpd

Somewhat related posts

(None have helped me at all)

i have same issue on snapshot of openwrt for 3 day for "resolve" :

/usr/sbin/nginx -s reload

for me solved with this ssh cmd
some bug with latest luci-nginx ?

fwiw, I just tried changing IP on my HH5a with 18.06.4

from to subnet mask LuCI ok
then tried subnet mask LuCI ok
then tried subnet mask LuCI still accessible.

Only extra packages installed are SQM and DDNS, neither are enabled.

Using Google chrome (with free ablock) on Windows 10 laptop with Defender antivirus.

Have you tried using a different device like smartphone or tablet?

Yes, I have. I have tried multiple browsers too. Firefox, Chrome, and the chrome app on my phone.

Are you using nginx rather than the default uhttpd?

uhttpd was down for three day im switched to nginx on rpi4 .
why nginx is no good ?

Is your HH5a's DHCP server providing IP address to your laptop, or are you manually configuring your own static settings on the laptop?

I can't think of any other ideas why you are having issues even when using other devices. My earlier brief test was with Win10 laptop wired direct to a HH5A's LAN port btw. HH5A's DHCP serving IP to the laptop

Nope. I'm not using dhcp.

I have some manual presets, which I switch between to make things a bit quicker.

niginx isn't bad. In fact, it's really useful.

But uhttpd is very lightweight, and also it's the default.

okay okay i using nginx because the openwrt how to say is best :s thanks for information friend , next snapshot im trying uhttpd

So can I suggest you try DHCP to confirm LuCI works?

If using manual settings, is the subnet mask correctly set on your devices and matches the HH5A ?

Update: I did a pin reset of my HH5A with 18.06.4, restoring all openwrt to defaults. Then using win10 laptop via ethernet, logged into with LuCI using Google Chrome. Edited ONLY the LAN IP address to Pressed 'Save & Apply and after the 30 second count down, confirmed I wanted to accept the changes . Unplugged LAN cable a few times to force laptop to renew its IP address. Logged into using LuCI.

I have tried using DHCP in the past. It has no helped.

Yes, my settings are correct. Subnet mask is correct, and my PC's IP address is in the range.

I can connect to the router via SSH, when it is on the new IP.

The next thing I will attempt is to use telnet. If that works, there must be an issue with my browser.

I have found a solution. By using turning off HTTPS redirect in uhttpd settings, and using incognito mode in chrome, I can access the HTTP site. The HTTPS site does not work at all.

Also, I do not understand why, but firefox, or any other browser, does not work. Even in private browsing mode.

If anyone has any ideas why this happens, please post your thoughts. My issue may be solved, but I don't necessarily need HTTPS. Others may need / want SSL.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.