Help with WRT1200AC and EA3500

The SSA file or the ZIP file? (SSA is inside the ZIP file.)

I would assume the SSA file so that the router doesn't have to unzip it on top of other things, but I tried the SSA file and it seemed to not work. Just my luck.


Should I flash 19.07 again, then try stock? To see if perhaps it's being weird about partitions like when flashing away from Linksys firmware.

The WRT1200AC has a powerful SoC and should have no issues with any modern OpenWrt codebase. Do keep in mind 22.03 is broken on those devices due to a DSA switch issue with kernel 5.10. If you want to use it as a router, switch to master which uses kernel 5.15.

1 Like

So I flashed 19.07 again it's on both partitions. However, after flashing stock again, it still wouldn't boot. Managed to get it to recover and here's what "Adv Reboot" is reporting to me.

01	Alternative   OpenWrt 19.07.9 (Linux
02	Current       OpenWrt 19.07.9 (Linux 4.14.267)

Looking at the Linux versions... I'm guessing the stock partially flashed but not fully?

Master? Is that like the latest release that isn't labeled as "stable" yet?

The builds are labeled snapshots and do not contain the web UI (LuCI) but you can install that afterwards.

Okay, have the latest snapshot on the 1200. Was noticing some lag but trying to narrow down the reason. I had forgotten to change a couple of settings, so seeing if that will have any affect. Namely, enabling STP and disabling DHCP. At times the lag was terrible, as I tried a couple of times, the lag became less of a problem. I do want to mention that this lag didn't start right away (as did with other flashes in the 21/22 series).

I have an Asus Z97-WS mobo so I'm able to connect to the main network and another router (1200) to tinker with. I had also connected the 1200 to the main router (software reasons) and thus the STP/DHCP stuff. It seems to have helped some, but still noticing lag when trying to browser (LuCI). Issue completely clears up if it's only the computer connected to the 1200, and the 1200 isn't connected to the main network at all. I have deleted both WAN/WAN6 and changed the br-lan to include the physical WAN port (ie, 5 port switch... well 4, since LAN1 doesn't work). Plan is to replace another router with the 1200 and it won't be an end-point, but rather part of a chain, so it has to be able to handle being in the middle of the network vs an end-point.

Where you trying to save the previous config?

Have you tried to restore defaults then upgrading using the sysupgrade image for the EA3500?

I had recently put it in front of my network to show 22.03.3 is working:

I had ran into a problem before with luci lagging, slow and instability due to too many adblock lists and remove a few to stablize the router, but I am not sure how the EA3500 plays in your network?

Good luck


   Current     Planned
A. WRT1200AC   EA8100  (Primary)
B. E2000       EA3500
C. E2000       WRT1200AC
D. EA3500      MR8300

The EA8100 and MR8300 are already in place and are running the latest stable OpenWRT versions available for them (22.03.3 and 22.03.2 respectively).

Note: A & B, are close in proximity to each other, as are C & D. So while it may seem unbalanced in regards to speed wifi abilities, it's not.

Planned/desired packages include: wpad-wolfssl (full), dnsmasq-full, luci-app-ttyd, DAWN (at least for those that it is available for), and luci-app-statistics. (Obviously the other packages that are necessary for these to run as well, I'm listing the main ones that will automatically include the others as well.) Primary has a few other things installed as well, but that's irrelevant. The ttyd app isn't crucial, so if it's causing any problems, it can be removed (and won't be missed).

For both 1200 and 3500, I wasn't attempting to save the config during upgrade. I deliberately went with fresh settings to avoid "carried over" settings from being a potential issue.

Okay so whipped out my usb/serial adapter (ty Silicon CP210x!) and managed to get the stock firmware installed, then 22.03.3 installed and Luci booted right on up.

Now to tinker with it and see if there are any issues.