Help with WRT1200AC and EA3500

Have both running 19.07.9 currently.

With the 1200, if I try to install anything newer, attempting to interact with it becomes sluggish/unreliable, and I have to be on my toes in order to flash it back to the 19.07.x series. Luci would work, but again, unreliable as the connection would keep dying out.

With the 3500, the system would fail to boot and I had to do the little button press thingy to gain enough access to flash it back to the 19.07.x series.

So are these two devices simply not capable of going to anything newer, or is there a trick that I just didn't come across that will make them work just fine?

Both should have no issue running OpenWrt 22.03. The EA3500 may be a bit weak, but will still run just fine.

Perhaps it would be useful to know the following:

  • did you use the standard images available on the downloads site, or did you create a custom image?
  • have you attempted to keep and/or restore your previous configuration?
  • have you installed and/or upgraded any packages?
  • Do you have a complex configuration?

Premade sysupgrade package, not saving settings.

Right away the problems that I mentioned exist. Both are v1 (no version numbers next to the model number).

Does the network performance work as expected (routing and/or wifi), or is that also slow?

For the interface, are you using the LuCI web interface or ssh? If web interface, have you tried clearing your cache and/or using a different browser?

What have you changed in your config (or is this truly an immediate issue -- before you even get to the point of modifying the config)?

With the 1200, as soon as it boots up, it's sluggish (both LuCI and SSH). I can type something via CLI and it might take a minute before it appears. I can copy/paste commands, though it's still a matter of it acknowledging that it received anything. I was able to get it back to 19.07.9 by using WinSCP to upload the sysupgrade package to /root and then flashing it from there (SSH). This is before even being able to change anything.

EA3500, I had to do the button press to get the Barry Allen flashing speed so I could TFTP into it to recover. It wouldn't complete the booting process.

I'm running 22.03 on a much less powerful device (an E3000), and while it's not great, it is nothing like what you describe -- it's perfectly serviceable.

Maybe ssh into the device and get the following info:

ubus call system board
df -h

and then look at what is happening wtih top
(I'd recommend htop, but you need to install that, and I'm guessing that'd be painful

1 Like

I hate you (not really). I bricked my E3000 a few years back and haven't been able to recover it. I had bricked it once before but managed to revive it, but then tried to do another upgrade (using wrong firmware I think, oops) and all it does now is blink blue on the power button. Shorting pins doesn't work, and not sure how to attach wires to the serial port (WAN port) to try that method. lol

That said, I get an error message when trying to upgrade past the 19.07 series. One I'm sure you've seen mentioned plenty of times.

Device linksys,caiman not supported by this image Supported devices: linksys,wrt1200ac armada-385-linksys-caiman linksys,caiman - Image version mismatch: image 1.1, device 1.0. Please wipe config during upgrade (force required) or reinstall. Reason: Config cannot be migrated from swconfig to DSA Image check failed.

The uploaded image file does not contain a supported format. Make sure that you choose the generic image format for your platform.

Before trying it again, should this be a warning sign, or is this to be expected when flashing from 19.x and before to something newer?

Could you be more specific with version number?

I have this model as well and already had upgraded to the current stable release 22.03.3 for a probaby a week ago or so using imagebuilder sysupgrade image.

Luci is running smoothly on the EA3500 at least in my network but I do rotate the models I own around and can put it back in front of my network and check again if I experience some performance issues later tomorrow.


When I had bricked this device in the past (I don't remember the circumstances), I actually did (successfully) use the pin-short method. It is most certainly not recommended, but I got it to work (I had to use a loupe and a very small metal object to short the correct pins and avoid any accidental damage).


The warning is entirely expected.
I'm not an expert on your two device, but I do recall that a few Linksys models actually need to be flashed back to stock and then utilize a factory image to 22.03 due to a partition map change.

wrt1200ac: openwrt-22.03.2-mvebu-cortexa9-linksys_wrt1200ac-squashfs-sysupgrade.bin

I have that ready to flash.

030c169cd84d367c18a8c823817a566ae64bc42d70013de33b2e04ee622fcd6d Website
030c169cd84d367c18a8c823817a566ae64bc42d70013de33b2e04ee622fcd6d Router

Actually the EA3500, was it a custom build in any way?

Is memory at ok or at a reasonable percentage on the EA3500 just in case you were expeiencing slow downs, disconnects etc?

EA3500, premade openwrt build. The one I tried was openwrt-21.02.5-kirkwood-linksys_ea3500-squashfs-sysupgrade.bin

The problem on the 3500 was that it wouldn't fully boot. Could never get it to the point of being able to use Luci or it showing as a connected network, etc.

try taking the EA3500 back to stock, and then flashing to OpenWrt from there.

Linksys firmware, then OpenWRT 'factory'?

yes... exactly.

Or... you could try using the factory image and flashing via tftp (which should basically be the same as returning to stock).

To clarify, when you say factory, you mean an OpenWRT 'factory' image, correct?

So, stock = company firmware, factory = OpenWRT? I want to make sure that I don't misunderstand.

Yes. Sorry for any confusion.

Stock = linksys firmware
Factory = openwrt factory image

You should be able to use the factory image with the tftp flashing method - that is the equivalent of rolling back to stock and then using the factory image to install openwrt.

You weren't causing any confusion, I've just learned to be extra cautious at times. I'd rather clarify and be right than to find out that... oops, I wasn't.

When I bricked it the first time around, shorting the pins fixed it for me. I don't know if the knowledge came from my asking for help, but I do know that the image provided to me (on which pins to short) has made its way to other sites. This was back in 2012 that I asked for help (using dd-wrt at the time) and a guru named Eko provided me with an image, telling me what I needed to do. It worked.

So I was a bit sad when it didn't save my (donkey) the next time around. :rofl:

1 Like

To confirm, TFTP is pressing the button, connecting to despite it not showing up in arp -a, then flashing a firmware from there? That didn't work, so flashing to 19.07 then doing it the long way around. (stock then factory)

Tftp instructions can be found here:

But going back to stock is fine, of course.