Help with VLANS on WRT3200ACM

I can configure the vlan like the examples and the two vlans will not talk to each other.

also seeing: "mv88e6085 f1072004.mdio-mii:00: VTU member violation for vid 1, source port 3" is this the problem? This error is very easy to get just remove untagged from vlan 1.

Have also added eth0 as tagged and did not help.

Been working on this for nights, and can not make it work,

very simple vlan 1 lan 2,3,4 and vlan2 lan one all untaged.
This is not will look like when finished if can make it work.

Version OpenWrt 22.03.2 r19803-9a599fee93 / LuCI openwrt-22.03 branch git-22.288.45147-96ec0cd

root@OpenWrt:/etc/config# cat network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdc3:c5f8:1077::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config interface 'lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option device 'br-lan.1'

config device
        option name 'wan'
        option macaddr '26:f5:a2:c1:eb:08'

config interface 'wan'
        option device 'wan'
        option proto 'dhcp'

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'

config bridge-vlan
        option device 'br-lan'
        option vlan '1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config bridge-vlan
        option device 'br-lan'
        option vlan '2'
        list ports 'lan1:t'

config interface 'VLAN2'
        option proto 'static'
        option ipaddr '192.168.2.1'
        option netmask '255.255.255.0'
        option device 'br-lan.2'

Well the first problem here is actually a switch driver fault in 22.03 that makes the switch to a hub so all ports are the same whatever vlan setup you do.
So the first thing you should do with this kind of multi vlan setup on this device family (mvebu) is to upgrade to a master image.

1 Like

The master image the dev snapshot?

https://downloads.openwrt.org/snapshots/targets/mvebu/cortexa9/
The new switch driver in kernel 5.15 in dev snapshot (master code) has a fix for the β€œhub like behavior”. Not sure it will fix the actual problem but I can’t see any big problem with your config either.

So let’s start with a working switch driver.

Remember that dev snapshot doesn’t have luci installed by default so if you like luci you need to run

dpkg update
dpkg install luci
1 Like

What is diff in openwrt-mvebu-cortexa9-linksys_wrt3200acm-squashfs-sysupgrade.bin v openwrt-mvebu-cortexa9-linksys_wrt3200acm-initramfs-kernel.bin? and what do a want?

now on OpenWrt SNAPSHOT r22555-cd8c698f78 / LuCI Master git-23.093.56957-2145121
still,
get kern.err kernel: [ 1582.640787] mv88e6085 f1072004.mdio-mii:00: VTU member violation for vid 1, source port 3

Initramfs is a imaginary image for development that is installed and run directly on the ram memory so a simple reboot erases it.

Initramfs is good to use if you don’t know if your new code is about to crash and burn your device. Usage of this during development and installation of new code over a couple of 100times also saves cycle life of the flash memory.

But it can’t be installed as normal installation, it is installed at boot usually with u-boot and tftp installation.

IIRC things are reversed, so lan1 (port 3) is getting a packet with VID 1 and it is not a member.

Are you trying to achieve something specific or just learning the ropes?
This can be done without using bridge vlan filtering.

How would you recommend doing it?

This is what look to do may change.

Tried without filter and vlan 21 does get ip from mesh device, direct on port 1 at this time.

root@OpenWrt:/etc/config# cat network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdd4:08d4:482c::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device
        option name 'wan'
        option macaddr '26:f5:a2:c1:eb:08'

config interface 'wan'
        option device 'wan'
        option proto 'dhcp'

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'

config device
        option type '8021q'
        option ifname 'lan1'
        option vid '21'
        option name 'lan1.21'

config interface '21'
        option proto 'dhcp'
        option device 'lan1.21'

Can I not use WRT3200ACM with VLANs?

Yes, at least it WFM, but some things are (were last I tried) broken.

so looks like need to start looking at other options. any recommended routers that do work with vlans?

I see nothing in the OP that is not achievable; but see my first post, as you had it wrong. Maybe present what you are attempting, not with a pic but a simple matrix.

Port 1 Vlan 1,21,150,160
Port 2 Vlan 1
Port 3 Vlan 1
Port 4 Vlan 1,10,15,21,150,160
Wifi Vlan 1,2

Starting with simple config vlan 1, ports 2-4 and vlan 21 on port 1
What did I do wrong?

updating to OpenWrt SNAPSHOT r22561-930e702d72 / LuCI Master git-23.093.56957-2145121 is test shortly
Is there a change log?

Appear to be conflating lanx with portx, not sure if this is what you are after:

╔═════╦═════════╦═════════╦═════════╦═════════╗
β•‘ VID β•‘   LAN1  β•‘   LAN2  β•‘   LAN3  β•‘   LAN4  β•‘
β•‘     β•‘ (port3) β•‘ (port2) β•‘ (port1) β•‘ (port0) β•‘
╠═════╬═════════╬═════════╬═════════╬═════════╣
β•‘ 1   β•‘    t*   β•‘    t*   β•‘    t*   β•‘    t*   β•‘
╠═════╬═════════╬═════════╬═════════╬═════════╣
β•‘ 10  β•‘         β•‘         β•‘         β•‘    t    β•‘
╠═════╬═════════╬═════════╬═════════╬═════════╣
β•‘ 15  β•‘         β•‘         β•‘         β•‘    t    β•‘
╠═════╬═════════╬═════════╬═════════╬═════════╣
β•‘ 21  β•‘    t    β•‘         β•‘         β•‘    t    β•‘
╠═════╬═════════╬═════════╬═════════╬═════════╣
β•‘ 150 β•‘    t    β•‘         β•‘         β•‘    t    β•‘
╠═════╬═════════╬═════════╬═════════╬═════════╣
β•‘ 160 β•‘    t    β•‘         β•‘         β•‘    t    β•‘
β•šβ•β•β•β•β•β•©β•β•β•β•β•β•β•β•β•β•©β•β•β•β•β•β•β•β•β•β•©β•β•β•β•β•β•β•β•β•β•©β•β•β•β•β•β•β•β•β•β•

but a quick hack on your OP by way of a start:

network
config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
	option packet_steering '1'
        option ula_prefix 'fdc3:c5f8:1077::/48'

config device
        option name 'switch0'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config bridge-vlan
        option device 'switch0'
        option vlan '1'
        list ports 'lan1:t*'
        list ports 'lan2:t*'
        list ports 'lan3:t*'
        list ports 'lan4:t*'
	option alias 'lan'

config interface 'lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option device 'switch0.lan'

config bridge-vlan
        option device 'switch0'
        option vlan '2'
        list ports 'lan1:t'
	option alias 'voip'

config interface 'voip'
        option proto 'static'
        option ipaddr '192.168.2.1'
        option netmask '255.255.255.0'
        option device 'switch0.voip'

config device
        option name 'wan'
        option macaddr '26:f5:a2:c1:eb:08'

config interface 'wan'
        option device 'wan'
        option proto 'dhcp'

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'

untested, but I think the original post I linked contains the answers.

Wrt3200acm work with vlan, many vlans and trunked ports, period!