Help with Samba4 share

Hello everybody...

I'm reconfiguring my system and I came across an unusual problem, at least for me...

When mounting my external HD, formatted in NTFS in Samba, through the mount point, I see these folders:

OK, they really should be seen... They are correct!

However, when sharing them on the network, regardless of the OS that is accessing the HD, I see these folders:

Did you see the differences? I would like to try to understand why this could be happening...

Below is my Samba4 configuration file (/etc/config/samba4)...

config samba
	option workgroup 'WORKGROUP'
	option charset 'UTF-8'
	option description 'Samba on OpenWRT'
	option interface 'lan'

config sambashare
	option name 'HD_Externo'
	option path '/mnt/sdb1'
	option read_only 'no'
	option guest_ok 'no'
	option create_mask '0666'
	option dir_mask '0777'
	option users 'tesla'

config sambashare
	option name 'HD_Externo'
	option path '/mnt/sdb1'
	option read_only 'no'
	option users 'felipe'
	option guest_ok 'no'
	option create_mask '0666'
	option dir_mask '0777'

config sambashare
	option name 'HD_Externo'
	option path '/mnt/sdb1'
	option read_only 'no'
	option users 'viviane'
	option guest_ok 'no'
	option create_mask '0666'
	option dir_mask '0777'

Below is my fstab configuration file (/etc/config/fstab)...

config global
	option anon_swap '0'
	option anon_mount '0'
	option auto_swap '1'
	option auto_mount '1'
	option delay_root '5'
	option check_fs '0'

config mount
	option target '/boot'
	option uuid '1234-ABCD'
	option enabled '0'

config mount
	option target '/'
	option uuid 'ff313567-e9f1-5a5d-9895-3ba130b4a864'
	option enabled '0'

config mount
	option target '/mnt/sda1'
	option uuid '88f8f53c-5250-9845-8d0f-eefc22de12b9'
	option enabled '1'
	option fstype 'ext4'

config mount
	option target '/mnt/sdb1'
	option uuid '5C16E57D16E55912'
	option enabled '1'
	option fstype 'ntfs3'

Any sugestions?

Thanks!

As you can see, all hidden folders have diacritics in their names, most probably unrecognizable to samba.

2 Likes

Is there any way for Samba4 to recognize characters in the PT-BR language and thus recognize the accent of files and folders correctly in my language?

try a file filesystem with better support in Linux, than NTFS ?

1 Like

No friend, I´m using ext4 on external hard disk...

Better performance in Linux / Openwrt, right?

I can use and format in NTFS, but I think that using ext4, I will gain performance...

I believe that is work now, I´m testing here.

Your original post says ‘formatted in NTFS’?

1 Like

I changed the file systems...

but relax, now, all works perfectly again...

Thanks all...