Help with IPTV configuration

Hello, I need some help in setting up my IPTV box from my router instead of ONT -> IPTV box, instead I want it to be laid down from ONT -> Router -> IPTV.

Problem is the documentation for my IPTV box is limited online, my ISP provider is etisalat and I am not exactly sure if there is VLAN configured for my IPTV box or not. Prior to this I've called my ISP and asked them to disable their PnP management (where they can remote into the router) and VLANs before setting up OpenWRT on my router. My IPTV box is DWI8591S.

If going by the assumption that VLAN isn't disabled for my IPTV box how do I go about starting?

It'll be critical to understand if the IPTV box requires a VLAN to operate -- typically that would mean creating a configuration where the VLAN passes from the wan port through to the desired Ethernet port, but knowing the VLAN ID is absolutely required. If it doesn't use a VLAN, then it should probably 'just work' when plugged into a lan port on your router. But you really need to know this information before you start because without it, you'll be truly stabbing in the dark.

Plugging my IPTV box to LAN port didn't seem to work, on the IPTV box it says "eLifeTV portal is unreachable, please connect IPTV LAN cable." I have Wireshark installed on my router would it be of any help to confirm anything?

Also going through by this old reddit post it seems the user had to configure VLAN for the IPTV box as well.

https://www.reddit.com/r/dubai/comments/6qiees/etisalat_pnp_router_config_updated/

That seems to suggest VLAN ID 18 or 27, so we can try those.

Which physical lan port do you want to use to connect the IPTV box?

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
1 Like

There's also another post by TP-Link but it suggests to use a random VLAN ID, I guess we'll find that out if it's really random or a VLAN ID range.

I want VLAN to be configured on my lan3 port.

root@OpenWrt:~# ubus call system board
{
        "kernel": "5.15.150",
        "hostname": "OpenWrt",
        "system": "MediaTek MT7621 ver:1 eco:3",
        "model": "ASUS RT-AX53U",
        "board_name": "asus,rt-ax53u",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "23.05.3",
                "revision": "r23809-234f1a2efa",
                "target": "ramips/mt7621",
                "description": "OpenWrt 23.05.3 r23809-234f1a2efa"
        }
}
root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option packet_steering '1'
        option ula_prefix 'fdb3:2a6a:9dd4::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '192.168.0.1'
        option ip6assign '64'
        list ip6class 'wan6'

config interface 'wan'
        option device 'wan'
        option proto 'pppoe'
        option username ''
        option ipv6 '1'
        option password ''

config interface 'wan6'
        option device '@wan'
        option proto 'dhcpv6'
        option reqaddress 'try'
        option reqprefix 'auto'
        option sourcefilter '0'

config interface 'wg0'
        option proto 'wireguard'
        option private_key ''
        option listen_port '443'
        list addresses '10.14.0.1/24'
        list addresses '2001:db8::/48'

config wireguard_wg0
        option description 'phone'
        option public_key ''
        option persistent_keepalive '25'
        option route_allowed_ips '1'
        list allowed_ips '10.14.0.2/32'
        list allowed_ips '2001:db8:0:1::/64'

config interface 'guest'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'

EDIT: I think VLAN might still be enabled for my IPTV + VOIP, few days ago I got around by accessing my ONT's webpage after some telnet hackery, I was able to retrieve only this information

It can't be random. It has to match the expected VLAN of the IPTV box and that which the upstream service uses. Unless the "random" is insofar as just trying random values until you find the one that works... that's over 4K VLAN ID possibilities, though.

First thing we need to do is add the wan port to br-lan:

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'wan'

Next, create 3 bridge-VLANs. The first is for the lan, then one for the wan, and finally the IPTV box:

config bridge-vlan
        option device 'br-lan'
        option vlan '1'
        list ports 'lan1:u*'
        list ports 'lan2:u*'

config bridge-vlan
        option device 'br-lan'
        option vlan '2'
        list ports 'wan:u*'

config bridge-vlan
        option device 'br-lan'
        option vlan '27'
        list ports 'lan3:t'
        list ports 'wan:t'

Now, we need to edit the lan and wan interfaces to use the new bridge-vlans (br-lan.1 and br-lan.2):

config interface 'lan'
        option device 'br-lan.1'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '192.168.0.1'
        option ip6assign '64'
        list ip6class 'wan6'

config interface 'wan'
        option device 'br-lan.2'
        option proto 'pppoe'
        option username ''
        option ipv6 '1'
        option password ''

And finally we'll create an unmanaged interface for the IPTV box:

config interface 'iptv'
        option device 'br-lan.27'
        option proto 'none'

This sets up VLAN ID 27 (tagged) on the wan port and lan3. If VLAN 27 is correct, the IPTV box should start working. If not, you can try VLAN 18 by editing the bridge-vlan from VLAN 27 to VLAN 18, and likewise changing the unmanaged iptv network from br-lan.27 to br-lan.18. And you can try any other VLAN IDs the same way.

Restart your router after you make all the changes and test.

1 Like

I am using LuCI to configure VLAN, are these options correct?


Yes, those parts look right.

Okay for some reason after applying those settings my clients couldn't connect to the main WiFi (DHCP server wasn't handing down and IP addresses) but the guest network worked. Rebooting the router seemed to fix it, I guess after each VLAN configuration change I just need to restart the wireless radio interfaces as well?

A complete restart of the router usually handles everything.

1 Like

Okay this time my IPTV box shows an error at startup

"Network Error

Unable to reach IPTV portal, the BOX may reboot in few minutes or try power restart the TV BOX after 5 minutes to restore the connectivity." Could it be because of unmanaged protocol?

Also it looks like the same issue as before, I guess wrong VLAN ID. Time to switch it up.

No, the unmanaged protocol has nothing to do with this.

Likely.

1 Like

I can't seem to capture any traffic in br-lan.18 nor in lan3 on Wireshark, any idea why?

Also should I setup firewall for them?

EDIT: Also I wanted to know since we are only enabling VLAN for lan3, is there any reason to specify VLAN 1 and 2 then changing the devices in the interface tab to reflect the VLAN?

Okay so I decided to just hook up the ethernet cable from the ONT to my Laptop and it looks like on Wireshark there are some igmpv3 packets, flooded with arp packets as well but I can't seem to find any vlan tagging present (probably because client devices aren't vlan aware?). Not so sure now. Not sure if there is a way to share my pcap file here.

I'm not really a Wireshark expert, but broadly speaking, my guess is that the VLAN ID is wrong. As I mentioned initially, it's important to know this information a priori in order to avoid the headache of trying to figure it out... basically, unless you have the information, you're going in completely blind.

That said, the interface is setup as unmanaged, so I don't think you'll be able to monitor it. You could change it to managed (i.e. dhcp or static IP), but without knowing what should be happening, it's also a bit or a chicken-or-egg.

No, as the data is really meant to pass through the router at L2 (switched). A firewall/interface would require that it would be L3 (routed).

Yes, because of the way that DSA works with bridges and bridge-vlans.

Right... I doubt that you'll get anywhere unless your computer's interface is VLAN aware.

1 Like

Just a small doubt, when I plugged my cable from ONT to IPTV box it was assigned an IPv4 and a local IPv6 address, (Assuming my ONT is only configured to hand out IPV6 addresses for my IPTV box) I guess this shouldn't pose an issue when I am trying to find the correct VLAN ID despite the protocol being set to unmanaged right?

EDIT: Just a few more screenshots I want to share...

I tried checking around my ONT and I can see the IPTV mac address for it. Hopefully something meaningful can be found?

image

The VLAN is a layer 2 thing, so no, it won't interfere... assuming it is a VLAN thing (and not some other method used to identify the IPTV box), it should just work once you find the right VLAN.

There is one other thing we can try (in case it's something like a vendor ID passed as part of the DHCP process and not VLAN'd at all)...
Edit VLAN 2's bridge-vlan to add port lan3 as untagged, like this:

config bridge-vlan
        option device 'br-lan'
        option vlan '2'
        list ports 'lan3:u*'
        list ports 'wan:u*'

Then restart and try again.

1 Like

Okay I guess this might be an improvement? I don't seem to get the "eLifeTV portal is unreachable, please connect IPTV LAN cable." message but I still get the Network Error, I guess I need to configure Layer 3 for it as well?

Probably not layer 3 on your end. But really this is information you need to get from the isp (or other sources) about how the isp handles the iptv stuff. Once that is known, we can help you with the openwrt implementation. But as I said before, everything is really just guessing right now.

1 Like

The changes you suggested here seemed to remove that issue, it looks like set my VLAN to 11 despite shown on the screenshots didn't help in anyway.

Only problem now is how do I get the ONT to hand down an IP address to my IPTV box which is behind a router :thinking: I just want to root down the issue whether it's Layer 2 or 3.

EDIT: I tried reversing all the changes and it looks like my IPTV box is no longer cooperating with me :confused: setting VLAN 27 and undoing the lan3 u:* changes on VLAN 2 doesn't seem to show the IPTV LAN cable error, it's only showing Network Error even after reboot.