Help with failsafe mode after breaking configuration while trying to configure router to be wifi repeater

The short question is: what is the SSH password for failsafe mode?

The long explanation: My router is tp-link archer C7 v2.0 and I just recently upgraded to 18.06.4 from 17.x. Since I got a new router, I was trying to make use of this one as a wifi repeater. After a few hours of trying (and failing) to get it working, I messed up configuration badly enough that I can no longer connect over ethernet (not even thinking about wifi).

To solve the problem, I found this: which explains that I should be able to enter failsafe mode and fix the issue from there. After a bit of trial and error I figured out how to enter failsafe mode and how to connect to the router. And there begins my next problem that I just can't figure out: what is the SSH password. It doesn't appear to be documented anywhere that I can find. I also tried telnet (nc on linux) on port 23 and a few other random port examples I could find on the internet, but it just exits without doing anything.

Once I get it working again, I will probably also need some help with what I originally tried to do, which is setting up wifi repeater. Should I create new topic for that, or continue here?

There is no password in failsafe mode.

1 Like

Right... I forgot to specify root user.
So I ran firstboot command and rebooted, and so far no changes.
I still can't connect over ethernet, and I still have exactly the same configuration. Is there anything I;m doing wrong?

You did not specify which other commands you issued. Did you do mount_root first?

Firstboot should reset the settings, but sounds like it did not actually run. Read the hard reset advice from that wiki article.

1 Like

I have exactly the same problem with the failsafe mode. Updated from OpenWRT 18.06.4 to ATH79 Master Snapshot with sysupgrade -n -F and changed some settings in Luci and after that I couldn't access the web interface anymore. So I set the router ( Archer C7 V2 ) to Failsafe mode but each time a ssh password is required which I don't know. Is this perhaps a bug?

Since I still had ssh access in normal mode I could load the snapshot again with the command WGET and reset the settings with the sysupgrade command but this is awkward because I have to the same procedure again and again.

If you merely want to reset to defaults you can boot the router normally (not into failsafe mode) then hold down the reset button for more than 5 seconds and release it. It's the same process as with factory firmware.

as @Barteks2x said, make sure you are using user root. If you use another user (when you just run ssh, it uses your username on your PC by default) it will ask for a password but since no user other than root exists on the router there is no way to log in.

But I want to do a "mtd -r delete rootfs_data", because I suspect that there are some remnants of the 18.06 left over.

I was able to get everything reset, turns out that mounting root first was the solution (I think). I think what may have happened too was that when selecting y/N, it's case sensitive.
Previously I ran the following commands in this order:


i do SSH on my Mac Terminal with " ssh root@" after i make a static ip on my mac Ethernet Card. But after i hit Enter it says "incorrect password"

sysupgrade -n or firstboot does exactly that.


When you ssh to a host for the first time you have to accept the key. If you ssh to a different host at the same IP (very common when setting up multiple OpenWrt routers) the ssh client will see that the key is not the same as the last time and give you a dire warning about a possible man in the middle attack. You need to remove the stored key on your PC in order to connect. (possibly ssh -y -y will bypass the key check). In any case this is a PC issue not an OpenWrt issue.


I will give it a try but the first time I had the problem after I saved the key that it required a password.

The problem is that I can't change the language in the master or choose another theme because I can't access the web interface afterwards.

Maybe it's a bug of the Master I don't know.

Now my only problem left is trying to actually set it up as a wifi repeater. Should I ask in separate thread?

1 Like

Yes please.