Help with creating a wired only repeater

I'm attempting to create a repeater (archer c7) in my living room for a media player (wired connection only, i do not care much about another wireless repeater). So far, via luci, I have scanned the wireless network and connected to the main router (netgear r7800) and assigned it the lan firewall zone. Then, i changed the IP for lan to be so it won't conflict with the main router.

  • ssh into repeater and can ping but not (r7800)

I attempted to create a bridge between the lan interface and the wwan (wireless client) interface but I have no success. The new bridge has an error "Network device not available" and I'm quite lost about this. Can anyone help me out? I'm pretty new to networking/openwrt so i'm lost atm but i can show screenshots of what i did if it's more helpful

Set a static LAN side IP for the repeater, but seems you've already done that.

go to wireless, do a wifi scan, join the wifi network, and that's it.

make sure you disable the DHCP in the repeater, and don't use the WAN interface anywhere.

Are you trying to achieve a wireless bridge? If so, try the instructions below if your wireless hardware is supported (mac80211 based):

1 Like

Okay, I reset to factory and tried again. My steps:

  1. Make new lan ip so it doesn't conflict with main router
  2. Scanned and connected to wifi from main router
  3. Tried to access anything. Can't access anything. Can't access lan devices or main router. But the archer c7 itself can access

My motivation is for the archer c7 to provide ethernet access to my odroid mediacenter. So i was thinking of the archer c7 connect to the main router and then be able to provide internet access via ethernet cables. If that's kind of what a wireless bridge is, then i think that would be what i want. I presume that means both the main router and the archer need to have configuration changes made to it?

You might need to install relayd.

1 Like

I've been able to follow that all the way up to the section on adding a repeater interface.

I have relayd installed now

root@OpenWrt:~# opkg install relayd
Package relayd (2020-04-25-f4d759be-1) installed in root is up to date.

however, I'm not seeing the relay bridge protocol

Any thoughts on why? I even rebooted the repeater and luci doesn't see it


1 Like

If your main router is running OpenWrt, use WDS. The only configuration change on the main router is to change its AP from AP to AP(WDS). Regular clients can still connect to an AP(WDS). On the second router (bridge), the setup is like a dumb AP except you don't have to set up a wifi AP if you don't need it. The dumb AP has only one network, lan, with the Client(WDS) and the Ethernet ports bridged into it.

If main router doesn't support WDS, use a regular routed client. This means that lan and wan are separate subnet ranges. The only thing in wan is a wifi client connected to the main router. Relayd is not necessary when you only need to give the remote device a link to the Internet and you don't care about lan to lan connections.


I linked you to a comprehensive howto. Your question gets answered in that howto.

Did you try the howto I linked you to?

Until he has tried WDS and confirmed it doesn't work for him, he doesn't. WDS trumps relayd if the former does what he needs. See post #3.


I resolved this by installing relayd for the moment. The reason i was holding off on making any changes to the main router is because i broke luci a few weeks ago and i'm not competent on the cli to fix it. I'll be resetting the main router after my roommate's semester is over and will try again with WDS. until then, relayd works well so far!

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.