Help with building OpenWrt for TP-Link EAP235 Wall with mt76/7615 'patch'


I'm trying to build openwrt master for a tplink_eap235-wall-v1 with a hack/patch for a problem with it's mt7613.

I've cloned and fetched both the openwrt and mt76 repositories, patched the relevant file (mt76/7615/mcu.c) But when I build openwrt it doesn't seem to use the patched file. How do I make the feed/makefile point to the local mt76 repository?

Thanks for the help!

Easiest way is to create a patches/ directory in package/kernel/mt76/ and drop that hack in there. Then compile.

No need to use the mt76 git repo, but if you'd like to (which greatly complicates things here, but hey), see these instructions. You can translate those to the mt76 package almost one on one.


However patches are new to me. It's not clear to me what the file in the patches directory should contain. The link points to a diff of mcu.c. Something should be added to the patch file to make clear the diff is about 7615/mcu.c, right?

I don't build this, but something like

wget -O package/kernel/mt76/patches/002-clearPending.patch

should get the job done if the patch applies correctly.

1 Like


No luck so far, I've tried to apply both patches.

The patch from @Borromini didn't apply, it gave a patch error:

Using the link provided by @anomeome the patch was applied, but gave errors during compilation:

@ptpt52 Does the patch work on the latest master, or should I apply it to an older version?

No I remember now rebasing the patch but it throwing an error on master. It should work just fine on 21.02 though, I'm running 21.02 with that hack.

That did the trick! The build was successful and it's running now. I see the one of the tx queues (AC31) growing every now and then for about 6 seconds and then it gets cleared. Looks like the patch is doing is work. Nice!

Thanks for the help.

Happy to help!

@elcovv I tried another master build myself this weekend for the 5.10 bump on ramips, and I decided to have a closer look at the hack breaking compilation. It seems it needed adapting after this commit:

You can find the adapted patch for master here. BTW, it seems you're trying to apply these patches in the mt76 source dir (or at least definitely not in the top dir of your buildroot), and you should just apply these in your buildroot, not in a subdir:

$ git apply $patch

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.