Help to configure openwrt

Hello, I visited all youtube videos and articles online to try comprehend the DSA switch. I managed to come up with the below config but it is still far from what I want to achieve.

  • cable from my main router (ubiquity) into wan port
  • 3 vlans IN
    • homenet vlan 1
    • guest vlan 6
    • iot vlan 7
  • all physical ports connected to home network
  • 3 ssids for each network

With below config, I managed to get an ip from my main router to the br-lan. The iotnet and homenet are not able to get an ip.
network file:


config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdbe:8406:3e81::/48'
	option packet_steering '1'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'
	list ports 'wan'

config interface 'lan'
	option device 'br-lan'
	option proto 'dhcp'

config interface 'wan'
	option device 'wan'
	option proto 'dhcp'

config device
	option type 'bridge'
	option name 'br-iot'
	option bridge_empty '1'
	list ports 'eth0'

config bridge-vlan
	option device 'br-iot'
	option vlan '7'

config device
	option type 'bridge'
	option name 'br-home'
	option bridge_empty '1'
	list ports 'eth0'

config bridge-vlan
	option device 'br-home'
	option vlan '1'
	list ports 'eth0:t'

config interface 'iotnet'
	option proto 'dhcp'
	option device 'br-iot'

config interface 'homenet'
	option proto 'dhcp'
	option device 'br-home.1'


hello, any help please? I have watched countless videos and read online now but am still unsuccessful with the multiple vlan on multi ssid.

I managed to get each interface up with this:


config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd35:a058:2583::/48'
	option packet_steering '1'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option device 'wan'
	option proto 'dhcp'

config interface 'wan6'
	option device 'wan'
	option proto 'dhcpv6'

config device
	option type '8021q'
	option ifname 'wan'
	option vid '6'
	option name 'wan.6'

config device
	option type '8021q'
	option ifname 'wan'
	option vid '7'
	option name 'wan.7'

config interface 'guest'
	option proto 'dhcp'
	option device 'wan.6'
	option type 'bridge'

config interface 'iot'
	option proto 'dhcp'
	option device 'wan.7'
	option type 'bridge'


config device
	    option name 'br-main'
	    option type 'bridge'
	    list ports 'lan1'
	    list ports 'lan2'
	    list ports 'lan3'
	    list ports 'lan4'
	    list ports 'wan'

config bridge-vlan
        option device 'br-main'
        option vlan '1'
        list ports 'lan1'
	    list ports 'lan2'
	    list ports 'lan3'
	    list ports 'lan4'
	    list ports 'wan' # 'wan:t' if you need to set tagging for VID 1  

config bridge-vlan
        option device 'br-main'
        option vlan '6'
        list ports 'wan:t'
		
config bridge-vlan
        option device 'br-main'
        option vlan '7'
        list ports 'wan:t'

config interface 'lan'
	    option proto 'dhcp'
	    option device 'br-main.1'

config interface 'guest'
	    option proto 'dhcp'
	    option device 'br-main.6'
	    option metric '10'
	
config interface 'iot'
	    option proto 'dhcp'
	    option device 'br-main.7'
	    option metric '20'

Better set a static IP on the lan interface so you can always access the device if something goes wrong.

Thank you, this helped me setup the 3 SSID on the dumb AP with home network on the 4 ethernet ports. May I ask what is the role of the eth0? I understood it was a common switch and that is why I try to keep it with the bridge.

https://forum.openwrt.org/t/wtf-is-ethernet-switch-eth0/165680 - #5 by zekica

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.