Help to access 2 dfferent routers at same time on network, 1 using stock firmware other using openwrt?


I had an old router and had difficulty with local lan transfers on my PC.. its different issue in other topic:
Recently bought a NEW Router and connect same to Internet using PPPOE.

Check my Network Diagram..

Everything is working as required, But cannot access both router configuration at one time from my Windows 10 PC.

IP range =
SSID 2.4ghz = TEST2.4 (Works Perfect)
SSID 5ghz = TEST5 (Works Perfect)

Wireless Settings on NEW router:

Network/Lan Interface on NEW Router:

Using latest openwrt Firmware
IP range =
SSID 2.4ghz = 2.4 OLD ROUTER (Works Perfect)
SSID 5ghz = 5 OLD ROUTER (Works Perfect)

Wireless Settings on OLD router:

Network/Lan Interface on OLD Router:

To connect to OLD router when everything is running fine and make some SSID changes:
(have to turn off NEW router do a network adapter RESET, then OLD router works fine, but internet does not works as IP range gets changed/updated from OLD Router and cannot access NEW router interface)

To connect back to NEW router:
(have to turn off OLD router do a network adapter RESET, then NEW router works fine, Everything starts working perfectly, but cannot access OLD router Interface)

Old Router SSID Settings in 2.4ghz and 5ghz mode:

Can someone direct to a proper solution please ?
I am not sure how to configure openwrt settings, was done by someone else.


Reconfigure the old router as a dumb AP/switch:


Openwrt setting is not possible for me, it was done few years ago by someone else.

Earlier from NEW router Lan port was connected to OLD router Lan Port via ethernet.
Changed now
NEW router Lan port is connected to OLD router Wan Port via ethernet.

I just reset the old router and it configured things on its own and works as desired:
I can now ping to both routers at same time without any issues:

Can access both router configuration without issues:

Tried to reboot new router first, all settings work fine
Tried to reboot old router first, all settings work fine.

Network interface of old router now after reset:

It seems problem is fixed or should i share some more screenshots from specific location to confirm ?
Required different SSID for both routers, which is working as planned.

What could have been issue ?
Not a networking expert, but still some knowledge can help in future

Thanks :slight_smile:

Just found one issue, when OLD router is shut down, ping and connection to both router fail (quite obvious).
But I can still connect to NEW router 2.4 ghz SSID - though not a decent speed.

@vgaetera gave you the best solution.


Hello @jc1685
I tried tested both routers MercSys Mr90 and Archer ax73.

Found Archer Ax73 connects even to furthest room corners.
I have decided to keep and use same.

Can't I install any custom ROM on same.