Help setting up PPPoE

In previous home, I used to have the ISP (Wind gr) modem/router(Zyxel) setup in bridge mode and the Linksys Openwrt setup with PPPoE. Everything was working fine.
Now I moved to a new house, the same ISP but 24mbps instead of fiber 100, I can't setup the same as before. Openwrt PADO and wan interface complains user_request.

What to look for?

Did you change the configuration?
Did you try another router?

I haven't changed anything. For bridge I tried a tplink with the same pado and user request problem.

But correct me if iam wrong, I have connected the lan port of bridge with the internet port of the linksys

I think you're saying you had fiber before, now it is DSL. So clearly a different type of modem is in place.

Check with the ISP:

  • Is the DSL circuit intact? (this would be indicated by having a steady DSL status light on the modem, but they can check the signal quality more completely from their end.)
  • Is the modem really in bridge mode?
  • Which port on the modem should be used? (in bridge mode, connect one port of the modem directly to your router WAN port, the other ports of the modem are unused).
  • Are VLAN tags necessary?

Check your log for ppp errors and post it here. The most common error is "Timeout waiting for PADO packets"-- which is caused by not having any connection to the ISP. That is usually due to one of the issues above.

That's right. Did you try another router to verify that the bridged modem is working properly?

I tried, the bridge modem is not working. I don't know what to look for. I have tried with two other modems, one tplink as bridge and Zyxel as pppoe and reverted Zyxel as bridge and tplink as pppoe.

If you're saying that other routers also did not work with your modem, you need to get assistance from the ISP.

I guess but unfortunately they don't know how to support

Well the problem was the cable, between the bridge and the router I have a 15 meters long cable and it was damaged from the heating system. The cable tester was showing ok but it was not ok for the system. I replaced the cable and is working ok.