Help setting up Magenta Austria DSL connection


I live in Austria and I have a DSL connection from Magenta. Now I’m using a fritz box 7530 with fritzOS but I would like to use my fritz box 3370 with openwrt. When I plug in the 7530 it just works but I don’t know how to set up the 3370. I tried everything but Iit just says interface is not present. The magenta support told me that I don’t need any credentials to connect. Could someone please help me? Here is a picture of the connection summary on the fritz box 7530:

And the export of the fritzOS configuration:

Thanks for your help in advance!

This sounds like the DSL modem may not have established a connection. The dsl0 network interface is only created during the first successful DSL connection.

You can check the DSL status using ubus call dsl metrics on the command line. It should also be shown on the overview page in the LuCI web interface.

Which DSL standard does your connection use? This should be shown as "Connection type" on the DSL overview page of your Fritzbox with original firmware.

Thanks for your reply! My connection type is VDSL2 17a G.Vector (ITU G.993.5)

Also how should I set up the DSL interface? PPPoE or DHCP?

       dslifaces {
                enabled = yes;
                name = "internet";
                weight = 50;
                dsl_encap = dslencap_ether;
                dslinterfacename = "dsl";
                no_masquerading = no;
                use_fixed_masqaddr_if_no_masquerading = yes;
                no_firewall = no;
                stackmode = stackmode_ipv4only;
                pppoevlanauto = no;
                pppoevlanauto_startwithvlan = no;
                vlancfg {
                        vlanencap = vlanencap_fixed_prio;
                        tagtype = vlantagtype_customer;
                        vlanid = 31;
                        vlanprio = 0;
                        tos = 0;
                ppptarget = "internet";
                rfc4638_enabled = no;
                fixed_masqaddr =;
                mtu = 0;
                gre_server_cfg {
                        server_dnsprefer = protoprefer_ipv4;
                        dpd {
                                inactivity = 20s;
                                replywait = 1s;
                                npings = 4;
                                period = 30s;
                        allow_netbios = no;
                etherencapcfg {
                        use_dhcp = yes;
                        use_dhcp_if_not_encap_ether = no;
                        ipaddr =;
                        netmask =;
                        gateway =;
                        dns1 =;
                        dns2 =;
                is_mcupstream = yes;
                stay_always_online = yes;
                disable_ondemand = no;
                reconnect_delay_after_conn_abort = 30s;
                only_route_when_connected = no;
                redial_delay_after_auth_failure = 1m;
                redial_limit = 3;
                redial_after_limit_reached = 10m;
                redial_after_limit_reached_variance = 5m;
                redial_after_limit_randomize = no;
                redial_delay_after_low_error = 10s;
                redial_delay_after_ppp_timeout = 10s;
                redial_delay_after_ppp_error = 1m;
                routes_only_for_local = no;
                dproutes_only_for_local = no;
                hide_interface_address = no;
                disable_staticroutes_on_dhcproutes = no;
                ripv2receiver_enabled = no;
                ripv2_update_timer = 30s;
                ripv2authmode = ripv2_auth_none;
                ripv2md5_keyid = 0;
                ripv2passwd = "";
                set_replicate_dhcpoptions_in_parameter_request_list = no;
                unset_ignored_dhcpoptions_in_parameter_request_list = yes;
                dsldpconfig {
                        security = dpsec_firewall;
                        filter_teredo = yes;
                        filter_netbios = yes;
                        filter_sip = no;
                        filter_smtp = no;
                        sip_alg = no;
                        lowinput {
                                policy = "permit";
                                accesslist =
                                             "deny ip any",
                                             "deny ip any host";
                        lowoutput {
                                policy = "permit";
                        highinput {
                                policy = "permit";
                        highoutput {
                                policy = "permit";
                                accesslist =
                                             "reject ip any",
                                             "deny ip any host",
                                             "reject ip any";
                dhcp_auth_mode = auth_none;
                dhcp_requests_with_client_id = yes;
                dhcp_ignore_options_in_renewing = no;
                is_erouter = no;
                fakepacm = no;
                dhcp_tr069_add_device_vendor_options = no;
                use_random_macaddr = no;
                arp_reply_for_any_net_enabled = yes;

most possible configuration is DS-LITE on dsl0.31 ( vlan 31) ,empty username/pass on pppoe . Lantiq cpu of 3370 in router mode wont be able to reach 100Mbps but it's good way to start .

Thanks for helping!
I’m a complete noob when it comes to setting up routers. Could you please write me a guide what and how to set up? Thanks in advance!

I don't know ISP so this will be trial and error
add new device configuration

change interface connection to

package ds-lite must be installed
set empty pppoe username and password

DS-Lite AFTR address is unknown for me .I've set 0 there but might be different one.
Courious observation is that my ISP (Orange Poland) also use DS-LITE but I'm setting up legacy mode using ipv4 only WAN

Now it is switching between Idle and Idle request on the DSL status page. Previously it was silent.

I don't know exactly how Magenta is set up, but my Fonira connection works fine. However, I'm on a 7530 with OpenWrt.

It's been a while since I last used an xrx200 device (on a UPC line, isn't that Magenta now?), but last time I tried it, the default firmware did not support vectoring. I had to supply a later DSL firmware revision to enable vectoring support - you can try the firmware overview from and pick one with vectoring. Make sure to reboot the device after copying the file (via scp) and configuring it, a reload of the interface is not enough. You can add the path to the firmware file in Network -> Interfaces -> DSL.


I wouldn't bother about DS-Lite or IPv6 for now, let's first try to get IPv4 working. If Magenta is similar to Fonira, then IPv6 is also supplied via DHCPv6.

NB: If you want to use your 7530 in the end, be aware that you will need to compile OpenWrt yourself in order to get DSL support. As usual for AVM devices, you will lose all telephony features. Apart from that my OpenWrt build and VDSL is very stable.

Thanks for the help and tips. Unfortunately no matter what I tried (multiple firmware files etc.) it just hangs on idle request or silent. If you have any other ideas please share them. Also tomorrow I’m planning to call Magenta and as them. Magenta vas UPC before but the as far as I know the DSL line belongs to A1

I'm quite sure that Magenta won't help you, they only support their modems. But who knows...

Anyway, for how long did you wait to get a sync? This might take several minutes or even longer until the line is ready.

I suppose you are on OpenWrt 22.03, right?

I plan to set up a similar Fritz!Box for A1 next weekend, the line there is also VDSL2 with vectoring.


I don’t know if this is an option but why don‘t you just put your magenta fb into bridge mode and use both devices?

I waited around 30 mins and I’m using 22.03. I hope Magenta will help me but we’ll see.

Not bad idea but my goal is to only use one device

1 Like

30 mins should be more than enough. My line with the 7530 syncs within a few minutes.

I understand that you don't want to flash your 7530 right away, but in the end this device is way more capable and should be able to support your >100MBit/s line. As mentioned, keep in mind that you need to build your own firmware for this to work - see Adding support for VRX518 (and maybe VRX320) for details, I'm using the following fork with great success:

If Magenta can’t help toady I will flash the 7530 with the fork when I get better. What do you think when will it be merged into the official repo?

Magenta said that I just had to plug it in and it should work. I’m afraid to flash the 7530 because if I can’t get it to work we will be without internet. I also posted my question on Reddit and in the Magenta community.

Which modem did Magenta supply to you? Or were you able to opt-out?
And for the sake of completeness: The hardware connections are correct, i.e. only one modem on the line, no splitter, tried to swap cables etc.?

The hardware works as it should because it works with the magenta supplied router which is the 7530 (we don’t have any splitters) . And I also tested the DSL port on the 3370. Maybe I will wait until next week with the flashing of the magenta supplied router

Hello everyone,
Thank you all for your help!
As @andyboeh suggested I tested my FritzBox 3370 with the original firmware again and it unfortunately turned out that there is problem with the hardware itself so I'll return it. My other question is that which DSL router do you recommend that is already supported by OpenWRT? (Not like the FritzBox 7530) Maybe a FritzBox 7362SL is a good choice?

If you want to max out your line there is not much choice apart from the 7530/7520.