Help set up DumbAP

Hello,

Since my last OpenWRT update to the last snapshot from [19.07.5] I'm unable to configure the router as a DumbAP.
I thinks it's because the /etc/config/network file is different.

Here is the list of commands I used to run in order to configure my router :

#dumb AP
uci set network.lan.ipaddr='192.168.4.250'
uci set network.lan.gateway='192.168.4.1'
uci set network.lan.broadcast='192.168.4.255'
uci add_list network.lan.dns='192.168.4.1'
uci commit
reboot now
///////////
uci set network.@switch_vlan[0].ports='1 2 3 6t'
uci -q delete network.@switch_vlan[1]
uci -q delete network.wan
uci -q delete network.wan6
uci commit network
reboot now

uci set dhcp.lan.ignore=1
uci commit dhcp
/etc/init.d/dnsmasq restart
/etc/init.d/odhcpd disable
/etc/init.d/odhcpd stop

reboot now

for now I stopped at the /////////// because after the next commands and reboot the router crash or doesn't give me a connection.

Here is my /etc/config/network file after the commands until the /////////// :

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option packet_steering '1'
        option ula_prefix 'fd57:c020:48ff::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.4.250'
        option gateway '192.168.4.1'
        option broadcast '192.168.4.255'
        list dns '192.168.4.1'

config interface 'wan'
        option device 'wan'
        option proto 'dhcp'

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'

I'm pretty sure the problem is due to the missing switch_vlan (0 and 1) but don't know what to do.
Hope someone will be able to help me ^^.

In 21.02 switch part migrated from swconfig to DSA, you should reset your device and start from scratch,

thx for the news, do you have a link to a documentation (since the dumbAP guide seems out of date) where I can find infos to replicate my old config ?

Not what I'm aware of.

but the configuration changes you're making can easily be made in LuCI.

There's nothing in your post about stopping the DHCP server on lan, which is essential for a dumb AP to not serve conflicting DHCP information on the network. Clients of a dumb AP obtain DHCP from the network's main router.

CIDR notation is now accepted to set up static networks you can use the single line option ipaddr '192.168.4.250/24' which also sets the correct netmask and broadcast.

Reassigning the wan port is the final and optional step, since the dumb AP will work with one of the lan ports connected to the network, and you should test it that way. Delete the wan and wan6 interfaces, then add device 'wan' (the wan Ethernet port) to br-lan.

isn't

uci set dhcp.lan.ignore=1
uci commit dhcp

stopping dhcp ?

as far as I remember before the update everything was working smoothly with this config.

Thx, I'll try it and then try to translate it to CLI ^^