Help: RPi 4 VLAN's and WiFi SSID's


Can someone please advise me on how to configure IOT and Guest WiFi networks on 2 access points?
Main router is RPi4, 1x Unifi 6 Lite and a hAP ac2 as dumb AP's running OpenWrt.
I have followed these videos but get stuck with interface settings/ VLAN's.

I have a Dell X1026P managed switch, Router is connected to port 24, Unifi is on port 11 and hAP ac2 is on port 4.

This is on the RPi4:

Create the same guest, iot and lan interfaces in the APs. Create a corresponding ssid for each interface and bridge it with only that interface. Make sure your switch is sending the proper tagged vlans to your APs.

1 Like

What protocol should I select when creating the interface on the AP's?


I would leave the guest and iot interfaces as unmanaged so the APs management interfaces aren’t available on those networks. Your config on the lan is ok, though I would have set it to dhcp then assigned it a static ip in the main router.

Thanks, I have made those changes.
I think I have a problem with the VLAN config on my switch, I recently got the switch and not very familiar with it.
When I try to connect to the Guest and IOT WiFi, I don't get an IP address.

All traffic should be passed from router to ap. The switch doesn’t need to do any segmenting between them. Packets should be passed intact, not stripped of vlan tags. I don’t have any experience with dell managed switches though so I don’t know if I can help you there.

Okay. I tried removing the VLAN's from the switch.
The only VLAN's I have on the switch is the default LAN vlan1, WANA vlan10, WANB vlan20 and WANC vlan30 for the specific ports the wan devices are connected to.
Still can't connect to IOT and GUEST WIFI. The standard default LAN WiFi network works and I get an ip address from the router
I have tried Tagging, Untagging and removing the 40 and 50 id's on the router and AP ports...

I'm a newbie, and although my setup is different from your's I've also struggled to have it working. Here is what I've learned.

I'm using 3x Unifi AP's managed by Unifi app (which propagates wlan definitions to all AP's). Two wlan's (IoT and Guest) are defined as vlan only, with their respective number (in my case 3000 and 1000). The higher the number the higher the priority. The Home wlan is not associated to a vlan, mainly because I can't manage Unifi AP's in a vlan

In my switches (TP-Link TL-SG108E and TL-SG108PE) vlans are defined as follows:

  • 1000 and 3000 are assigned to tagged ports where AP's, RasPi (OpenWrt) and other switches are connected. 3000 are assigned also to untagged ports where I have IoT devices connected. These devices are not prepared for vlan so the switch adds the tag for them

I have several interfaces defined: eth0.1000 eth0 and eth0.3000. In daily activity the IoT network (vlan 3000) has no access to internet (I enable it occasionally to install IoT devices that require cloud access during setup). You can use the following video as a guide

Hope this helps.

Thanks for the advice.
I eventually found the solution in another post.

Installed ip-full package on WAP's
edited mine to this:

config interface 'guest'
	option type 'bridge'
	option proto 'none'
	option ifname 'lan.40'

config interface 'iot'
	option type 'bridge'
	option proto 'none'
	option ifname 'lan.50'

Configured switch ports to trunk with 40 and 50 vlan's

It works now.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.