Help needed to unbrick BT HomeHub 5 after downgrade from 21.02 to 19.07

Help please!
I'm not very experienced with CLI.

I had openwrt 21.02.0-rc1 installed on my BT Homehub 5 running without problems. By mistake i installed on LUCI the older firmware 19.07.0.-rc2 and bricked my device.
I connected via serial. This is the log
serial log

Please somebody guide me to install 21.02.0-rc1 via cli on serial. I can connect on Putty but wget doesn't work. wget says "Failed to establish connection".
Any chance to get the firmware with TFTP? or any other way?


Your log looks fine, kernel boots up, interfaces are initialized. Have you tried failsafe mode first?

I think you're running into an issue where LUCI/Network config/etc won't work correctly because it's using 21.02 settings and syntax in 19.07. Booting into failsafe mode means you boot the router with a clean, fresh config from ROM. You can then decide to SSH into the device to fix the configuration issues, run the firstboot command to do a full wipe of the old configuration, or try to upload new firmware.

You can also enter failsafe via your serial by interrupting the boot process:

Press the [f] key and hit [enter] to enter failsafe mode
Press the [1], [2], [3] or [4] key and hit [enter] to select the debug level
1 Like

While on failsafe mode, i run firstboot and it returns:

I root@ (none) :/# firstboot [

24.630996] random: crng init done

I 25.136940] jffs2reset: This will erase all settings and remove any installed

packages. Are you sure? [N/y]

[ 28.991016] jffs2reset: /dev/ubi0 2 is not mounted

[ 28.994607] jffs2reset: /dev/ubi0 2 will be erased on next mount [ 29.000650] jffs2reset: writing /dev/ubi0_2 failed: Operation not permitted

The firstboot command is partially broken on the HomeHub 5; jffs2reset is not suitable for UBI volumes.

One of the following might work - I do not remember which one I used last time I needed this.

  • run mount_root before firstboot
  • run mount_root, then erase the contents of /overlay using rm
  • erase the ubi volume named rootfs_data using ubiupdatevol -t /dev/ubi0_2; but before you do this, you might want to double check the volume name using ubinfo /dev/ubi0_2
  • perform a firmware installation with sysupgrade -n (do not save configuration over reflash)
1 Like

Your serial log seems to look ok at first glance, as already suggested by @ergamus.

fwiw, have you tried the Reset button on back of the HH5a ?
See section 8

Otherwise, as you appear to have serial access, you could boot the 'LEDE installation image' as described in section 4, skip the 'prepare' script and go straight to executing sysupgrade command (try with '-n' flag), to installing 19.07.6 sysupgrade.bin image from USB drive.

1 Like

Thanks! The reset button cleared the settings and i could flash again the newest openwrt firmware.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.