Help: hAP ac2 ipq4018 guest and iot vlan

Hi

Please assist with configuring guest and iot vlan's device / interface on hap ac2 dumb AP.
The LAN Wifi is working fine.
DHCP and DNS is handled by the main router RPi4.
My Unifi 6 Lite AP works with all WiFi SSID's (Home LAN, Guest, IOT) correctly.

Is the network config correct?

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdbf:6b68:5e94::/48'
	option packet_steering '1'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0'

config device
	option name 'eth0'
	option macaddr '74:4d:28:aa:57:e7'

config interface 'lan'
	option device 'br-lan'
	option proto 'dhcp'

config device
	option name 'eth1'
	option macaddr '74:4d:28:aa:57:e6'

config interface 'wan'
	option device 'eth1'
	option proto 'dhcp'

config interface 'wan6'
	option device 'eth1'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '1 2 3 4 0'

config switch_vlan
	option device 'switch0'
	option vlan '40'
	option vid '40'
	option ports '0t 1t 2t 3t 4t 5t'

config interface 'guest'
	option proto 'none'
	option type 'bridge'

config switch_vlan
	option device 'switch0'
	option vlan '50'
	option vid '50'
	option ports '0t 1t 2t 3t 4t 5t'

config interface 'iot'
	option proto 'none'
	option type 'bridge'

Thanks

Anyone?
Still not able to get this working...
Need to add vlan 40 for Guest and vlan 50 for IOT...
This is the default network config:


config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd2c:e44d:6f8f::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0'

config device
	option name 'eth0'
	option macaddr '74:4d:28:aa:57:e7'

config interface 'lan'
	option device 'br-lan'
	option proto 'dhcp'

config device
	option name 'eth1'
	option macaddr '74:4d:28:aa:57:e6'

config interface 'wan'
	option device 'eth1'
	option proto 'dhcp'

config interface 'wan6'
	option device 'eth1'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '1 2 3 4 0'


What should I change or add to the network config file?

Eventually got it working.
Installed ip full package.

network config.

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fde3:814b:656a::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0'

config device
	option name 'eth0'
	option macaddr '74:4d:28:aa:57:e8'

config interface 'lan'
	option device 'br-lan'
	option proto 'dhcp'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '1 2 3 4 0'

config switch_vlan
	option device 'switch0'
	option vlan '3'
	option ports '1t 2t 3t 4t 0t'
	option vid '40'

config switch_vlan
	option device 'switch0'
	option vlan '4'
	option ports '1t 2t 3t 4t 0t'
	option vid '50'

config interface 'guest'
	option proto 'none'
	option device 'br-guest'

config interface 'IOT'
	option proto 'none'
	option device 'br-IOT'

config device
	option name 'br-guest'
	option type 'bridge'
	list ports 'eth0.40'

config device
	option name 'br-IOT'
	option type 'bridge'
	list ports 'eth0.50'


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.