[HELP] DSA VLAN behind ISP router on bridge mode. Cannot get IP on 22.03, but could get it on 19.07.10

Hello all.

I have a Linksys WRT1900ACS on 19.07.10 behind a ZTE F680 (wth ONT included) in bridge mode (DHCP mode WAN on LAN1 interface), and therefore the Linksys obtaining the public IP through the WAN port connected to the LAN1 port of the ZTE. To achieve this I have to create an VLAN with ID 20 (ISP VLAN ID) and assign it to the WAN interface of the Linksys. Everything goes flawlessly like this, although not being an ideal escenario (I cannot obtain the GPON keys to substitute the F680 for an ONT only device, but that is another war).

This is my configuration under the Network-->Switch menu:

And this is my assignation of the newly created eth1.20 to the WAN interface:

Now I have flashed 22.03, and I have met some difficulties, first the switch menu is gone in favour of DSA, and second only 1 CPU is supported in DSA (eth0), so eth1 is gone.

I have tried all the possible combinations to get internet behind the ZTE in bridge mode as in 19.07.10 but I got no possitive result. I suspect I have to do something similar to this, create a new bridge interface with eth0 (CPU), lan1, lan2, lan3, lan4 and wan

Assign VLAN IDs like this (I have no eth1 option as before):

(I do not know why the WAN interface shows as "no link", when it is physically connected and the ZTE is working)
I have tried tagging/untagging the devices in br0.

Resulting in the devices as shown:

And assigning the newly created br0.20 to the WAN interfaces like this:

But still the Linksys cannot get the IP from my ISP, I have to revert provissionally to 19.07.10 to have internet.

Anyone knows why it is not working? I am a civil engineer so I am not too much tech-savvy.

Thank so much in advance and keep up the good work with Openwrt.


Put all ports into one bridge (ideally reuse the br-lan one). Add a vlan 1 (or whatever) to br-lan covering all lan ports untagged and a vlan 20 covering wan port tagged. Save it. Then change the logical lan interface settings and change from device br-lan to device br-lan.1, then save & apply.


Thank you, that was it.

I had to edit the WAN interfaces to use the br-lan.20 aswell, so final configuration would look like this:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.