Help configure switch for custom board

Hello,

Im upgrading from 18.06 and compiling the branch openwrt-21.02 for my custom board based on the Hilink hlk-7688a.
I only have one eth interface and I want only to be a host. No Bridge, Switch, etc...
But when I use my old network config file, I don't get any internet connection.
Only when I enable two things:

option type 'bridge'
list ports 'eth0.1'

This is my full config file:

# /etc/config/network
config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config interface 'lan'
    option ifname 'eth0'
    option type 'bridge'
    list ports 'eth0.1'
    option proto 'dhcp'
    option macaddr '1c:88:79:55:51:9f'
    option dns '8.8.8.8'

Can someone tell me where I should be looking to successfully disable bridge type and port 'eth0.1'?

Thanks in advance.

Ian