Help build OpenWrt for sitecom wlx-5100


Since I am new to this forum and I absolutely do not consider myself an expert in this field, I would need some tips and understand the steps to take since the online guides, in English, I find them difficult to understand.

The device I would like to run it on is a Sitecom Wi-Fi Range Extender Dualband AC750 (WLX-5100v1 001), which burned out the internal power supply due to lightning, so I wanted to recycle it as a wifi bridge that the base firmware is a bit painful.

First, I tried to load firmware for chipset,
but it gives me error
*** Warning - bad CRC, using default environment
when bootup firmware.

Then, I saw that it is similar to the Sitecom model wlr-4100v1 002 and the firmware is already available.

If I upload this latest firmware with serial + tftp, it starts correctly, only it has some secondary issues that make it essentially unusable as it is:

  1. The serial port baudrate is different from the one set at the time of the bootloader
  2. The lan port is not reachable (even if recognized), since the wrl4100 has 5 lan ports (mine only one).
  3. (although at the moment it does not seem to give me problems) I should remove the support for the secondary chip that mine does not have (in theory the other lan ports).
  4. Add support for external 5ghz wifi chip.

These are the main information that I managed to get from the device (leaving out the event log for now):

Sitecom wlx-5100 v1 001
SoC: MT7620A
RAM: winbond w9751g6kb25i (DDR2 512Mb or 64MB)
serial connection bitrate: 57600
bootloader: U-Boot 1.1.3 (Apr 24 2013 - 17:40:58)
bootloader (secondary?): Ralink UBoot Version:
u-boot tftp ipaddr =
u-boot expected serverip =

I believe it uses two chained bootloaders (but I ask for confirmation if anyone is an expert in this).

Is anyone able to help me, so maybe you make it available on the platform?
(I also need links to guides to fill in and / or modify the points mentioned above).

Sorry for my bad English.

change it, or ignore the uboot garbage, to see the kernel boot log.

what does dmesg say about the port when plugging and unplugging an ethernet cable ?

1 Like


[ 90.206485] mtk_soc_eth 10100000.ethernet eth0: port 4 link up (100Mbps/Full duplex)

[ 87.763226] mtk_soc_eth 10100000.ethernet eth0: port 4 link down

But after i set up the card network ip to and gateway to no connection is established via SSH.

Well, fortunately I have another tp-link extender and looking for how to unlock it I saw that v1 has the same hardware type as Sitecom and is supported by OpenWrt.

tplink re200 v1

Except that once the tplink firmware has been loaded via tftp on Sitecom device and booted up, it gives me:

## Booting image at bc050000 ...
raspi_read: from:50000 len:40
Bad Magic Number,01000000

How can I correct this error?

Can you show output of command (from uboot command line):

md bc050000

I think that tplink use incompatible firmware header and uboot can't recognize it.

1 Like

Hi Sir.
I think this is no needed anymore.

I found these two firmwares which appear to work with my device. I am currently checking out more based on the MT7620a chipset.

planex mzk-ex750np
errors: it would seem none!

glinet gl-mt750
errors: serial baudrate wrong, but LAN works!

So I will then try to test them a little more deeply.

If I find a perfectly compatible one, can I create the device page on openwrt and link to the found firmware as it is?

Planex mzk-ex750np Firmware seem to lack 5ghz drivers (MT76x0e seem not loaded in log), so I decided to try fix the glinet gl-mt750 firmware which seems to have full support for both wifi frequencies.

There is just one problem, at some point in the event log these errors/warnings appear:

[    0.814333] pci_bus 0000:00: No busn resource found for root bus, will use [bus 00-ff]
...other stuffs here...
[    1.014735] pci 0000:00:00.0: BAR 0: no space for [mem size 0x80000000]
[    1.026983] pci 0000:00:00.0: BAR 0: failed to assign [mem size 0x80000000]
...other stuffs here...
[    1.557814] 0x000000ff0000-0x000001000000 : "art"
[    1.562666] mtd: partition "art" is out of reach -- disabled
...other stuffs here..
[    7.125923] mtd: partition firmware extends beyond the end of device spi0.0 -- size truncated to 0x7b0000
[    7.161226] 0x000000ff0000-0x000001000000 : art
[    7.166067] mtd: partition art is out of reach -- disabled
...other stuffs here...
[   11.847211] urngd: jent-rng init failed, err: 2]

and I would like to know from you if they could give system instability problems.

In this case, can they be solved easily or is it better to fix the lack of 5ghz support in the other firmware?


Start from this page.

1 Like

I tried to understand the link guide, but I'm not sure of one thing:

Which is better to use in my case?