Help: Asus WL520GU reflash from openwrt

Apologies if this is not the proper place to post my problem.

So I have old ASUS WL520GU that i want to use solely as print server for my laser printer. I understood that new firmware is too big to fit into the router, so I decided to build the firmware image myself following the "space saving measure" guide available. I flashed the firmware ok, it was running tomato shibby btw. I then noticed it became apparent that the hardware is too weak to run openwrt.

Right now, I want to try the old "tomato USB" firmware because it seems to come with usb driver and p910nd print server. However, I still cannot put the firmware on top off openwrt. What is the easiest way to install this firmware? I read something about TFTP, but I am not sure if the asus wl520gu support or comes with it.. Any help is appreciated.

I'd probably try the recovery tool described in , but go back to stock fw, before attempting to flash Tomato again.

yes, I forgot to mention that, I already tried the asus firmware recovery tool, It didn't work. It'd be great if someone had success with asus tool, let me know how to do it.

I also tried going to router's web to upgrade, it failed too..though I don't know whether it failed caused by laggy openwrt on my router.

Can't really help you there, since you made your own image - we don't know what you've left out, and what you kept.

Does ssh work, or was it removed, too ?

you could try the recovery methods described by DD-WRT

Just an update, so i ended up using the TFTP method. Firstly I connect the router to ftdi cable to read serial console output per this guide. Then, install the firmware using tftp method. By monitoring the serial console output I could know that the firmware uploaded and installed successfully. Hopefully this would help someone who run into the same problem as I did.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.