Having trouble routing between interfaces

Hi,

I've been using OpenWrt on a Raspberry Pi 2 for about 6 months as a router on a stick with a low speed broadband connection, but have now decided to upgrade my router as I'm moving to a 300Mb/s fiber connection.

I've bought a Netgear R6260 and set it up as below, but I'm not able to get any communication between the networks which hang off the lan3 and lan4 interfaces. Traffic from lan3 & lan4 going out to the internet over the wan port works fine.

Can anyone advise if my issue is related to the config below?

If not, where else should i be looking?

Network Config

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option packet_steering '1'

config interface 'wan'
        option device 'wan'
        option proto 'dhcp'

config interface 'lan3'
        option proto 'static'
        option device 'lan3'
        option ipaddr '192.168.3.1'
        option netmask '255.255.255.0'

config interface 'lan4'
        option proto 'static'
        option device 'lan4'
        option ipaddr '192.168.4.1'
        option netmask '255.255.255.0'

config device
        option name 'lan3'
        option ipv6 '0'

config device
        option name 'lan4'
        option ipv6 '0'

Firewall Config

config defaults
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        option synflood_protect '1'

config forwarding
        option src 'lan'
        option dest 'wan'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        list network 'lan3'
        list network 'lan4'

config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        list network 'wan'

Thanks

I’m not seeing any issues with the config, but it seems you may have shared only snippets. It would be helpful to see the complete files.

What operating systems are on the hosts you are trying to use across subnets? If windows is involved, the default windows firewall config will not allow connections from different subnets - you need to adjust the windows firewall to allow it. You can turn off the windows firewall temporarily to test this

I've shared the full config, there is nothing else in the files. fyi, there is very minimal config as I'm testing the new router before i replace my existing Raspberry Pi with it.

I'm running windows, and the firewall is configured correctly but just to be sure I turned the fw off on both machines, and still not getting the pings through. I've also put both machines onto another layer2 network, and they can ping each other, so I'm sure it is not the machines.

I've also noted that if i try to ping to machine ip's from the diagnostics page, then i can ping both machines. So it seems like the routing between the interfaces is not occurring.

Could the issue be related to the hardware being incompatible with what I'm trying to achieve?.

Can I provide any more details that may help to identify what is causing this?

Thanks.

I would recommend resetting to defaults. It looks like you have removed a lot of things that should normally be there.

No. Something is wrong with your config or there are external issues with those hosts.

But it is unlikely to be a hardware compatibility issue.

Reset and start over. I think something got messed up.

That worked - Thank you for your help.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.