Having trouble downgrading D-Link dwm-222 firmware to older version to expose serial USB for GSM

This is really crumby. I did lots of research for 2 days or so looking for a 4g dongle with good compatibility with linux and was shown in usb_modeswitch udev rules.

I settled on this since it looked solid and paid the premium price compared to huawei or such.

I specifically was trying to avoid RNDIS dongles since I want GSM functionality with modemmanager. Tbh I was very happy with my old huawei 3565 except the mobile companies in the uk have discontinued 3g, which would have been fine speed wise for me, leaving only 2g and 4/5 so I was stuck with 0.1 speeds! I like to think I am a minimalist but that was just too much!

Anyway I bought the dwm-222 thinking it would be smooth sailing out the gate and I have been banging my head the last two days trying to get it working in GSM. As soon as I plugged it in to my archlinux machine to my horror it showed a wired ethernet connection in nmcli and ethernet interface in ip link!!!!

I had even been reading posts from users online stating they were using the very same device in usb serial modem mode!

As to why I want GSM, I want to be able to use modemmanager to receive and send texts from the command line like I was with the huawei. I know you can receive them in the server via d-link control panel but I much prefer to avoid that and to not have to have this RNDIS rubbish running at all.

I found this link after some research which indicates my issues are due to having the latest A2, 2.0.2 firmware whereas a downgrade to 2.0.1 should provide the functionality I desire.

I thought it would be plain sailing after reading that but ohh noo!!!! I made a hirensbootcd vm for windows and downloaded the firmware downgraded version. Ran it and put in the dongle. It seemed to passthrough ok as the firmware output that it found the device however after a little while a popup error comes up with the message: "The modem port may have been used!" I close it and it just comes up again and again and cannot get successful flashing.

This doesn't seem to be related to linux still running the wired connection as I checked in the host and it doesn't show the wired link or interface any more so seems unrelated to it being used by the host.

I am a bit stuck now. On my research this forum seemed to keep popping up with the most related information so thought I would put my questions here in hopes of some help.

I am not sure how to overcome that error now so any help appreciated.

Uninstall ModemManager, reboot and show the output of cat /sys/kernel/debug/usb/devices

1 Like

Simply not having the ModemManager service running will suffice no? That is what I did, it was disabled when running the command.

For brevity I presume you only want the output related to the D-link device as none of the other output seemed to pertain to the stick (checked lusb before and after) which would make the code much longer unnecessarily:

D:  Ver= 2.01 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  2
P:  Vendor=2001 ProdID=7e46 Rev= 2.28
S:  Manufacturer=Mobile Connect
S:  Product=Mobile Connect
S:  SerialNumber=0123456789ABCDEF
C:* #Ifs= 3 Cfg#= 1 Atr=a0 MxPwr=500mA
A:  FirstIf#= 0 IfCount= 2 Cls=e0(wlcon) Sub=01 Prot=03
I:* If#= 0 Alt= 0 #EPs= 1 Cls=e0(wlcon) Sub=01 Prot=03 Driver=rndis_host
E:  Ad=82(I) Atr=03(Int.) MxPS=   8 Ivl=32ms
I:* If#= 1 Alt= 0 #EPs= 2 Cls=0a(data ) Sub=00 Prot=00 Driver=rndis_host
E:  Ad=81(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=01(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
I:* If#= 2 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage
E:  Ad=83(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=02(O) Atr=02(Bulk) MxPS= 512 Ivl=125us
C:  #Ifs= 3 Cfg#= 2 Atr=a0 MxPwr=500mA
I:  If#= 0 Alt= 0 #EPs= 1 Cls=02(comm.) Sub=06 Prot=00 Driver=
E:  Ad=82(I) Atr=03(Int.) MxPS=  16 Ivl=32ms
I:  If#= 1 Alt= 0 #EPs= 0 Cls=0a(data ) Sub=00 Prot=00 Driver=
I:  If#= 1 Alt= 1 #EPs= 2 Cls=0a(data ) Sub=00 Prot=00 Driver=
E:  Ad=81(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=01(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
I:  If#= 2 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=
E:  Ad=83(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=02(O) Atr=02(Bulk) MxPS= 512 Ivl=125us

I have a few more days to be able to get a full refund so would like to figure out whether or not I can get it working before that time elapses so if not I could return and get a different device.

This is different from what we have seen before. Probably another new hw revision?
Your modem has two configurations, and neither of them has a serial port.
I suggest to get rid of it.


Look in the link. That is from this same forum and they discuss this exact issue. Specifically @tsjk notes that downgrading the firmware makes the RNDIS vanish.

It seems I just have to successfully be able to flash it which I have been unable to do so far. The firmware versions are just the same as mine which are discussed in that thread.

I only tried on windows vms so far so I may try on my mother's windows machine instead.

Btw do you recommend another 4g dongle which works nicely with linux in usbserial mode?

On my initial research it seemed most require some tweaking to get going, even the huaweis, which seem most popular.

Dongle, or modem ?

ZTE MF286D, and other MF28* LTE routers are cheap.

286D is faster though.

1 Like

If you really need a dongle then see Please recommend a USB modem / dongle - #8 by AndrewZ

1 Like

Definitely a usb powered dongle. I want it for my laptop which I am running in my van so do not want anything with extra power source.

Speed not an issue. I am happy with just a mb or 2 but the 2g 0.1 mb was just too slow! As mentioned I would have been happy with up to 7mb that 3g provided but they shut it down.

So just modest requirements speed wise. Main thing is it definitely works either out the box as a serial gsm device or a simple modeswitch.

Actually another consideration is that dongles seem very rare nowadays in the UK except for the second hand market. Due to paranoia/security if it was hacked somehow, seems over the top I guess but that is just me :stuck_out_tongue: I am veering away from 2nd hand and I think I have only found huawei 3372 and one other zte which I can't recall now, so more a case of picking from what is available.

What complicates matters with they seem to change the architecture regularly of devices with the same name or very subtle model name change with radically different funtionality. That was the case with this original one and noticed there are a lot of huaweis with very similar names of the 3372 family.

I don't want any hotspot stuff, less to go wrong and don't want my connection broadcast! Just the simplest 4g dongle which works for linux in GSM mode.

The more I read about RNDIS the more I disliked it. Talk of possible 0day exploits and more.

Kinda, since everything is encrypted nowadays.

I'd have picked one of the Huaweis, I've got one myself.

How do you mean? What does encryption have to do with malware being on a storage device?

Which huawei? Huawei 4G Dongle - E3372H-325 seems available to me. Is this a good one? What are all the additional numbers after. I prefer not get hotspot as I don't want signal broadcast as I said. Wondering if the H stands for that, have to check.

The Huawei HiLink web interface providing a convenient way to connect with the minimum of hassle.

This is somewhat concerning. Web interface indicates a server setup and perhaps another one of the RNDIS rubbish?

If you use Openwrt/Linux, don't mount it ?

No idea, I'm not home atm, probably an E3276.

Forgive me for being obtuse but not following where then encryption part comes in re mounting or not?

Also I think you are right about the hardware change as I tried it without using a vm, rather booting a usb into hirensbootcd and still the same error.

Perhaps the modem device the flashing program is throwing the error for no longer exists at all!

Given up and issued a refund. D-Link support were beyond useless. Just some overseas person with clearly no knowledge of the technical specifics just reading from a script of common problems.

Btw how do I quote other users as other have done for me? I only see the blockquote but not to add another user's username.

Oh boy I just read that the H stands for Hilink for the e3372. Does hilink mean another dreaded RNDIS? From that thread it sounds like the classic gsm style ones are discontinued and the market seemed to turn to other tech which seems RNDIS plug and play is that right?

In that case I am probably better buying second hand after all!

So will E3372H-325 be RNDIS or no?

Encryption was about the Internet traffic, and nothing else.

What about the:

ZTE 4G Dongle - MF833U1

I did a search and some ads say it is cat4 but this one doesn't. Cat4 I am guessing is again another term for ethernet/RNDIS.

The question is whether this one is an older one with GSM functionality or they just omitted the cat4 on this ad and all these models are like that.

Been looking for a couple of hours and it is really slim pickings for new ones.

Cat4 is the theoretical top speed, all Cat4 device will have the same max speed.
Real life max thoughput is 85mbit, or so.
The previously suggested MF286D is using a Cat12 modem.

1 Like

Oh right. So is this zte MF833U1 a standard gsm one do you know with no hidden tricks like the others? :stuck_out_tongue:

I am just looking in the usb_modeswitch udev rules and ZTE MF833V, Telewell TW-LTE v2 is listed.

I guess the U in the above one taken from seller site may be a typo when they meant to put V? That would make sense since 1 is after meaning V1.

V1 not listed in the rules file though after just finishing search.

Oh actually I see it is discussed here already in same naming format. No resolution in that thread as to whether it worked or not. :slight_smile:

Or how about the Alcatel IK40V-2AALGB1 LinkKey Mobile Internet Dongle? This one benefits from being about 1/2 the price or less of other ones.

As I research more it seems like the dwm-222 might still be the best bet if I can get my hands on one of the older 2.0.1 firmware version ones.

I saw one available 2nd hand.

New I sent out a load of messages to sellers asking if they stock the old firmware.

The only other option seems to be the huawei e3372H which would require some heavy lifting to flash back down. That shorting trick sounds daunting! I even read a post earlier that said it isn't even possible to downgrade the firmware on some newer models. Sounds like the exact same case as I had with this dwm-222 I b ought.