Have I bricked my Fritz!Box 4040?

I had latest openwrt installed on it but the eth1/wan kept going down all the time so I tried to restore the Fritz!OS. During the procedure the box was found but the procedure ended with the error message "Could not recover the partition mtd1! WinError 10054".
Now, when restarting the router the info led flashes red all the time and no other leds are lit. Lan and wifi not working.
Is this fixable?

Thank you in advance for the help.

Winerror 10054 is a TCP error. Some Googling gave me this. As long as the bootloader is OK you can retry.

Thank you. I realized that DHCP does not work but if I set the IP address manually I can ping it. There's some sort of web interface interaction but the connection is refused before I reach the login page.
Haven't tried ssh yet but I cannot find any installation instructions other than those that work with a working web interface. Is there any other way to do it?

I'm pretty sure these are remnants in your browser cache, FritzBoxen do not have a web recovery method that I am aware of.

Just repeat the FTP flashing method like you did when installing OpenWrt for the first time or, if you want to return to stock, use the official AVM recovery tool (which also uses the same FTP flashing method, wrapped in an executable to guide you). From own experience, FritzBoxen are a bit impatient when it comes to flashing/recovery, you may have to try a few times.

I tried the AVM recovery tool and it was what caused this problem from the beginning. Now I cannot get it to work again, it cannot find the router.
The FTP flashing method does not work. When powering up the router the power led flashes a couple of times and then the info led flashes red all the time. And also the ftp command is missing the -q switch, maybe this in itself is a problem.
Anyways, there is a ftp server on but I cannot log on since I don't know the password. User root and my previous set password does not work.

I remember that flashing with Windows posed its own problems, most of the FTP clients not being able to properly do the necessary passive FTP method. I don't exactly remember which FTP client I used, I just remember Windows' default commandline FTP did not work for me, and that I had to go through maybe half a dozen clients to find one that works. (No such problems under Linux, where commandline ftp seems to work just fine.)

That seems right though. Recovery FTP access is only available a few seconds after powering on the router (while the power LED is flashing, IIRC), and it still was fiddly to get the timing right, to "slip in just at the right moment" and issue the necessary commands to stop it booting into the proper firmware.

Also check your computer's firewall settings. It may be helpful to temporarily disable the machine's firewall so it doesn't get in the way.

If you are indeed looking at recovery FTP, both the username and password should be adam2

(But at this point I'm really just repeating the flashing instructions to you.)

So I found a ftp client that works but it cannot connect to the router using the FTP flashing method. I just get "tnftp: Can't connect to '': No route to host" and "tnftp: Can't connect to ''".
When changing address to and trying gFTP to connect I get as far as following:

Connected to
220 ADAM2 FTP Server Ready
USER adam2
221 Password required for adam2
PASS xxxx
230 User adam2 successfully logged in
215 AVM EVA Version 1.3620 0x0 0x240D
220 Type set to BINARY
502 Command not implemented
Invalid response '5' received from server.
Disconnecting from site

Any ideas?


I of course used the ftp server I could reach on the command line instead for the graphical one and flashed the router according to the FTP flashing method. Case closed and thank you for all your help!

I'm glad it worked out in the end. Happy new year to you!

P.S.: You can mark a reply (even your own) as solution, marking the topic as solved.