Has cal_data corruption on HG556 been fixed?

Just as tittle says, previous 18.06.1 was corrupting cal_data on install, i wonder if this has been fixed on this new release

It seems not - this thread is also active:

Pity, guess im stuck with chaos calmer for life :expressionless:

Has someone created a bug report?

1 Like

Referenced on https://openwrt.org/toh/huawei/hg556a#installation -- have not checked if there is a formal bug report.

@kill_us_now Moving to at least v17 would be wise. Then again, if I were in your shoes with a 300 MHz CPU, 64 MB RAM, ancient, 2.4 GHz wireless, and only 100 Mbps Ethernet, I'd spend ~US$20 and replace it with a current device with sufficient resources for v18 and beyond.

Ah well you are right but i dont pretend to install nothing fancy like proxies or torrents on the router, i only use it as a repeater with samba for network share. Then i guess you are thinking, ¿why would i want to upgrade, then?

well, because there is some sort of bug that is stopping my ralink usb external antenna to achieve more than 1.2mb/sec of download, no matter what it wont surpass that number, so i was thinking that maybe a new version fixxed that thing.

https://openwrt.org/supported_devices/432_warning

Usability issues

Insufficient RAM for stable operation

  • 32 MB can work for minimal router/AP functions, but may repeatedly “crash”, depending on your hardware and use case

  • 64 MB may still have issues with stability, depending on your hardware and use cases

I think it likely that a minimum of 128 MB RAM will be required for stable operation within a year. v17 is effectively EOL, v18 won't be far behind.

SMB and Samba have had more than enough significant, critical security issues in the past. That alone should drive you to upgrade and to stay current.

The 300 MHz, single-core, MIPS CPU may well be at the core of that.

Yes, a new version of a router would likely fix that issue :wink:

Many opinions and recommendations in the long thread

No i dont think so, because with the internal card the download speed is as fast as it could be, the 1.2 limit with the usb card is constant, there is no spikes or such, it just stops at 1.2 no matter what. Firstly i tough it may be cause 1.1 usb limit but checking the drivers the 2.0 was installed. Anyway i could be entirely wrong in many things, my knowledge of linux and command line is basic at best :slight_smile:

Uh uh okay, copy that.

:smile: believe me wish i had the cash to toy with a new powerful router, i really love to learn command line and network configuration, but right now i have to stick with this dinosaur, that, all said, has served and is serving me at it best.